7.7 Как сделать сумму прописью в отчете с копейками?

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем Kas-tet, 5 окт 2016.

  1. TopicStarter Overlay
    Kas-tet
    Offline

    Kas-tet

    Регистрация:
    30 сен 2016
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    В документе АктКухни при печати ТН сумма прописью выводит в целых, т.е. если в таблице стоит 3.04, то пишет Три рубля, а нужно Три рубля, 4 копейки. Может кто подскажет как это сделать?
    Менял с ЧПД - на ЧПДС
    Код:
    Всего отпущено на сумму с НДС: [?(Валюта = Константа.ОсновнаяВалюта,Формат(ИтогВсего,"ЧПДС"),Формат(ИтогВсего,"ЧПДС"))]
    Вот код вывода на печать:
    Код:
    Процедура ПечатьСчПр()
       
        НомерДокПечатнойФормы = глПреобразоватьНомерДок(НомерДок, 0, 0);
       
        АдресТелефон = "";
        глДобавитьРеквизит(АдресТелефон, "Адрес: ", глПредставлениеАдреса(Константа.АдресОрганизации));
        глДобавитьРеквизит(АдресТелефон, ", тел.: ", Константа.ТелефоныОрганизации);
       
        ПоставщикРасчСчет        = "";
        ПоставщикИНН            = "";
        ПоставщикКПП            = "";
        ПоставщикБанк            = "";
        Кредит                    = "";
        ПоставщикБанкБИК        = "";
        ПоставщикБанкКорсчет    = "";
        глПлатежныеРеквизиты(Заказчик.ОсновнойСчет.ТекущийЭлемент(), ПоставщикРасчСчет, ПоставщикБанк, Кредит, ПоставщикБанкБИК, ПоставщикБанкКорсчет, ПоставщикИНН, ПоставщикКПП, 2);
       
        Плательщик1                = "";
        БанкПлательщика            = "";
        НомерСчетаПлательщика    = "";
        БИКБанкаПлательщика        = "";
        СчетБанкаПлательщика    = "";
        ИННплательщика            = "";
        глПлатежныеРеквизиты(Заказчик.ОсновнойСчет.ТекущийЭлемент(), Плательщик1, БанкПлательщика, НомерСчетаПлательщика, БИКБанкаПлательщика, СчетБанкаПлательщика, ИННплательщика,, 2);
       
        Заказчик1            = "";
        БанкЗаказчика        = "";
        НомерСчетаЗаказчика    = "";
        БИКБанкаЗаказчика    = "";
        СчетБанкаЗаказчика    = "";
        ИННЗаказчика        = "";
        глПлатежныеРеквизиты(Заказчик.ОсновнойСчет.ТекущийЭлемент(), Заказчик1, БанкЗаказчика, НомерСчетаЗаказчика, БИКБанкаЗаказчика, СчетБанкаЗаказчика, ИННЗаказчика,, 2);
       
        Таб = СоздатьОбъект("Таблица");
        Валюта = Константа.ОсновнаяВалюта; 
        Вал = Валюта.Наименование;
        ЦеныВДоговоре = 1; // в рублях
        ОплатаДоговора = 1; // в рублях
        Если ПустоеЗначение(Договор.ВалютаДоговора) = 0 Тогда
            ЦеныВДоговоре = 2; // в валюте 
            ОплатаДоговора = Договор.ОплатаДоговора;
            Валюта = Договор.ВалютаДоговора;
            Кратность = Валюта.Кратность.Получить(ДатаДок);
            Кратность = ?(Кратность=0, 1, Кратность);
            Если (ОплатаДоговора = 2)  Тогда
                Вал = Договор.ВалютаДоговора.Наименование;
                Если ПустоеЗначение(Договор.ВалютаДоговора.ИмяФайлаПрописи) = 1 Тогда
                    Предупреждение("Для выбранной валюты не указан файл прописи.");
                Иначе
                    Пропись(Договор.ВалютаДоговора.ИмяФайлаПрописи);
                КонецЕсли;
            Иначе
                Пропись("");
            КонецЕсли;
        КонецЕсли;
       
        ИмяФайлаПечатнойФормы = КаталогИБ()+"ExtForms\PrnForms\1cbs.mxl";
        Если ФС.СуществуетФайл(ИмяФайлаПечатнойФормы) = 1 Тогда
            Таб.ИсходнаяТаблица(ИмяФайлаПечатнойФормы);  
           
        ИначеЕсли НомерТекущейФормы = 7  Тогда
            Таб.ИсходнаяТаблица("Счет");
       
        ИначеЕсли (НомерТекущейФормы = 9) Тогда
            Таб.ИсходнаяТаблица("Протокол");
       
        ИначеЕсли (НомерТекущейФормы = 8) Тогда
            Таб.ИсходнаяТаблица("СчетПротокол");
       
        КонецЕсли; 
       
        Таб.ВывестиСекцию("Шапка");
        ВыбратьСтроки();
        Ном = 0;
        Пока ПолучитьСтроку() = 1 Цикл
            Ном = Ном + 1;
            СтавкаНДС = Товар.СтавкаНДС.Получить(ДатаДок).Ставка;
            Наименование = ?(ПустаяСтрока(Товар.ПолнНаименование) = 1, Товар.Наименование, Товар.ПолнНаименование);
           
            ПечЦена        = ФРМ(ЦенаСНаценкой);
            ПечСумма    = ФРМ(Сумма);
            ПечНДС        = ФРМ(НДС);
            ПечВсего    = ФРМ(Всего);
           
            Если Товар.ЦенаИзготовителя = 0 Тогда             
                ПечЦенаИзготовителя = ФРМ(ЦенаСНаценкой);
                Если ПустоеЗначение(Константа.ПечатьОптовойНадбавки) = 0 Тогда
                    ОптоваяНадбавка = СокрЛП(Константа.ПечатьОптовойНадбавки);
                Иначе   
                    ОптоваяНадбавка = "0%";
                КонецЕсли;   
            Иначе
                ОптПроц = (Цена - Товар.ЦенаИзготовителя) / Товар.ЦенаИзготовителя * 100;
                ОптПроц = Окр(ОптПроц, 1, 1);
                ОптоваяНадбавка = "" + ОптПроц + "%";
                Если ОптПроц > 20 Тогда
                    Сигнал();
                    Предупреждение ("Оптовая надбавка по товару: " + Товар + " больше 20 %", 0);
                КонецЕсли;
                ПечЦенаИзготовителя = ФРМ(Товар.ЦенаИзготовителя);
            КонецЕсли;
           
            СтНДС = ПолучитьПустоеЗначение("Справочник.Ставки"+НДС);
            Если ВариантРасчетаНалогов.Выбран() = 1 Тогда
                Если ПустоеЗначение(ВариантРасчетаНалогов) = 0 Тогда // выбран вариант
                    СтНДС = ВариантРасчетаНалогов.СтавкаНДС;
                КонецЕсли;
            КонецЕсли;
           
            Если ПустоеЗначение(СтНДС) = 1 Тогда // поиск в номенклатуре
                Если Товар.Выбран() = 1 Тогда
                    СтНДС = Товар.СтавкаНДС.Получить(ДатаДок);
                Иначе
                    СтНДС = глЗначениеПоУмолчанию("ОсновнаяСтавка" + НДС);
                КонецЕсли;
            КонецЕсли;
           
    //        Если НДС = 0 Тогда
    //            СтНДС = "";
    //        КонецЕсли;
    
            Таб.ВывестиСекцию("Строка");
    
        КонецЦикла;
       
        ПечИтогСумма    = ФРМ(Итог("Сумма"));
        ПечИтогНДС        = ФРМ(Итог("НДС"));
        ПечИтогВсего    = ФРМ(Итог("Всего"));
        Таб.ВывестиСекцию("Итого");
       
        ПрописьИтогСумма= ФРМП(Итог("Сумма"));
        ПрописьИтогНДС    = ФРМП(Итог("НДС"));
        ПрописьИтогВсего= ФРМП(Итог("Всего"));
       
        Таб.ВывестиСекцию("Подвал"); 
       
        Если (НомерТекущейФормы = 8) Тогда
           
            Таб.ВывестиСекцию("ШапкаП");
           
            ВыбратьСтроки();
            Ном = 0;
            Пока ПолучитьСтроку() = 1 Цикл
                Ном = Ном + 1;
                СтавкаНДС = Товар.СтавкаНДС.Получить(ДатаДок).Ставка;
                Наименование = ?(ПустаяСтрока(Товар.ПолнНаименование) = 1, Товар.Наименование, Товар.ПолнНаименование);
               
                ПечЦена    = ФРМ(ЦенаСНаценкой);
                ПечСумма= ФРМ(Сумма);
                ПечНДС    = ФРМ(НДС);
                ПечВсего= ФРМ(Всего);
                Если Товар.ЦенаИзготовителя = 0 Тогда
                    ПечЦенаИзготовителя = ФРМ(ЦенаСНаценкой);
                    Если ПустоеЗначение(Константа.ПечатьОптовойНадбавки) = 0 Тогда
                        ОптоваяНадбавка = СокрЛП(Константа.ПечатьОптовойНадбавки);
                    Иначе   
                        ОптоваяНадбавка = "0%";
                    КонецЕсли;   
                Иначе
                    ОптПроц = (Цена - Товар.ЦенаИзготовителя) / Товар.ЦенаИзготовителя * 100;
                    ОптПроц = Окр(ОптПроц, 1, 1);
                    ОптоваяНадбавка = "" + ОптПроц + "%";
                    Если ОптПроц > 20 Тогда
                        Сигнал();
                        Предупреждение("Оптовая надбавка по товару: " + Товар + " больше 20 %", 0);
                    КонецЕсли;
                    ПечЦенаИзготовителя = ФРМ(Товар.ЦенаИзготовителя);
                КонецЕсли;
               
                Таб.ВывестиСекцию("СтрокаП");
           
            КонецЦикла;
           
            Таб.ВывестиСекцию("ИтогоП");
            Таб.ВывестиСекцию("ПодвалП");
       
        КонецЕсли;
       
        Таб.Опции(0, 0, 0, 0, "ОпцииПечатиСчета", "ОкноСчета");
        Таб.ТолькоПросмотр(1);
        Таб.Показать("Печать счета", "");
    
    КонецПроцедуры //  ПечатьСчПр()
  2. 1с-ник
    Offline

    1с-ник Профессионал в 1С

    Регистрация:
    5 окт 2014
    Сообщения:
    304
    Симпатии:
    49
    Баллы:
    54
    Странно, но у меня работает приведенный выше код:
    Код:
    Формат(Итог("Всего"), "ЧПДС")
    Kas-tet нравится это.
  3. TopicStarter Overlay
    Kas-tet
    Offline

    Kas-tet

    Регистрация:
    30 сен 2016
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    Пробовал, не помогает...хотя, это где должно быть прописано, может я не там менял?
  4. 1с-ник
    Offline

    1с-ник Профессионал в 1С

    Регистрация:
    5 окт 2014
    Сообщения:
    304
    Симпатии:
    49
    Баллы:
    54
    Вообще я не спец в 7.7, просто открыл имеющуюся конфу и глянул вывод суммы прописью.
    "Судя гуглу", то некоторые рекомендуют указать файл прописи. СП:
    Код:
    Пропись(<?>);
    Синтаксис:
    Пропись(<Параметр>)
    Назначение:
    Задать образец вывода чисел прописью.
    Параметры:
    <Параметр> - строка, содержащая имя файла с прописью (если в параметре передано '''' (пустая строка), то устанавливается пропись по умолчанию) или объект типа ''СписокЗначений'', в котором лежат строки, структура которых совпадает со структурой файла прописей - там тоже двухуровневая структура, порядок строк тоже такой же.
    Подробнее см. в документации, глава ''Системные процедуры и функции''
    Kas-tet нравится это.
  5. TopicStarter Overlay
    Kas-tet
    Offline

    Kas-tet

    Регистрация:
    30 сен 2016
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    Я это смотрел, только так и не понял что в скобкахдолжно быть Пропись("")
  6. 1с-ник
    Offline

    1с-ник Профессионал в 1С

    Регистрация:
    5 окт 2014
    Сообщения:
    304
    Симпатии:
    49
    Баллы:
    54
    Вот эта компонента, у меня она в папке с конфигурацией. Можно блокнотом открыть и глянуть что там)
    --- Объединение сообщений, 5 окт 2016 ---
    Полный путь к компоненте
    --- Объединение сообщений, 5 окт 2016 ---
    Код:
    {"Speller",
    {"Money",
    {"Рубль","Рубля","Рублей","Копейка","Копейки","Копеек","M"}},
    {"Numbers",
    {"Один","Два","Три","Четыре","Пять","Шесть","Семь","Восемь","Девять","Одна","Две",
    "Десять","Одиннадцать","Двенадцать","Тринадцать","Четырнадцать","Пятнадцать","Шестнадцать","Семнадцать","Восемнадцать","Девятнадцать",
    "Двадцать","Тридцать","Сорок","Пятьдесят","Шестьдесят","Семьдесят","Восемьдесят","Девяносто",
    "Сто","Двести","Триста","Четыреста","Пятьсот","Шестьсот","Семьсот","Восемьсот","Девятьсот",
    "Тысяча","Тысячи","Тысяч",
    "Миллион","Миллиона","Миллионов",
    "Миллиард","Миллиарда","Миллиардов",
    "Триллион","Триллиона","Триллионов",
    "Ноль"}},
    {"Date",
    {"Январь","Февраль","Март","Апрель","Май","Июнь","Июль","Август","Сентябрь","Октябрь","Ноябрь","Декабрь",
    "Января","Февраля","Марта","Апреля","Мая","Июня","Июля","Августа","Сентября","Октября","Ноября","Декабря",
    "г.","Квартал"}},
    {"DateRange",
    {"Полугодие","Месяцев"}},
    {"WeekDay",
    {"Понедельник","Вторник","Среда","Четверг","Пятница","Суббота","Воскресенье"}}
    }
    Формат(Итог("Всего"), "ЧПДС") обращается к этой компоненте

    Вложения:

    • 1CV7.7z
      Размер файла:
      576 байт
      Просмотров:
      1
    Kas-tet нравится это.
  7. TopicStarter Overlay
    Kas-tet
    Offline

    Kas-tet

    Регистрация:
    30 сен 2016
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    У меня есть эта компонента, прописано в ней тоже самое...
  8. 1с-ник
    Offline

    1с-ник Профессионал в 1С

    Регистрация:
    5 окт 2014
    Сообщения:
    304
    Симпатии:
    49
    Баллы:
    54
    Ну попробуй тогда перед вызовом Формат() указывать путь к этой компоненте:
    Код:
    Пропись("С:\1с77\Bin\1CV7.SPL");
  9. TopicStarter Overlay
    Kas-tet
    Offline

    Kas-tet

    Регистрация:
    30 сен 2016
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    Вот весь код, я уже понаизменял что не знаю где надо было а где нет, может подскажешь где что и как?

    Код:
    Функция ИтоговаяСтрока()
      
        ИтСтр = "Итого реализовано на сумму: " + СокрЛ(Формат(Итог("Всего"),"Ч20.2,")) + "," +
        "в т.ч. НДС: " + СокрЛ(Формат(Итог("НДС"),"Ч20.2,"));
        Если Итог("НП") > 0 Тогда
            ИтСтр = ИтСтр + ", НП: " + СокрЛ(Формат(Итог("НП"),"Ч20.2-,"));
        КонецЕсли;
      
        Возврат ИтСтр;
    
    КонецФункции // ИтоговаяСтрока()
    
    //******************************************************************************
    
    Функция ФРМ(ЧислЗнач)
      
        РезСтрока = СокрЛ(Формат(ЧислЗнач, "Ч015.2.'"));
        Возврат РезСтрока;
    
    КонецФункции // ФРМ()
    
    //******************************************************************************
    
    Функция ФРМП(ЧислЗнач)
      
        Валюта = Константа.ОсновнаяВалюта;
        Вал = Валюта.Наименование;
        ЦеныВДоговоре = 1; // в рублях
        ОплатаДоговора = 1; // в рублях
        РезСтрока = СокрЛ(Формат(ЧислЗнач, "ЧПДC"));
        Пропись("D:\1Cv77\1c\1CV7.SPL");
      
        Возврат РезСтрока;
    
    КонецФункции // ФРМП()
    
    //******************************************************************************
    
    Процедура ПроверкаНомТекФормы()
      
        Если (НомерТекущейФормы = 6) Тогда
            Сприлож = 1;
            Т=СоздатьОбъект("Таблица");
            Если НомерТекущейФормы = 2 Тогда
                Т.ИсходнаяТаблица("ТН2");
                Если ТТНновые = 1 Тогда
                    Т.ИсходнаяТаблица("ТН-2");  
                КонецЕсли;
                Т.ПараметрыСтраницы(1,100,0,5,5,5,5,,,);
            Иначе   
                Т.ИсходнаяТаблица("ТТН_ГГГ");
                Если ТТНновые = 1 Тогда
                    Т.ИсходнаяТаблица("ТНН-1");  
                КонецЕсли;
                Если НомерТекущейФормы = 4 Тогда
                    Т.ПараметрыСтраницы(2,100,0,5,5,5,0,,,);
                Иначе
                    Т.ПараметрыСтраницы(1,,0,5,5,5,5,,,1);
                КонецЕсли;
            КонецЕсли;   
            Т.ВывестиСекцию("Приложение");
            Т.ВывестиСекцию("ШапкаС");
        КонецЕсли;           
    
    КонецПроцедуры // ПроверкаНомТекФормы()
    
    //******************************************************************************
    
    Процедура Печать()    
      
        Если ТекущийДокумент().Выбран() = 0 Тогда
            Если Вопрос("Перед печатью документ необходимо провести.
            |Провести документ?",4) = 6 Тогда
                Записать();
                Провести();
            Иначе
                Возврат;
            КонецЕсли;
        КонецЕсли;
      
        Если ТекущийДокумент().Проведен() = 0 Тогда
            Если Вопрос("Перед печатью документ необходимо провести.
            |Провести документ?",4) = 6 Тогда
                Провести();
            Иначе
                Возврат;
            КонецЕсли;
        КонецЕсли;
      
        Если Модифицированность() = 1 Тогда
            Если Вопрос("Документ был изменен.
            |Провести документ?",4) = 6 Тогда
                Провести();
            Иначе
                Возврат;
            КонецЕсли;
        КонецЕсли;
      
        НомерДокПечатнойФормы = глПреобразоватьНомерДок(НомерДок, 0, 0);
        Таб = СоздатьОбъект("Таблица");
        Если (НомерТекущейФормы = 1) или (НомерТекущейФормы = 2) Тогда
            Таб.ИсходнаяТаблица("ТН2");
            Таб.ПараметрыСтраницы(1,100,0,5,5,5,5,,,1);
        ИначеЕсли (НомерТекущейФормы = 3) или (НомерТекущейФормы = 4)  Тогда
            Таб.ИсходнаяТаблица("ТТН_ГГГ");
            Таб.ПараметрыСтраницы(2,100,0,5,5,5,0,,,1);
        ИначеЕсли (НомерТекущейФормы = 5) или (НомерТекущейФормы = 6)  Тогда
            Таб.ИсходнаяТаблица("ТТН_В");
            Таб.ПараметрыСтраницы(1,,0,5,5,5,5,,,1);
        КонецЕсли;
      
        ЛицензияО             = Сокрлп(Константа.Лицензия.Получить(ДатаДок));
        Если ПустоеЗначение(Заказчик) = 0 Тогда
            ЗаказчикСтр    = СокрЛП(Заказчик.ПолнНаименование)+", адрес: "+СокрЛП(Контрагент.ПочтовыйАдрес)+", Р/сч:"+СокрЛП(Заказчик.ОсновнойСчет.Номер)+" в "+СокрЛП(Заказчик.ОсновнойСчет.БанкОрганизации)+" код "+СокрЛП(Заказчик.ОсновнойСчет.БанкОрганизации.Код)+", адрес: "+СокрЛП(Заказчик.ОсновнойСчет.БанкОрганизации.Местонахождение)+",   УНН: "+СокрЛП(Заказчик.ИНН)+", ОКПО: "+СокрЛП(Заказчик.КодОКПО)+" "+СокрЛП(Заказчик.Лицензия.Получить(ДатаДок));
        Иначе
            ЗаказчикСтр    = СокрЛП(Константа.НазваниеОрганизации)+", Р/сч:"+СокрЛП(Константа.ОсновнойБанковскийСчет.Номер)+" в "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации)+" код "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации.Код)+", адрес: "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации.Местонахождение)+",   УНН: "+СокрЛП(Константа.ИННОрганизации)+", ОКПО: "+Константа.КодОКПО+" "+СокрЛП(ЛицензияО);  
        КонецЕсли;
      
        ГрузоотправительСтр    = СокрЛП(Константа.НазваниеОрганизации)+", "+СокрЛП(Кухня)+" "+СокрЛП(Кухня.Адрес)+" , Р/сч:"+СокрЛП(Константа.ОсновнойБанковскийСчет.Номер)+" в "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации)+" код "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации.Код)+", адрес: "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации.Местонахождение)+",   УНН: "+СокрЛП(Константа.ИННОрганизации)+", ОКПО: "+СокрЛП(Константа.КодОКПО)+" "+ЛицензияО;
      
        Если ВнутреннееПеремещение = 1 Тогда
            ГрузополучательСтр    = СокрЛП(Константа.НазваниеОрганизации)+", "+СокрЛП(МестоРеализации)
                                +", адрес: "+СокрЛП(МестоРеализации.Адрес)+" , Р/сч:"+СокрЛП(Константа.ОсновнойБанковскийСчет.Номер)
                                +" в "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации)
                                +" код "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации.Код)
                                +", адрес: "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации.Местонахождение)
                                +",   УНН: "+СокрЛП(Константа.ИННОрганизации)+", ОКПО: "+СокрЛП(Константа.КодОКПО)+" "+ЛицензияО;  
        Иначе
            ГрузополучательСтр    = СокрЛП(Контрагент.ПолнНаименование)
                                +" "+СокрЛП(Контрагент.ПочтовыйАдрес)+" , Р/сч:"+СокрЛП(Контрагент.ОсновнойСчет.Номер)
                                +" в "+СокрЛП(Контрагент.ОсновнойСчет.БанкОрганизации)
                                +" код "+СокрЛП(Контрагент.ОсновнойСчет.БанкОрганизации.Код)
                                +", адрес: "+СокрЛП(Контрагент.ОсновнойСчет.БанкОрганизации.Местонахождение)
                                +", УНН: "+СокрЛП(Контрагент.ИНН)+", ОКПО: "+СокрЛП(Контрагент.КодОКПО)+" "+СокрЛП(Контрагент.Лицензия.Получить(ДатаДок));
        КонецЕсли;
      
        КонтрТН    = (СокрЛП(Константа.НазваниеОрганизации))+", "+(СокрЛП(МестоРеализации))+", адрес: "+(СокрЛП(МестоРеализации.Адрес));                  
        Если ПустоеЗначение(Контрагент) = 0 Тогда
            Если Контрагент <> Константа.КонтрагентМы Тогда
                КонтрТН    = (СокрЛП(Контрагент.ПолнНаименование))+", адрес: "+(СокрЛП(Контрагент.ПочтовыйАдрес));  
            КонецЕсли;
        КонецЕсли;                  
                          
        Лицензия     = Сокрлп(Константа.Лицензия.Получить(ДатаДок));
        ЛицензияК     = Сокрлп(Контрагент.Лицензия.Получить(ДатаДок));
        ЛицензияЗ     = Сокрлп(Заказчик.Лицензия.Получить(ДатаДок));
        Довер        = "";
        Если ПустоеЗначение(ДовНом) = 0 Тогда
            Довер="доверенность № "+ДовНом+" от  "+ДовДата;
        КонецЕсли;
      
        Сприлож         = 0;
        Валюта             = Константа.ОсновнаяВалюта;
        Вал             = Валюта.Наименование;
        ЦеныВДоговоре     = 1; // в рублях
        ОплатаДоговора     = 1; // в рублях
        Если ПустоеЗначение(Договор.ВалютаДоговора) = 0 Тогда
            ЦеныВДоговоре     = 2; // в валюте
            ОплатаДоговора     = Договор.ОплатаДоговора;
            Валюта             = Договор.ВалютаДоговора;
            Кратность         = Валюта.Кратность.Получить(ДатаДок);
            Кратность         = ?(Кратность=0, 1, Кратность);
            Если (ОплатаДоговора = 2)  Тогда
                Вал = Валюта.Наименование;
                Если ПустоеЗначение(Валюта.ИмяФайлаПрописи) = 1 Тогда
                    Предупреждение("Для выбранной валюты не указан файл прописи.");
                Иначе
                    Пропись(Валюта.ИмяФайлаПрописи);
                КонецЕсли;
            Иначе
                Пропись("D:\1Cv77\1c\1CV7.SPL");
            КонецЕсли;
        КонецЕсли;
        Ном = 0;
        ПроверкаНомТекФормы();
        ИтогВсегоПроизводства = 0;
      
        Если ПечатьЦеныПроизводства = 1 Тогда
            Если (НомерТекущейФормы = 5) или (НомерТекущейФормы = 6) Тогда
                Таб.ВывестиСекцию("Шапка");
            Иначе
                Таб.ВывестиСекцию("ШапкаСЦП");  
            КонецЕсли;
        Иначе
            Таб.ВывестиСекцию("Шапка");
        КонецЕсли;
      
        ВыбратьСтроки();
        Пока ПолучитьСтроку()=1 Цикл
            Ном = Ном + 1;
            МЦ = ?(ПустоеЗначение(Товар.ПолнНаименование) = 0,Товар.ПолнНаименование,Товар.Наименование) ;
            Код = Товар.Код; 
            Выход = Товар.Калькуляция.Получить(ДатаДок).ВыходБлюда;
    //
    // ***** 04.11.2009 *****
    //  В чём разница ???
    //
    //        Если ПечатьЦеныПроизводства = 1 Тогда
    //            МЦ    = СокрЛП(МЦ) + " (" + СокрЛП(Выход) + " гр.)"
    //        Иначе
                МЦ    = СокрЛП(МЦ) + " (" + СокрЛП(Выход) + " гр.)";
    //        КонецЕсли;
    //
    // ***** evm *****      
    //      
            ЕдиницаИзмерения = Товар.ЕдиницаИзмерения;
            ЕдиницаИзмеренияКод = ЕдиницаИзмерения.Код;
            Если ((ЦеныВДоговоре = 2) и (ОплатаДоговора = 1))  Тогда
                ПечЦена     = ЦенаСНаценкой;
                СуммаБезНДС = СуммаПродажи;
                СуммаНДС     = НДС;
                ПечВсего     = Всего;
            Иначе
                ПечЦена     =  ЦенаСНаценкой;
                СуммаБезНДС =  СуммаПродажи;
                СуммаНДС     =  НДС;
                ПечВсего     =  Всего;  
                Если  ДатаДок < Дата(2005,08,01) Тогда
                    ПечЦенаПроизводства = Окр((Товар.Себестоимость.Получить(ДатаДок)*Константа.НаценкаПроизводства.Получить(ДатаДок)+Товар.СебестоимостьХлеба.Получить(ДатаДок))*коэффициент,2);
                Иначе
                    ПечЦенаПроизводства = ЦенаПроизводства;
                КонецЕсли;  
                ПечВсегоПроизводства = ПечЦенаПроизводства*Количество;
            КонецЕсли;  
          
            СтНДС = ПолучитьПустоеЗначение("Справочник.Ставки"+НДС);
            Если ВариантРасчетаНалогов.Выбран() = 1 Тогда
                Если ПустоеЗначение(ВариантРасчетаНалогов) = 0 Тогда // выбран вариант
                    СтНДС = ВариантРасчетаНалогов.СтавкаНДС;
                КонецЕсли;
            КонецЕсли;
          
            Если ПустоеЗначение(СтНДС)= 1 Тогда // поиск в номенклатуре
                Если Товар.Выбран() = 1 Тогда
                    СтНДС = Товар.СтавкаНДС.Получить(ДатаДок);
                Иначе
                    СтНДС = глЗначениеПоУмолчанию("ОсновнаяСтавка"+НДС);
                КонецЕсли;
            КонецЕсли;
            СтНДС = Константа.НДСПроизводства.Получить(ДатаДок);
          
          
            Если (ОплатаДоговора = 2) Тогда
                Если ПустоеЗначение(Константа.ПечатьОптовойНадбавки) = 0 Тогда
                    ОптоваяНадбавка = СОКРЛП(Константа.ПечатьОптовойНадбавки);
                Иначе  
                    ОптоваяНадбавка = "0%";
                КонецЕсли;   
            Иначе   
                ОптПроц         = 0;
                ОптоваяНадбавка = Строка(ОптПроц)+"%";
                ПечЦена         = ЦенаСНаценкой;
            КонецЕсли;
          
            Если Сприлож = 1 Тогда
                Если ПечатьЦеныПроизводства = 1 Тогда
                    Т.ВывестиСекцию("СтрокаСЦП");
                Иначе  
                    Т.ВывестиСекцию("Строка");                                       
                КонецЕсли;
                Если (ПустаяСтрока(СтрП) = 0)Тогда
                    Т.ВывестиСекцию("Всоставе");
                КонецЕсли;
            Иначе
                Если ПечатьЦеныПроизводства = 1 Тогда
                    Таб.ВывестиСекцию("СтрокаСЦП");
                Иначе  
                    Таб.ВывестиСекцию("Строка");                                       
                КонецЕсли;
                Если (ПустаяСтрока(СтрП) = 0)Тогда
                    Таб.ВывестиСекцию("Всоставе");
                КонецЕсли;
            КонецЕсли; 
            ИтогВсегоПроизводства = ИтогВсегоПроизводства + ПечВсегоПроизводства;
        КонецЦикла;
      
        ИтогКоличество = Итог("Количество");
    //
    // ***** 04.11.2009 *****
    //  В чём разница ???
    //
    //    Если ((ЦеныВДоговоре = 2) и (ОплатаДоговора = 1))  Тогда
    //        ИтогСумма     = Итог("СуммаПродажи");
    //        ИтогВсего     = Итог("Всего");
    //        ИтогНДС     = Итог("НДС");
          
    //    Иначе
            ИтогСумма     =  Итог("СуммаПродажи");
            ИтогВсего     =  Итог("Всего");
            ИтогНДС     =  Итог("НДС");
    //    КонецЕсли;
    //
    // ***** evm *****      
    //      
        Если СПрилож=1 Тогда
            Таб.ВывестиСекцию("Спецификация"); 
        КонецЕсли;
      
        Если ПечатьЦеныПроизводства = 1 Тогда
            Таб.ВывестиСекцию("ПодвалСЦП");
        Иначе
            Таб.ВывестиСекцию("Подвал");
        КонецЕсли;      
      
        Если (НомерТекущейФормы = 5) или (НомерТекущейФормы = 6) или (НомерТекущейФормы = 3) или (НомерТекущейФормы = 4) Тогда
            Если (ЛистПеч = 1) Тогда
            Иначе  
                Таб.НоваяСтраница(); 
            КонецЕсли;
        КонецЕсли;
    //    Если (НомерТекущейФормы = 3) или (НомерТекущейФормы = 4) Тогда
    //        Таб.НоваяСтраница(); 
    //    КонецЕсли;
        Таб.ВывестиСекцию("Подвал2");
        Если СПрилож=1 Тогда
            Т.ВывестиСекцию("Подвал");
            Если НомерТекущейФормы <> 2 Тогда
                Т.ВывестиСекцию("ПодвалПриложение");
            КонецЕсли;  
        КонецЕсли;
        Если СПрилож=1 Тогда
            Т.Показать("Печать приложения","");  
        КонецЕсли;
        Таб.ТолькоПросмотр(1);
        Таб.Показать("Печать накладной","");
      
    КонецПроцедуры // Печать()
    
    //******************************************************************************
    
    Процедура ПечатьПриложенияПоЦенам()
    
    //    Если (ВидПеремещения = 1)или(ВидПеремещения = 4) Тогда
            Таб    = СоздатьОбъект("Таблица");
            Таб.ИсходнаяТаблица("расшифровкаПОценам");
            Таб.ВывестиСекцию("Шапка");
            ВыбратьСтроки();
          
            Валюта         = Константа.ОсновнаяВалюта;
            Вал         = Валюта.Наименование;
            Ном        = 0;
            Кол55    = 0;
            Всего55    = 0;
          
            ПечВсегоИт    = 0;
            Пока ПолучитьСтроку()=1 Цикл
                Ном = Ном + 1;
                МЦ     = ?(ПустоеЗначение(Товар.ПолнНаименование) = 0,Товар.ПолнНаименование,Товар.Наименование) ;
                Код = Товар.Код;
              
                ЕдиницаИзмерения     = Товар.ЕдиницаИзмерения;
                ЕдиницаИзмеренияКод = ЕдиницаИзмерения.Код;
                СтНДС                = "";
              
                ПечЦена         = ЦенаСНаценкой;
                КоличествоПеч     = Количество;
                СуммаБезНДС     = Всего;
              
                ОптоваяНадбавка    = 0;
                СуммаНДС        = "";
              
                КолВоПол        = Количество;
                ЦенаПол            = ЦенаПроизводства;
                СуммаПол        = ЦенаПроизводства*Количество;
                Тн                = "";
              
                Кол55    = Кол55 + КолВоПол;
                Всего55    = Всего55 + СуммаПол;
                СуммаНДС    = 0;
                ПечВсего     = Всего;
                ПечВсегоИт     = ПечВсегоИт + Всего;
                ИтогНДС        = ИтогНДС + СуммаНДС;
              
                СтНДС                = "-";
            //    СтНДС             = Константа.НДСПроизводства.Получить(ДатаДок);
                ОптоваяНадбавка = "0%";
                ВсегоПол        = СуммаПол;
                Таб.ВывестиСекцию("Строка");  
            КонецЦикла;
            Таб.ВывестиСекцию("Итого");
    //    КонецЕсли;
      
        Таб.ПараметрыСтраницы(2,,,,,,,,, 1,,);
        Таб.Опции(0, 0, 0, 0,);
        Таб.Показать();
    
    КонецПроцедуры // ПечатьПриложенияПоЦенам()
    
    
    Последнее редактирование: 5 окт 2016
  10. TopicStarter Overlay
    Kas-tet
    Offline

    Kas-tet

    Регистрация:
    30 сен 2016
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    Продолжение кода:
    Код:
    
    Процедура ПечатьТТН_В()
      
        НомерДокПечатнойФормы = глПреобразоватьНомерДок(НомерДок, 0, 0);
        Таб = СоздатьОбъект("Таблица");
        Если (НомерТекущейФормы = 5) ИЛИ (НомерТекущейФормы = 6)  Тогда
            Таб.ИсходнаяТаблица("ТТН_В");
            Если ТТНновые = 1 Тогда
                Таб.ИсходнаяТаблица("ТТН-1");  
            КонецЕсли;
            Таб.ПараметрыСтраницы(1,, 0, 15, 5, 15, 5,,, 1);
        ИначеЕсли (НомерТекущейФормы = 1) ИЛИ (НомерТекущейФормы = 2)  Тогда
            Таб.ИсходнаяТаблица("ТН-2");
            Таб.ПараметрыСтраницы(1,, 0, 15, 5, 15, 5,,, 1);
        Иначе
            Таб.ИсходнаяТаблица("ТТН_ГГГ");
            Если ТТНновые = 1 Тогда
                Таб.ИсходнаяТаблица("ТТН-1");  
            КонецЕсли;
            Таб.ПараметрыСтраницы(2, 100, 0, 5, 5, 5, 0,,, 1);
        КонецЕсли;
      
        ИтогНП        = 0;
        ЛицензияО     = Сокрлп(Константа.Лицензия.Получить(ДатаДок));
        Если ПустоеЗначение(Заказчик) = 0 Тогда
            ЗаказчикСтр    = СокрЛП(Заказчик.ПолнНаименование)+", адрес: "+СокрЛП(Контрагент.ПочтовыйАдрес)+", Р/сч:"+СокрЛП(Заказчик.ОсновнойСчет.Номер)+" в "+СокрЛП(Заказчик.ОсновнойСчет.БанкОрганизации)+" код "+СокрЛП(Заказчик.ОсновнойСчет.БанкОрганизации.Код)+", адрес: "+СокрЛП(Заказчик.ОсновнойСчет.БанкОрганизации.Местонахождение)+",   УНН: "+СокрЛП(Заказчик.ИНН)+", ОКПО: "+СокрЛП(Заказчик.КодОКПО)+" "+СокрЛП(Заказчик.Лицензия.Получить(ДатаДок));
            Если ТТНновые = 1 Тогда
                ЗаказчикСтр    = СокрЛП(Заказчик.ПолнНаименование)+", адрес: "+СокрЛП(Контрагент.ПочтовыйАдрес);
            КонецЕсли;
        Иначе
            ЗаказчикСтр    = СокрЛП(Константа.НазваниеОрганизации)+", Р/сч:"+СокрЛП(Константа.ОсновнойБанковскийСчет.Номер)+" в "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации)+" код "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации.Код)+", адрес: "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации.Местонахождение)+",   УНН: "+СокрЛП(Константа.ИННОрганизации)+", ОКПО: "+Константа.КодОКПО+" "+СокрЛП(ЛицензияО);  
            Если ТТНновые = 1 Тогда
                ЗаказчикСтр    = СокрЛП(Константа.НазваниеОрганизации) + ", "+СокрЛП(Кухня)+" "+СокрЛП(Кухня.Адрес) ;  
            КонецЕсли;
        КонецЕсли;
    //    ЗаказчикСтр            = СокрЛП(Константа.НазваниеОрганизации)+", Р/сч:"+СокрЛП(Константа.ОсновнойБанковскийСчет.Номер)+" в "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации)+" код "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации.Код)+", адрес: "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации.Местонахождение)+",   УНН: "+СокрЛП(Константа.ИННОрганизации)+", ОКПО: "+Константа.КодОКПО+" "+СокрЛП(ЛицензияО);
        ГрузоотправительСтр    = СокрЛП(Константа.НазваниеОрганизации)+", "+СокрЛП(Кухня)+" "+СокрЛП(Кухня.Адрес)+" , Р/сч:"+СокрЛП(Константа.ОсновнойБанковскийСчет.Номер)+" в "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации)+" код "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации.Код)+", адрес: "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации.Местонахождение)+",   УНН: "+СокрЛП(Константа.ИННОрганизации)+", ОКПО: "+СокрЛП(Константа.КодОКПО)+" "+ЛицензияО;
        Если ТТНновые = 1 Тогда
            ГрузоотправительСтр    = СокрЛП(Константа.НазваниеОрганизации)+", "+СокрЛП(Кухня)+" "+СокрЛП(Кухня.Адрес);
        КонецЕсли;
        Если ВнутреннееПеремещение = 1 Тогда
            ГрузополучательСтр    = СокрЛП(Константа.НазваниеОрганизации)+", "+СокрЛП(МестоРеализации)
                                +", адрес: "+СокрЛП(МестоРеализации.Адрес)+" , Р/сч:"+СокрЛП(Константа.ОсновнойБанковскийСчет.Номер)
                                +" в "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации)
                                +" код "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации.Код)
                                +", адрес: "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации.Местонахождение)
                                +",   УНН: "+СокрЛП(Константа.ИННОрганизации)+", ОКПО: "+СокрЛП(Константа.КодОКПО)+" "+ЛицензияО;  
            Если ТТНновые = 1 Тогда
                ГрузополучательСтр    = СокрЛП(Константа.НазваниеОрганизации)+", "+СокрЛП(МестоРеализации)
                                +", адрес: "+СокрЛП(МестоРеализации.Адрес) ;  
            КонецЕсли;
        Иначе
            ГрузополучательСтр    = СокрЛП(Контрагент.ПолнНаименование)
                                +" "+СокрЛП(Контрагент.ПочтовыйАдрес)+" , Р/сч:"+СокрЛП(Контрагент.ОсновнойСчет.Номер)
                                +" в "+СокрЛП(Контрагент.ОсновнойСчет.БанкОрганизации)
                                +" код "+СокрЛП(Контрагент.ОсновнойСчет.БанкОрганизации.Код)
                                +", адрес: "+СокрЛП(Контрагент.ОсновнойСчет.БанкОрганизации.Местонахождение)
                                +", УНН: "+СокрЛП(Контрагент.ИНН)+", ОКПО: "+СокрЛП(Контрагент.КодОКПО)+" "+СокрЛП(Контрагент.Лицензия.Получить(ДатаДок));
            Если ТТНновые = 1 Тогда
                ГрузополучательСтр    = СокрЛП(Контрагент.ПолнНаименование) + " " + СокрЛП(Контрагент.ПочтовыйАдрес);  
            КонецЕсли;
        КонецЕсли;
    //    ГрузополучательСтр    = СокрЛП(Константа.НазваниеОрганизации)+", "+СокрЛП(МестоРеализации)+" "+СокрЛП(МестоРеализации.Адрес)+" , Р/сч:"+СокрЛП(Константа.ОсновнойБанковскийСчет.Номер)+" в "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации)+" код "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации.Код)+", адрес: "+СокрЛП(Константа.ОсновнойБанковскийСчет.БанкОрганизации.Местонахождение)+",   УНН: "+СокрЛП(Константа.ИННОрганизации)+", ОКПО: "+СокрЛП(Константа.КодОКПО)+" "+ЛицензияО;
      
        ПунктПогрузки    = СокрЛП(Кухня.Адрес);
        ПунктРазгрузки    = СокрЛП(МестоРеализации.Адрес);    
        Цель        = ЦельПриобретения.Наименование;
        КолУпакСтр    = 0;
        Довер    = "";
        Если ПустоеЗначение(ДовНом) = 0 Тогда
            Довер    = "доверенность № "+ Сокрлп(ДовНом) + " от  " + ДовДата;
        КонецЕсли;
        Сприлож     = 0;
        Валюта         = Константа.ОсновнаяВалюта;
        Вал         = Валюта.Наименование;
        Серия        = "";
        Пропись("D:\1Cv77\1c\1CV7.SPL");
        СуммПроизводства    = 0;
        Ном = 0;
        ПроверкаНомТекФормы();
      
        ИтогНДС    = 0;
      
        ПечатьЦеныПр        = ПечатьЦеныПроизводства;
        СуммПроизводства    = 0;
        КвоПорций            = 1;
       
        Если ТТНновые = 1 Тогда
            Таб.ВывестиСекцию("ШапкаВн");  
        Иначе
            Таб.ВывестиСекцию("Шапка");
        КонецЕсли;
      
        ВыбратьСтроки();
        Пока ПолучитьСтроку() = 1 Цикл
          
            Примечание    = "";
            Если Товар.КоэффКг <> 0 Тогда
                Масса    = Окр(Товар.КоэффКг * Количество / 1000, 4, 1);  
            КонецЕсли;
            Ном     = Ном + 1;
            МЦ         = ?(ПустоеЗначение(Товар.ПолнНаименование) = 0, Товар.ПолнНаименование, Товар.Наименование);
            Код     = Товар.Код; 
            Выход    = Товар.Калькуляция.Получить(ДатаДок).ВыходБлюда;
          
    //
    // ***** 04.11.2009 *****
    //  В чём разница ???
    //
    //        Если ПечатьЦеныПроизводства = 1 Тогда
    //            МЦ = СокрЛП(МЦ) + " (" + СокрЛП(Выход) + " гр.)"
    //        Иначе
                МЦ = СокрЛП(МЦ) + " (" + СокрЛП(Выход) + " гр.)" ;
    //    КонецЕсли;
    //
    // ***** evm *****      
    //      
            ЕдиницаИзмерения = Товар.ЕдиницаИзмерения;
            ЕдиницаИзмеренияКод = ЕдиницаИзмерения.Код;
    
    //        Если ((ЦеныВДоговоре = 2) И (ОплатаДоговора = 1)) Тогда
    //            ПечЦена     = ЦенаСНаценкой;
    //            СуммаБезНДС = СуммаПродажи;
    //            СуммаНДС     = НДС;
    //            ПечВсего     = Всего;
    //        Иначе
                ПечЦена     =  ЦенаСНаценкой;
                СуммаБезНДС =  СуммаПродажи;
                СуммаНДС     =  НДС;
                ПечВсего     =  Всего;  
              
                Если  ДатаДок < Дата(2005,08,01) Тогда
                    ПечЦенаПроизводства = Окр((Товар.Себестоимость.Получить(ДатаДок)*Константа.НаценкаПроизводства.Получить(ДатаДок)+Товар.СебестоимостьХлеба.Получить(ДатаДок))*коэффициент,2);
                Иначе
                    ПечЦенаПроизводства = ЦенаПроизводства;
                КонецЕсли;  
              
                ПечВсегоПроизводства = ПечЦенаПроизводства * Количество;
    //        КонецЕсли;  
          
            СтНДС = ПолучитьПустоеЗначение("Справочник.Ставки" + НДС);
            Если ВариантРасчетаНалогов.Выбран() = 1 Тогда
                Если ПустоеЗначение(ВариантРасчетаНалогов) = 0 Тогда // выбран вариант
                    СтНДС = ВариантРасчетаНалогов.СтавкаНДС;
                КонецЕсли;
            КонецЕсли;
          
            Если ПустоеЗначение(СтНДС)= 1 Тогда // поиск в номенклатуре
                Если Товар.Выбран() = 1 Тогда
                    СтНДС = Товар.СтавкаНДС.Получить(ДатаДок);
                Иначе
                    СтНДС = глЗначениеПоУмолчанию("ОсновнаяСтавка"+НДС);
                КонецЕсли;
            КонецЕсли;
            СтНДС = Константа.НДСПроизводства.Получить(ДатаДок);
            КоличествоПеч     = Количество;
          
    //        Если (ОплатаДоговора = 2) Тогда
    //            Если ПустоеЗначение(Константа.ПечатьОптовойНадбавки) = 0 Тогда
    //                ОптоваяНадбавка = СОКРЛП(Константа.ПечатьОптовойНадбавки);
    //            Иначе  
    //                ОптоваяНадбавка = "0%";
    //            КонецЕсли;   
    //        Иначе   
                ОптПроц         = 0;
                ОптоваяНадбавка = Строка(ОптПроц) + "%";
                ПечЦена         = ЦенаСНаценкой;
    //        КонецЕсли;
          
            Если Сприлож = 1 Тогда
                    Т.ВывестиСекцию("Строка");                                       
                Если (ПустаяСтрока(СтрП) = 0)Тогда
                    Т.ВывестиСекцию("Всоставе");
                КонецЕсли;
            Иначе
                    Таб.ВывестиСекцию("Строка");                                       
                Если (ПустаяСтрока(СтрП) = 0)Тогда
                    Таб.ВывестиСекцию("Всоставе");
                КонецЕсли;
            КонецЕсли; 
            ИтогВсегоПроизводства = ИтогВсегоПроизводства + ПечВсегоПроизводства;
            СуммПроизводства = СуммПроизводства + ЦенаПроизводства * Количество * КвоПорций;
        КонецЦикла;
      
        ИтогКоличество = Итог("Количество");
    //    Если ((ЦеныВДоговоре = 2) и (ОплатаДоговора = 1))  Тогда
    //        ИтогСумма     = Итог("СуммаПродажи");
    //        ИтогВсего     = Итог("Всего");
    //        ИтогНДС     = Итог("НДС");
    //  
    //    Иначе
            ИтогСумма     =  Итог("СуммаПродажи");
            ИтогВсего     =  Итог("Всего");
            ИтогНДС     =  Итог("НДС");
    //    КонецЕсли;
      
        Если СПрилож = 1 Тогда
            Таб.ВывестиСекцию("Спецификация"); 
        КонецЕсли;
      
        Таб.ВывестиСекцию("Подвал");
      
        Если СПрилож = 0 Тогда
            Если ЛистПеч = 1 Тогда
            Иначе
                Таб.НоваяСтраница();  
            КонецЕсли;
        КонецЕсли; 
      
        Если ТТНновые = 0 Тогда
            Если НомерТекущейФормы <> 1 Тогда
                Таб.ВывестиСекцию("Подвал2");
            КонецЕсли;
        Иначе
            Таб.ВывестиСекцию("Подвал2");
        КонецЕсли;
      
        Если СПрилож = 1 Тогда
            Т.ВывестиСекцию("Подвал");
            Если НомерТекущейФормы <> 3 Тогда
                Т.ВывестиСекцию("ПодвалПриложение");
            КонецЕсли;
        КонецЕсли;
      
        Если СПрилож = 1 Тогда
            Т.Показать("Печать приложения","");
        КонецЕсли;
      
    //    Таб.Опции(0, 0, ?(Проведен() = 0, 1, 0), 0, "ОпцииПечатиМ15", "ОкноМ15");
        Таб.ТолькоПросмотр(1);
        Таб.Показать("Печать накладной","");
        Если ПечатьЦеныПроизводства = 1 Тогда
            ПечатьПриложенияПоЦенам();  
        КонецЕсли;
    
    КонецПроцедуры // ПечатьТТН_В()
    
    //******************************************************************************
    
    Процедура ПечатьМеню(номформы)
      
        Заполнитель = "....................................................................................................";
        Таб = СоздатьОбъект("Таблица");
        Таб.ИсходнаяТаблица("Меню");
      
        Таб.ВывестиСекцию("Шапка");
        Таб.ВывестиСекцию("Группа1");
      
        Ном = 0;
        Итого = 0;
        ВыбратьСтроки();
        Пока ПолучитьСтроку() = 1 Цикл
            Вес = СокрЛП(Товар.Калькуляция.Получить(ДатаДок).ВыходБлюда);
            Вес = ?(ПустоеЗначение(Вес) = 0, " (" + Вес + " гр.) ", " " + Заполнитель);
    //        СтрокаНаименование = "" + Спр.Наименование + ЕдИзм + Вес;
            СтрокаНаименование = "" + Товар.Наименование;
            Ном = Ном + 1;
            Таб.ВывестиСекцию("Строка");
            Итого = Итого + ЦенаСНаценкой;
        КонецЦикла;
      
        Если номформы = 1 Тогда
            Таб.ВывестиСекцию("Подвал");
        Иначе  
            Таб.ВывестиСекцию("Подвал1");
        КонецЕсли;
      
        Таб.ТолькоПросмотр(0);
        Таб.ПараметрыСтраницы(1,,, 10, 0, 5, 5);
        Таб.Опции(0, 0, 0, 0, "Меню", "Меню");
        Таб.Показать("Меню", "");
    
    КонецПроцедуры //  ПечатьМеню()
    
    //******************************************************************************
    
    Процедура ПечатьМенюЗаказа()    
      
        Если ТекущийДокумент().Выбран() = 0 Тогда
            Если Вопрос("Перед печатью документ необходимо провести.
            |Провести документ?",4) = 6 Тогда
                Записать();
            Иначе
                Возврат;
            КонецЕсли;
        КонецЕсли;
      
        Заполнитель = "....................................................................................................";
        Таб = СоздатьОбъект("Таблица");
        Таб.ИсходнаяТаблица("Меню1");
      
        Таб.ВывестиСекцию("Шапка");
        Таб.ВывестиСекцию("Группа1");
      
        Ном = 0;
        Итого = 0; 
      
        Запрос = СоздатьОбъект("Запрос");
        ТекстЗапроса =
        "//{{ЗАПРОС(Сформировать)
        |Период с ДатаДок по ДатаДок;
        |ОбрабатыватьДокументы Все;
        |АктКухни = Документ.АктКухни.ТекущийДокумент;
        |ДляМеню = Документ.АктКухни.ДляМеню;
        |Товар = Документ.АктКухни.Товар;
        |ЕдИзм = Документ.АктКухни.ЕдИзм;
        |ЦенаПродажи = Документ.АктКухни.ЦенаСНаценкой;
        |Количество = Документ.АктКухни.Количество;
        |Всего = Документ.АктКухни.Всего;
        |Группировка ДляМеню;
        //|Группировка Товар;
        |Группировка СтрокаДокумента;
        |Условие(АктКухни = ТекущийДокумент());
        |"//}}ЗАПРОС
        ;  
      
        Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
            Возврат;
        КонецЕсли;
      
        Ном = 0;      
        ИтогоЗаДень = 0;
      
        Пока Запрос.Группировка("ДляМеню") = 1 Цикл
            Таб.ВывестиСекцию("Группа2");          
            ИтогоПоГруппе = 0;
            Пока Запрос.Группировка(2) = 1 Цикл
                Если Запрос.Товар.ЭтоГруппа() = 1 Тогда
                    Продолжить;
                КонецЕсли;
              
                Если Запрос.Товар.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Продукция Тогда
                    Вес = СокрЛП(Запрос.Товар.Калькуляция.Получить(ДатаДок).ВыходБлюда);
                    Вес = ?(ПустоеЗначение(Вес) = 0, " (" + Вес + " гр.) ", " " + Заполнитель);
                Иначе
                    Вес = Запрос.ЕдИзм;
                КонецЕсли;
              
                СтрокаНаименование = "" + Запрос.Товар.Наименование;
                Ном = Ном + 1;
                Таб.ВывестиСекцию("Строка");
                ДокКалк = Запрос.Товар.Калькуляция.Получить(ДатаДок);
              
                Если ДокКалк.Выбран() = 1 Тогда
                    ДокКалк.ВыбратьСтроки();
                    СтрокаСостава = "/";
                    Пока ДокКалк.ПолучитьСтроку() = 1 Цикл
                        СтрокаСостава = СтрокаСостава + СокрП(ДокКалк.Товар.Наименование) + ",";
                    КонецЦикла; 
                    СтрокаСостава = СтрокаСостава + "/";
                    Таб.ВывестиСекцию("Состав");
                КонецЕсли;
              
                ИтогоПоГруппе = ИтогоПоГруппе + Запрос.Всего;
          
            КонецЦикла;
          
            Таб.ВывестиСекцию("Итого");
            ИтогоЗаДень = ИтогоЗаДень + ИтогоПоГруппе;
      
        КонецЦикла;
      
        Таб.ВывестиСекцию("Подвал");
        Таб.ТолькоПросмотр(0);
        Таб.ПараметрыСтраницы(1,,, 10, 0, 5, 5);
        Таб.Опции(0, 0, 0, 0, "Меню1", "Меню1");
        Таб.Показать("Меню", "");
    
    КонецПроцедуры // ПечатьМенюЗаказа()
    
    
    
  11. TopicStarter Overlay
    Kas-tet
    Offline

    Kas-tet

    Регистрация:
    30 сен 2016
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура ПечатьМенюНаркологии() 
     
        Если ТекущийДокумент().Выбран() = 0 Тогда
            Если Вопрос("Перед печатью документ необходимо провести.
            |Провести документ?",4) = 6 Тогда
                Записать();
            Иначе
                Возврат;
            КонецЕсли;
        КонецЕсли;
     
        Заполнитель = "....................................................................................................";
        Таб = СоздатьОбъект("Таблица");
        Таб.ИсходнаяТаблица("Меню");
     
        Таб.ВывестиСекцию("Шапка");
        Таб.ВывестиСекцию("Группа1");
        ИтогоЗаДень = 0;                           
     
        Запрос = СоздатьОбъект("Запрос");
        ТекстЗапроса =
        "//{{ЗАПРОС(Сформировать)
        |Период с ДатаДок по ДатаДок;
        |ОбрабатыватьДокументы Все;
        |АктКухни = Документ.АктКухни.ТекущийДокумент;
        |ГруппаМеню = Документ.АктКухни.ГруппаМеню;
        |Товар = Документ.АктКухни.Товар;
        |ЦенаПродажи = Документ.АктКухни.ЦенаСНаценкой;
        |Группировка ГруппаМеню Без Упорядочивания;
        //|Группировка Товар Без Упорядочивания;
        |Группировка СтрокаДокумента;
        |Условие(АктКухни = ТекущийДокумент());
        |"//}}ЗАПРОС
        ; 
     
        Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
            Возврат;
        КонецЕсли;
     
        Ном = 0; 
        Пока Запрос.Группировка("ГруппаМеню") = 1 Цикл
            Таб.ВывестиСекцию("Группа2");         
            ИтогоПоГруппе = 0;
    //        Пока Запрос.Группировка("Товар") = 1 Цикл
            Пока Запрос.Группировка(2) = 1 Цикл
                Если Запрос.Товар.ЭтоГруппа() = 1 Тогда
                    Продолжить;
                КонецЕсли;
             
                Если Запрос.Товар.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Продукция Тогда
                    Вес = СокрЛП(Запрос.Товар.Калькуляция.Получить(ДатаДок).ВыходБлюда);
                    Вес = ?(ПустоеЗначение(Вес) = 0, " (" + Вес + " гр.) ", " " + Заполнитель);
                Иначе
                    Вес = ЕдИзм;
                КонецЕсли;
             
                СтрокаНаименование = "" + Запрос.Товар.Наименование;
                Ном = Ном + 1;
                Таб.ВывестиСекцию("СтрокаЗ");
             
                ИтогоПоГруппе = ИтогоПоГруппе + Запрос.ЦенаПродажи;
            КонецЦикла;
         
            Таб.ВывестиСекцию("Итого");
            ИтогоЗаДень = ИтогоЗаДень + ИтогоПоГруппе;
     
        КонецЦикла;
     
        Таб.ВывестиСекцию("Подвал2");
        Таб.ТолькоПросмотр(0);
        Таб.Опции(0, 0, 0, 0, "Меню", "Меню");
        Таб.ПараметрыСтраницы(1,,, 0, 0, 0, 0,,, 1);
        Таб.Показать("Меню", "");
    
    КонецПроцедуры // ПечатьМенюНаркологии()
    
    //******************************************************************************
    
    Процедура ПечатьМенюНаркологииК() 
     
        Если ТекущийДокумент().Выбран() = 0 Тогда
            Если Вопрос("Перед печатью документ необходимо провести.
            |Провести документ?",4) = 6 Тогда
                Записать();
            Иначе
                Возврат;
            КонецЕсли;
        КонецЕсли;
     
        Заполнитель = "....................................................................................................";
        Таб = СоздатьОбъект("Таблица");
        Таб.ИсходнаяТаблица("Таблица1");
     
        Таб.ВывестиСекцию("Шапка");
        Таб.ВывестиСекцию("Группа1");
     
        ИтогоЗаДень = 0;
        ИтогоЗаДеньК = 0;
        ИтогоЗаДеньС = 0;
     
        Запрос = СоздатьОбъект("Запрос");
        ТекстЗапроса =
        "//{{ЗАПРОС(Сформировать)
        |Период с ДатаДок по ДатаДок;
        |ОбрабатыватьДокументы Все;
        |АктКухни = Документ.АктКухни.ТекущийДокумент;
        |ГруппаМеню = Документ.АктКухни.ГруппаМеню;
        |Товар             = Документ.АктКухни.Товар;
        |Количество     = Документ.АктКухни.Количество;
        |СуммаПродажи     = Документ.АктКухни.СуммаПродажи;
        |ЦенаПродажи     = Документ.АктКухни.ЦенаСНаценкой;
        |Группировка ГруппаМеню Без Упорядочивания;
        //|Группировка Товар Без Упорядочивания;
        |Группировка СтрокаДокумента;
        |Условие(АктКухни = ТекущийДокумент());
        |"//}}ЗАПРОС
        ; 
     
        Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
            Возврат;
        КонецЕсли;
     
        Ном = 0; 
        Пока Запрос.Группировка("ГруппаМеню") = 1 Цикл
            Таб.ВывестиСекцию("Группа2");         
            ИтогоПоГруппе = 0;
            ИтогоПоГруппеК = 0;
            ИтогоПоГруппеС = 0;
    //        Пока Запрос.Группировка("Товар") = 1 Цикл
            Пока Запрос.Группировка(2) = 1 Цикл
                Если Запрос.Товар.ЭтоГруппа() = 1 Тогда
                    Продолжить;
                КонецЕсли;
                Если Запрос.Товар.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Продукция Тогда
                    Вес = СокрЛП(Запрос.Товар.Калькуляция.Получить(ДатаДок).ВыходБлюда);
                    Вес = ?(ПустоеЗначение(Вес) = 0, " (" + Вес + " гр.) ", " " + Заполнитель);
                Иначе
                    Вес = ЕдИзм;
                КонецЕсли;
             
                СтрокаНаименование = "" + Запрос.Товар.Наименование;
                Ном = Ном + 1;
                Таб.ВывестиСекцию("СтрокаЗ");
             
                ДокКалк = Запрос.Товар.Калькуляция.Получить(ДатаДок);
                Если ДокКалк.Выбран() = 1 Тогда
                    ДокКалк.ВыбратьСтроки();
                    СтрокаСостава = "/";
                    Пока ДокКалк.ПолучитьСтроку() = 1 Цикл
                        СтрокаСостава = СтрокаСостава + СокрП(ДокКалк.Товар.Наименование) + ",";
                    КонецЦикла;
                    СтрокаСостава = СтрокаСостава + "/";
                    Таб.ВывестиСекцию("Состав");
                КонецЕсли;
             
                ИтогоПоГруппе     = ИтогоПоГруппе + Запрос.ЦенаПродажи;
                ИтогоПоГруппеК     = ИтогоПоГруппеК + Запрос.Количество;
                ИтогоПоГруппеС     = ИтогоПоГруппеС + Запрос.СуммаПродажи;
         
            КонецЦикла;
         
            Таб.ВывестиСекцию("Итого");
            ИтогоЗаДень = ИтогоЗаДень + ИтогоПоГруппе;
            ИтогоЗаДеньК = ИтогоЗаДеньК + ИтогоПоГруппеК;
            ИтогоЗаДеньС = ИтогоЗаДеньС + ИтогоПоГруппеС;
     
        КонецЦикла;
     
        Таб.ВывестиСекцию("Подвал2");
        Таб.ТолькоПросмотр(0);
        Таб.Опции(0, 0, 0, 0, "Меню", "Меню");
        Таб.ПараметрыСтраницы(1,,, 0, 0, 0, 0,,, 1);
        Таб.Показать("Меню", "");
    
    КонецПроцедуры // ПечатьМенюНаркологииК()
    
    //******************************************************************************
    
    Процедура ПечатьСчПр()
     
        НомерДокПечатнойФормы = глПреобразоватьНомерДок(НомерДок, 0, 0);
     
        АдресТелефон = "";
        глДобавитьРеквизит(АдресТелефон, "Адрес: ", глПредставлениеАдреса(Константа.АдресОрганизации));
        глДобавитьРеквизит(АдресТелефон, ", тел.: ", Константа.ТелефоныОрганизации);
     
        ПоставщикРасчСчет        = "";
        ПоставщикИНН            = "";
        ПоставщикКПП            = "";
        ПоставщикБанк            = "";
        Кредит                    = "";
        ПоставщикБанкБИК        = "";
        ПоставщикБанкКорсчет    = "";
        глПлатежныеРеквизиты(Заказчик.ОсновнойСчет.ТекущийЭлемент(), ПоставщикРасчСчет, ПоставщикБанк, Кредит, ПоставщикБанкБИК, ПоставщикБанкКорсчет, ПоставщикИНН, ПоставщикКПП, 2);
     
        Плательщик1                = "";
        БанкПлательщика            = "";
        НомерСчетаПлательщика    = "";
        БИКБанкаПлательщика        = "";
        СчетБанкаПлательщика    = "";
        ИННплательщика            = "";
        глПлатежныеРеквизиты(Заказчик.ОсновнойСчет.ТекущийЭлемент(), Плательщик1, БанкПлательщика, НомерСчетаПлательщика, БИКБанкаПлательщика, СчетБанкаПлательщика, ИННплательщика,, 2);
     
        Заказчик1            = "";
        БанкЗаказчика        = "";
        НомерСчетаЗаказчика    = "";
        БИКБанкаЗаказчика    = "";
        СчетБанкаЗаказчика    = "";
        ИННЗаказчика        = "";
        глПлатежныеРеквизиты(Заказчик.ОсновнойСчет.ТекущийЭлемент(), Заказчик1, БанкЗаказчика, НомерСчетаЗаказчика, БИКБанкаЗаказчика, СчетБанкаЗаказчика, ИННЗаказчика,, 2);
     
        Таб = СоздатьОбъект("Таблица");
        Валюта = Константа.ОсновнаяВалюта;
        Вал = Валюта.Наименование;
        ЦеныВДоговоре = 1; // в рублях
        ОплатаДоговора = 1; // в рублях
        Если ПустоеЗначение(Договор.ВалютаДоговора) = 0 Тогда
            ЦеныВДоговоре = 2; // в валюте
            ОплатаДоговора = Договор.ОплатаДоговора;
            Валюта = Договор.ВалютаДоговора;
            Кратность = Валюта.Кратность.Получить(ДатаДок);
            Кратность = ?(Кратность=0, 1, Кратность);
            Если (ОплатаДоговора = 2)  Тогда
                Вал = Договор.ВалютаДоговора.Наименование;
                Если ПустоеЗначение(Договор.ВалютаДоговора.ИмяФайлаПрописи) = 1 Тогда
                    Предупреждение("Для выбранной валюты не указан файл прописи.");
                Иначе
                    Пропись(Договор.ВалютаДоговора.ИмяФайлаПрописи);
                КонецЕсли;
            Иначе
                Пропись("D:\1Cv77\1c\1CV7.SPL");
            КонецЕсли;
        КонецЕсли;
     
        ИмяФайлаПечатнойФормы = КаталогИБ()+"ExtForms\PrnForms\1cbs.mxl";
        Если ФС.СуществуетФайл(ИмяФайлаПечатнойФормы) = 1 Тогда
            Таб.ИсходнаяТаблица(ИмяФайлаПечатнойФормы);
         
        ИначеЕсли НомерТекущейФормы = 7  Тогда
            Таб.ИсходнаяТаблица("Счет");
     
        ИначеЕсли (НомерТекущейФормы = 9) Тогда
            Таб.ИсходнаяТаблица("Протокол");
     
        ИначеЕсли (НомерТекущейФормы = 8) Тогда
            Таб.ИсходнаяТаблица("СчетПротокол");
     
        КонецЕсли;
     
        Таб.ВывестиСекцию("Шапка");
        ВыбратьСтроки();
        Ном = 0;
        Пока ПолучитьСтроку() = 1 Цикл
            Ном = Ном + 1;
            СтавкаНДС = Товар.СтавкаНДС.Получить(ДатаДок).Ставка;
            Наименование = ?(ПустаяСтрока(Товар.ПолнНаименование) = 1, Товар.Наименование, Товар.ПолнНаименование);
         
            ПечЦена        = ФРМ(ЦенаСНаценкой);
            ПечСумма    = ФРМ(Сумма);
            ПечНДС        = ФРМ(НДС);
            ПечВсего    = ФРМ(Всего);
         
            Если Товар.ЦенаИзготовителя = 0 Тогда           
                ПечЦенаИзготовителя = ФРМ(ЦенаСНаценкой);
                Если ПустоеЗначение(Константа.ПечатьОптовойНадбавки) = 0 Тогда
                    ОптоваяНадбавка = СокрЛП(Константа.ПечатьОптовойНадбавки);
                Иначе 
                    ОптоваяНадбавка = "0%";
                КонецЕсли; 
            Иначе
                ОптПроц = (Цена - Товар.ЦенаИзготовителя) / Товар.ЦенаИзготовителя * 100;
                ОптПроц = Окр(ОптПроц, 1, 1);
                ОптоваяНадбавка = "" + ОптПроц + "%";
                Если ОптПроц > 20 Тогда
                    Сигнал();
                    Предупреждение ("Оптовая надбавка по товару: " + Товар + " больше 20 %", 0);
                КонецЕсли;
                ПечЦенаИзготовителя = ФРМ(Товар.ЦенаИзготовителя);
            КонецЕсли;
         
            СтНДС = ПолучитьПустоеЗначение("Справочник.Ставки"+НДС);
            Если ВариантРасчетаНалогов.Выбран() = 1 Тогда
                Если ПустоеЗначение(ВариантРасчетаНалогов) = 0 Тогда // выбран вариант
                    СтНДС = ВариантРасчетаНалогов.СтавкаНДС;
                КонецЕсли;
            КонецЕсли;
         
            Если ПустоеЗначение(СтНДС) = 1 Тогда // поиск в номенклатуре
                Если Товар.Выбран() = 1 Тогда
                    СтНДС = Товар.СтавкаНДС.Получить(ДатаДок);
                Иначе
                    СтНДС = глЗначениеПоУмолчанию("ОсновнаяСтавка" + НДС);
                КонецЕсли;
            КонецЕсли;
         
    //        Если НДС = 0 Тогда
    //            СтНДС = "";
    //        КонецЕсли;
    
            Таб.ВывестиСекцию("Строка");
    
        КонецЦикла;
     
        ПечИтогСумма    = ФРМ(Итог("Сумма"));
        ПечИтогНДС        = ФРМ(Итог("НДС"));
        ПечИтогВсего    = ФРМ(Итог("Всего"));
        Таб.ВывестиСекцию("Итого");
     
        ПрописьИтогСумма= ФРМП(Итог("Сумма"));
        ПрописьИтогНДС    = ФРМП(Итог("НДС"));
        ПрописьИтогВсего= ФРМП(Итог("Всего"));
     
        Таб.ВывестиСекцию("Подвал");
     
        Если (НомерТекущейФормы = 8) Тогда
         
            Таб.ВывестиСекцию("ШапкаП");
         
            ВыбратьСтроки();
            Ном = 0;
            Пока ПолучитьСтроку() = 1 Цикл
                Ном = Ном + 1;
                СтавкаНДС = Товар.СтавкаНДС.Получить(ДатаДок).Ставка;
                Наименование = ?(ПустаяСтрока(Товар.ПолнНаименование) = 1, Товар.Наименование, Товар.ПолнНаименование);
             
                ПечЦена    = ФРМ(ЦенаСНаценкой);
                ПечСумма= ФРМ(Сумма);
                ПечНДС    = ФРМ(НДС);
                ПечВсего= ФРМ(Всего);
                Если Товар.ЦенаИзготовителя = 0 Тогда
                    ПечЦенаИзготовителя = ФРМ(ЦенаСНаценкой);
                    Если ПустоеЗначение(Константа.ПечатьОптовойНадбавки) = 0 Тогда
                        ОптоваяНадбавка = СокрЛП(Константа.ПечатьОптовойНадбавки);
                    Иначе 
                        ОптоваяНадбавка = "0%";
                    КонецЕсли; 
                Иначе
                    ОптПроц = (Цена - Товар.ЦенаИзготовителя) / Товар.ЦенаИзготовителя * 100;
                    ОптПроц = Окр(ОптПроц, 1, 1);
                    ОптоваяНадбавка = "" + ОптПроц + "%";
                    Если ОптПроц > 20 Тогда
                        Сигнал();
                        Предупреждение("Оптовая надбавка по товару: " + Товар + " больше 20 %", 0);
                    КонецЕсли;
                    ПечЦенаИзготовителя = ФРМ(Товар.ЦенаИзготовителя);
                КонецЕсли;
             
                Таб.ВывестиСекцию("СтрокаП");
         
            КонецЦикла;
         
            Таб.ВывестиСекцию("ИтогоП");
            Таб.ВывестиСекцию("ПодвалП");
     
        КонецЕсли;
     
        Таб.Опции(0, 0, 0, 0, "ОпцииПечатиСчета", "ОкноСчета");
        Таб.ТолькоПросмотр(1);
        Таб.Показать("Печать счета", "");
    
    КонецПроцедуры //  ПечатьСчПр()
    
  12. 1с-ник
    Offline

    1с-ник Профессионал в 1С

    Регистрация:
    5 окт 2014
    Сообщения:
    304
    Симпатии:
    49
    Баллы:
    54
    Код:
    Процедура Печать()
    Пропись(ПолныйПутьКомпоненты);
    ...
    ПрописьИтогСумма = Формат(Итог("Сумма"), "ЧПДС");
    ПрописьИтогНДС = Формат(Итог("НДС"), "ЧПДС");
    ПрописьИтогВсего = Формат(Итог("Всего"), "ЧПДС");
    Таб.ВывестиСекцию("Подвал");
    ...
    
    Kas-tet нравится это.
  13. TopicStarter Overlay
    Kas-tet
    Offline

    Kas-tet

    Регистрация:
    30 сен 2016
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    а это
    Код:
    ПрописьИтогСумма = Формат(Итог("Сумма"), "ЧПДС");
    ПрописьИтогНДС = Формат(Итог("НДС"), "ЧПДС");
    ПрописьИтогВсего = Формат(Итог("Всего"), "ЧПДС");
    Таб.ВывестиСекцию("Подвал");
    где должно быть?
  14. TopicStarter Overlay
    Kas-tet
    Offline

    Kas-tet

    Регистрация:
    30 сен 2016
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    странно, в моей базе(копии) оно не работает, но как объединил конфигурацию на основной базе, так там все нормально пишет...в любом случае спасибо большой!):)

Поделиться этой страницей