8.х Как сделать правильно группировку?

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем worker-good, 9 сен 2011.

  1. TopicStarter Overlay
    worker-good
    Offline

    worker-good

    Регистрация:
    13 июл 2011
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    В 1С-Бухгалтерии 2.0 (1С:Предприятие 8.2) есть модуль осуществляющий группировку:



    Код:
    Структура = СтруктураУровень1;
    Для Каждого ПолеВыбраннойГруппировки Из ДанныеОтчета.Группировка Цикл
    Если ПолеВыбраннойГруппировки.Использование Тогда
    Структура = Структура.Структура.Добавить(Тип("ГруппировкаКомпоновкиДанных"));
    ПолеГруппировки = Структура.ПоляГруппировки.Элементы.Добавить(Тип("ПолеГруппировкиКомпоновкиДанных"));
    ПолеГруппировки.Использование  = Истина;
    ПолеГруппировки.Поле           = Новый ПолеКомпоновкиДанных(ПолеВыбраннойГруппировки.Поле);
    Если ПолеВыбраннойГруппировки.ТипГруппировки = Перечисления.ТипДетализацииСтандартныхОтчетов.Иерархия Тогда
    ПолеГруппировки.ТипГруппировки = ТипГруппировкиКомпоновкиДанных.Иерархия;
    ИначеЕсли ПолеВыбраннойГруппировки.ТипГруппировки = Перечисления.ТипДетализацииСтандартныхОтчетов.ТолькоИерархия Тогда
    ПолеГруппировки.ТипГруппировки = ТипГруппировкиКомпоновкиДанных.ТолькоИерархия;
    Иначе
    ПолеГруппировки.ТипГруппировки = ТипГруппировкиКомпоновкиДанных.Элементы;
    КонецЕсли;
    Структура.Выбор.Элементы.Добавить(Тип("АвтоВыбранноеПолеКомпоновкиДанных"));
    Структура.Порядок.Элементы.Добавить(Тип("АвтоЭлементПорядкаКомпоновкиДанных"));
    КонецЕсли;
    КонецЦикла;
    
    

    Однако группировка осуществляется неправильно, т.е. для каждого контрагента выводит 1 дополнительную строку но группировка не осуществляется.

    Прошу ответить что надо изменить в коде чтобы осуществлялась правильная группировка? Заранее благодарен.

Поделиться этой страницей