8.х как сделать отдельной функцией запрос и вывести эти данные в макет другой функцией

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Vektor8, 11 дек 2009.

  1. TopicStarter Overlay
    Vektor8
    Offline

    Vektor8 Опытный в 1С

    Регистрация:
    11 дек 2009
    Сообщения:
    90
    Симпатии:
    0
    Баллы:
    26
    Функция ПечатьДокумента()
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    | РеализацияТоваровУслуг.Номер,
    |РеализацияТоваровУслуг.Дата
    | из
    |Документ.РеализацияТоваровУслуг как РеализацияТоваровУслуг
    |где
    |РеализацияТоваровУслуг.Ссылка=&ТекущийДокумент";
    Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект);
    Шапка=Запрос.Выполнить().Выбрать();
    Шапка.Следующий();

    ТабДокумент=Новый ТабличныйДокумент;
    Макет=ПолучитьМакет("Макет");
    ОбластьМакета=Макет.ПолучитьОбласть("Заголовок");
    ОбластьМакета.Параметры.ТекстЗаголовка="Расходная накладная №"+Шапка.Номер+"от"+Шапка.дата;
    ТабДокумент.Вывести(ОбластьМакета);
    Возврат ТабДокумент;

    КонецФункции

    Функция Печать() Экспорт
    ТабДокумент=ПечатьДокумента();
    Возврат ТабДокумент;
    КонецФункции

    Вложения:

  2. TopicStarter Overlay
    Vektor8
    Offline

    Vektor8 Опытный в 1С

    Регистрация:
    11 дек 2009
    Сообщения:
    90
    Симпатии:
    0
    Баллы:
    26
    пытаюсь добавить функцию которая будет работать только с запросом
  3. Абырвалг
    Offline

    Абырвалг Опытный в 1С

    Регистрация:
    8 дек 2009
    Сообщения:
    112
    Симпатии:
    1
    Баллы:
    29
    Передавайте параметр в функцию, например
    Код:
    Функция ПечатьДокумента()
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    | РеализацияТоваровУслуг.Номер,
    |РеализацияТоваровУслуг.Дата
    | из
    |Документ.РеализацияТоваровУслуг как РеализацияТоваровУслуг
    |где
    |РеализацияТоваровУслуг.Ссылка=&ТекущийДокумент";
    Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект);
    Шапка=Запрос.Выполнить().Выбрать();
    Шапка.Следующий();
    
    ТабДокумент=Новый ТабличныйДокумент;
    Макет=ПолучитьМакет("Макет");
    ОбластьМакета=Макет.ПолучитьОбласть("Заголовок");
    ОбластьМакета.Параметры.ТекстЗаголовка="Расходная накладная №"+Шапка.Номер+"от"+Шапка.дата;
    ТабДокумент.Вывести(ОбластьМакета);
    Возврат ТабДокумент;
    
    КонецФункции
    
    Функция Печать(ТабДокумент) Экспорт
    ТабДокумент=ПечатьДокумента();
    Возврат ТабДокумент;
    КонецФункции
    
    
  4. TopicStarter Overlay
    Vektor8
    Offline

    Vektor8 Опытный в 1С

    Регистрация:
    11 дек 2009
    Сообщения:
    90
    Симпатии:
    0
    Баллы:
    26
    мне нужно создать новую функцию , типа Запрос() что ли?

    и передать её в Функцию ПечатьДокумента(). Чтобы в итоге получилось 3 функции
  5. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    Переносите из ПечатьДокумента() строки в новую функцию
    Код:
    Функция СформироватьВыполнитьВыбрать()
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    | РеализацияТоваровУслуг.Номер,
    |РеализацияТоваровУслуг.Дата
    | из
    |Документ.РеализацияТоваровУслуг как РеализацияТоваровУслуг
    |где
    |РеализацияТоваровУслуг.Ссылка=&ТекущийДокумент";
    Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект);
    Возврат Запрос.Выполнить().Выбрать();
    КонецФункции
    
    
    В ПечатьДокумента() пишете
    Код:
    Шапка=СформироватьВыполнитьВыбрать();
    
  6. TopicStarter Overlay
    Vektor8
    Offline

    Vektor8 Опытный в 1С

    Регистрация:
    11 дек 2009
    Сообщения:
    90
    Симпатии:
    0
    Баллы:
    26
    Спасибо Вам огромное :unsure:

Поделиться этой страницей