8.х Как сделать это в 1С 8.2 ?

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем cobra77777, 6 июн 2012.

  1. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте !

    Есть пример в 8.2 (наз-ся Общепит) так вот на рис.показаны столики и при наведение курсором на столик он становиться активным.
    Интересует как это было сделано в какую ветку смотреть ?

    Вложения:

  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    без клика мышкой/клавой????
  3. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Ну это было бы вообще "волшебно" :). В данном случае мышкой.
  4. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Никто не знает !???
  5. Эмин
    Offline

    Эмин Руководитель проектов

    Регистрация:
    25 май 2007
    Сообщения:
    1.178
    Симпатии:
    1
    Баллы:
    26
    Ну можно поле WEB документа встроить с javascript и т.д. где можно обработать наведение. А уже клик будет вызывать определенную реакцию со стороны системы.

    И еще есть географические схемы :)
  6. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Добавлю немного:
    А формы управляемые или обычные?
    Если обычные то как уже сказали ПолеHTMLДокумента вроде должно подойти (там есть событие onmouseover). Если управляемые - то сложнее, там элемент формы ПолеHTMLДокумента намного урезанее в плане событий.
  7. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Выкладываю исходник.

    Вложения:

  8. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Эм. И? Что вам сказать то по исходнику надо?
  9. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Как это сделано ?
  10. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Жаль что никто не знает.
  11. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Ээээ... Так а вот это не обработчик нажатия?
    Смотрите что размещено на рабочем столе. Когда сами найдете - считайте что начали путь осноения конфигурации =)
    Как вам и сказали там поле HTML и обрабатывается его событие
    Код:
    &НаКлиенте
    Процедура НавигацияПриНажатии(Элемент, ДанныеСобытия, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    
    Попытка
    СтрокаНомерСтолика = ДанныеСобытия.Element.href;
    Если Найти(СтрокаНомерСтолика, "Столик1") > 0 Тогда
    ОткрытьФорму("Документ.Счет.Форма.ФормаДокумента",
    Новый Структура("Столик",
    "Столик 1"));
    КонецЕсли;
    
    Если Найти(СтрокаНомерСтолика, "Столик2") > 0 Тогда
    ОткрытьФорму("Документ.Счет.Форма.ФормаДокумента",
    Новый Структура("Столик",
    "Столик 2"));
    КонецЕсли;
    
    Если Найти(СтрокаНомерСтолика, "Столик3") > 0 Тогда
    ОткрытьФорму("Документ.Счет.Форма.ФормаДокумента",
    Новый Структура("Столик",
    "Столик 3"));
    КонецЕсли;
    
    Если Найти(СтрокаНомерСтолика, "Столик4") > 0 Тогда
    ОткрытьФорму("Документ.Счет.Форма.ФормаДокумента",
    Новый Структура("Столик",
    "Столик 4"));
    КонецЕсли;
    
    Если Найти(СтрокаНомерСтолика, "Столик5") > 0 Тогда
    ОткрытьФорму("Документ.Счет.Форма.ФормаДокумента",
    Новый Структура("Столик",
    "Столик 5"));
    КонецЕсли;
    
    Если Найти(СтрокаНомерСтолика, "Столик6") > 0 Тогда
    ОткрытьФорму("Документ.Счет.Форма.ФормаДокумента",
    Новый Структура("Столик",
    "Столик 6"));
    КонецЕсли;
    
    Если Найти(СтрокаНомерСтолика, "БарнаяСтойка") > 0 Тогда
    ОткрытьФорму("Документ.Счет.Форма.ФормаДокумента",
    Новый Структура("Столик",
    "Барная стойка"));
    КонецЕсли;
    
    Исключение
    КонецПопытки;
    КонецПроцедуры
    
  12. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Ээээ... Так а вот это не обработчик нажатия?
    Смотрите что размещено на рабочем столе. Когда сами найдете - считайте что начали путь осноения конфигурации =)
    Как вам и сказали там поле HTML и обрабатывается его событие

    Ну хорошо. Тогда сможете (если Вам не сложно) на живом примере показать как это реализуется т.е. нарисуйте какие-нибудь предметы (любые) и сделайте тоже самое. Мне непонятно одно, как на нарисованных предметах привязать событие ?
  13. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Событие там одно - обработчик нажатия. А куда именно нажали уже проверяется в этом обработчике (разбирается html структура, ищется элемент на котором находится курсор).
  14. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104

    Вложения:

    • 1Cv8.zip
      Размер файла:
      252,8 КБ
      Просмотров:
      26
  15. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Допустим я добавил еще один столик 4, но при нажатии на этот столик выходит форма Счет создание, но почему то Данные по столику все равно 3 выходит не 4. :( Как сделать автоматом чтобы вых. 4 столик ?
  16. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Я так понимаю, что вы не разобрались в принципе работы. Иначе вопроса не было бы. Смотрите на прописанный HTML код.
  17. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Я тут по Вашему примеру пытался делать не получается :(.
    Почему мой вариант не работает (файл приложен). Общие -> Общие макеты ->Столики. Что не так делаю ? Почему при наведении курсора на столик 1, и нажатии выводится окошко со столиком 2, а не 1.
    Где ошибки ?

    Вложения:

    • 1Cv8.rar
      Размер файла:
      252,2 КБ
      Просмотров:
      15
  18. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Ну как бы все.
    Еще раз:
    1) Без минимальных знаний языка HTML вам здесь никак не обойтись. Именно то, что написано в макете (на html) и определяет как внешний вид, так и то, как потом можно обработать нажатие.
    2) Смотрите на обработчик нажатия в общей форме. Но без п.1 вам это ничего не даст.
  19. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Понятно. Последний вопрос. Откуда берется строка href="V8Config://............................ ?
  20. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Вопросов больше нет. Тема закрыта.

Поделиться этой страницей