7.7 Как сделать чтобы в ТОРГ-12 печатался только товар?

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем Vit@L, 11 мар 2011.

  1. TopicStarter Overlay
    Vit@L
    Offline

    Vit@L Опытный в 1С

    Регистрация:
    23 сен 2008
    Сообщения:
    59
    Симпатии:
    0
    Баллы:
    26
    Привет всем. Помогите пожалуйста, люди добрые, вопрос у меня следующий, как сделать так, чтобы в печатной форме ТОРГ-12 (в документе "Реализация") выводился на печать только товар, а услуги не включались. 1с 7.7 Торговля и Склад.
    Дело все в том, что при создании документа "Реализация" в табличной части забиваю как услуги так и товар. Когда выбираю "Акт", то все хорошо, печатаются только услуги, но когда выбираю ТОРГ-12, то печатаются все позиции которые забиты в табличной части документа "Реализация" (товар и услуги). Как сделать чтобы выводился только товар? В общем, очень нужна помощь. Заранее спасибо.
  2. Itsys
    Offline

    Itsys Опытный в 1С

    Регистрация:
    3 янв 2010
    Сообщения:
    1.394
    Симпатии:
    0
    Баллы:
    26
    Какой релиз?
    В каком-то релизе был реализован выбор печать всей ТЧ или без услуг.
  3. TopicStarter Overlay
    Vit@L
    Offline

    Vit@L Опытный в 1С

    Регистрация:
    23 сен 2008
    Сообщения:
    59
    Симпатии:
    0
    Баллы:
    26
    1С Предприятие для 7.7 для SQL (7.70.025)
    Типовая конфигурация "Торговля + Склад" редакция 9.2 (7.70.931)

    Выбора без услуг к сожалению нет. Есть только печатная форма Торг-12 и Торг-12 с выбором грузополучателя, это все что доступно из ТН для печати в "Реализации"
  4. Itsys
    Offline

    Itsys Опытный в 1С

    Регистрация:
    3 янв 2010
    Сообщения:
    1.394
    Симпатии:
    0
    Баллы:
    26
    Берете 965 релиз и копируете из него все, что связано с печатью. Там меняются процедуры выбора печатной формы и процедура печати ТОРГ-12.
  5. TopicStarter Overlay
    Vit@L
    Offline

    Vit@L Опытный в 1С

    Регистрация:
    23 сен 2008
    Сообщения:
    59
    Симпатии:
    0
    Баллы:
    26
    А где взять этот релиз? И как скопировать все что связано с печатью. Не пинайте сильно, просто не силен я в программировании 1С, но это нужно позарез.
    Заранее спасибо
  6. sergejk74
    Offline

    sergejk74 Опытный в 1С

    Регистрация:
    15 ноя 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Найди через конфигуратор процедуру
    Код:
    Печать(СразуНаПринтер = 0,КолЭкз = 1)
    
    Добавь в цикле
    Код:
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    
    Условие
    Код:
    Если (Номенклатура.ВидНоменклатуры = Перечисление.ВидыНоменклатуры.Услуга) Тогда
    Продолжить;
    КонецЕсли;
    
    Это минимум, для большего эффекта нужно еще перед условием
    Код:
    Если КоличествоСтрок() = 1 Тогда
    
    добавить
    Код:
    КоличествоСтрок = 0;
    
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    Если Номенклатура.ВидНоменклатуры = Перечисление.ВидыНоменклатуры.Услуга Тогда
    Продолжить;
    КонецЕсли;
    
    КоличествоСтрок	= КоличествоСтрок + 1;
    КонецЦикла;
    
    Примерно как то так, разберешься
  7. Itsys
    Offline

    Itsys Опытный в 1С

    Регистрация:
    3 янв 2010
    Сообщения:
    1.394
    Симпатии:
    0
    Баллы:
    26
    Обратиться к франчайзи, если не сильны в программировании, можно к ним же обратиться по поводу доработки. Это займет не больше получаса.

Поделиться этой страницей