7.7 как сделать автоматический выбор в 1С

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем phcode, 30 июл 2009.

  1. TopicStarter Overlay
    phcode
    Offline

    phcode Опытный в 1С

    Регистрация:
    13 апр 2009
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    Подскажите пожалуйста, как сделать, чтобы при открытие Производственного листа, автоматически подставлялся склад списания мат. затрат -> Склад №2?
    И как сделать так, что если щелкнуть на таблице, в столбце материал открывался сразу справочник 10,1 Сырье?
    Заранее благодарен!

    [​IMG]

    [warn="!!! Читайте правила форума !!!"]Два вопроса = две темы[/warn]
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Уважаемый phcode просьба уважать участников форума и облегчать им задачу - сообщайте в вопросе вашу конфигурацию. Судя по названию документа она не совсем стандартная.

    1) Для автоматического указания склада (опять же неисзвестно что за конфа, возможно все уже реализовано штатными средствами). В просудуре ВводНового нужно добавить заполнение данного реквизита приблизительно так:
    Код:
    Процедура ВводНового()
    МестоХранения = Константа.СкладСписсания;
    .....
    КонецПроцедуры
    
    
    
    2)Судя по картинке мы имеем дело с реквизитом типа "неопределенный".
    Для начала воспользуйтесь методом НазначитьТип. Приблизительно так:
    Код:
    Процедура ПриНачалеВыбораЗначения(Ид,Фл)
    Если Ид="Материал" Тогда
    НазначитьТип("Материал","Справочник.Материалы");
    КонецЕсли;
    
    КонецПроцедуры
    
    
    
    Таким образом автоматически будет открываться справочник материалы
    для выбора элемента ТОЛЬКО с реквизитом счет 10.1 нужно будет еще организовать фильтр списка справочника. Воспользуйтесть

    УстановитьОтбор(<ИмяОтбора>,<ЗначениеОтбора>)
    Назначение:
    Установить отбор списка справочника.

Поделиться этой страницей