8.х КАК Разбить Характеристику

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем spavel, 27 дек 2007.

  1. TopicStarter Overlay
    spavel
    Offline

    spavel

    Регистрация:
    22 апр 2007
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Конфа -- УТ
    В документе РеализацияТоваровУслуг есть характеристика Номенклатуры
    Допустим Характеристика номенклатуры состоит из цвета и размера
    вопрос

    Как вывести в табличный документ (печатуемый из реализации) две колонки в одну запихнуть цвет из характеристики в другую размер из этой же характеристики?

    Короче КАК мсожно разбить характеристику на составляющие??
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Посмотри, как редактируется характеристика в типовых.
  3. Senya
    Offline

    Senya Опытный в 1С

    Регистрация:
    6 июн 2006
    Сообщения:
    594
    Симпатии:
    0
    Баллы:
    26
    Что-то вроде этого - здесь ищется одно свойство из всего набора характеристик:
    Код:
    ЗапросХ.УстановитьПараметр("НазначениеСвойств",       ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_ХарактеристикиНоменклатуры);
    ЗапросХ.УстановитьПараметр("ОбъектОтбораЗначений",    ?(Проверка,КодП.ХарактеристикаНоменклатуры,КодП.ХарактеристикаНоменклатурыПолучатель));
    ЗапросХ.УстановитьПараметр("СписокНазначенийСвойств", СписокНазначенийСвойствАБ(КодП.Номенклатура));
    
    ЗапросХ.Текст = "
    |ВЫБРАТЬ РАЗЛИЧНЫЕ РАЗРЕШЕННЫЕ
    |    СвойстваОбъектов.ПометкаУдаления                            КАК ПометкаУдаления,
    |    СвойстваОбъектов.Ссылка                                     КАК Свойство,
    |    РегистрСведений.ЗначенияСвойствОбъектов.Значение            КАК Значение
    |
    |ИЗ
    |// Отбираются свойства, предназначенные для заданного типа объектов.
    |    (
    |    ВЫБРАТЬ 
    |        ПланВидовХарактеристик.СвойстваОбъектов.Ссылка          КАК Ссылка,
    |        ПланВидовХарактеристик.СвойстваОбъектов.ПометкаУдаления КАК ПометкаУдаления
    |
    |    ИЗ
    |        ПланВидовХарактеристик.СвойстваОбъектов
    |
    |    ГДЕ
    |        ПланВидовХарактеристик.СвойстваОбъектов.НазначениеСвойства В ( &НазначениеСвойств )
    |
    |    )                                                           КАК СвойстваОбъектов
    |
    |ЛЕВОЕ ВНЕШНЕЕ СОЕДИНЕНИЕ
    |// Присоединяются значения свойств, назначенные для заданного объекта.
    |    РегистрСведений.ЗначенияСвойствОбъектов
    |ПО
    |    РегистрСведений.ЗначенияСвойствОбъектов.Свойство = СвойстваОбъектов.Ссылка
    |    И
    |    РегистрСведений.ЗначенияСвойствОбъектов.Объект = &ОбъектОтбораЗначений
    |
    |ЛЕВОЕ ВНЕШНЕЕ СОЕДИНЕНИЕ
    |// Присоединяются группы, которым назначено свойство, для отбора свойств.
    |// Если свойству назначено значение, оно отбирается в любом случае.
    |    РегистрСведений.НазначенияСвойствОбъектов
    |ПО
    |    РегистрСведений.НазначенияСвойствОбъектов.Свойство = СвойстваОбъектов.Ссылка
    |    И
    |    РегистрСведений.ЗначенияСвойствОбъектов.Значение ЕСТЬ NULL
    |
    |ГДЕ
    |// Если значение свойства не задано, свойство должно быть назанчено
    |// или всем объектам, или одной из групп - родителей объекта.
    |    РегистрСведений.НазначенияСвойствОбъектов.Объект ЕСТЬ NULL
    |    ИЛИ
    |    РегистрСведений.НазначенияСвойствОбъектов.Объект В ( &СписокНазначенийСвойств )
    |
    |УПОРЯДОЧИТЬ ПО
    |    СвойстваОбъектов.Ссылка.Наименование
    |";
    
    ТЗ = ЗапросХ.Выполнить().Выгрузить();
    Если ТЗ.Количество()>0 тогда
    Для сч=0 По ТЗ.Количество() - 1 Цикл
    Если ТипЗнч(ТЗ[Сч].Значение)=Тип("СправочникСсылка.Заказы") тогда
    Заказ    = ТЗ[Сч].Значение;
    КонецЕсли;
    КонецЦикла; 
    КонецЕсли;
    

Поделиться этой страницей