Как рассчитать среднюю закупочную цену

Тема в разделе ""1С:Управление торговлей УТ"", создана пользователем Аля, 28 янв 2015.

  1. TopicStarter Overlay
    Аля
    Offline

    Аля

    Регистрация:
    28 янв 2015
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте! Мы работаем в 1С8 торговля, розничная торговля. Возникают трудности, в том что не можем настроить в программе конфигурацию, чтобы программа автоматически высчитывала среднюю закупочную цену на товар по нескольким поставкам. Программа запоминает последнюю цену, которую мы вбили в установках цен номенклатуры. Я знаю, что в 7 была такая возможность, наш программист говорит, что в 1с8 нет такого. Ну ведь не может быть, подскажите кто знает????
  2. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.440
    Симпатии:
    374
    Баллы:
    104
    1) в 8-ке нет "Торговля", есть "Управление Торговлей"
    2) вопрос задайте корректнее

    PS
    7-ка тоже последнюю цену запоминала
  3. TopicStarter Overlay
    Аля
    Offline

    Аля

    Регистрация:
    28 янв 2015
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Да не "Торговля", а "Управление Торговлей", но наверно понятно о чем я говорю. Просто у нас ситуация: в прошлом году купили 3 колеса по 5400 руб., а в этом году одно по цене 3200. Если зайти в справочники и посмотреть закупочную цену на это колесо, программа показывает 3200, а на самом деле ведь 4850 - средняя цена на одно колесо из четырех. Как это увидеть в программе????
    Последнее редактирование модератором: 28 янв 2015
  4. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    можно подумать на УТ или на Розницу... Если в 7 выводилась средняя, то думаю, она была допиленная под это.
  5. TopicStarter Overlay
    Аля
    Offline

    Аля

    Регистрация:
    28 янв 2015
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    В семерке : Отчеты - остатки ТМЦ - далее в окне по строке "цены" можно было выбрать "усредненная себестоимость с НДС". и формировался список необходимых мне товаров со средней закупочной ценой.
  6. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.440
    Симпатии:
    374
    Баллы:
    104
    ну так это отчёт
    там банально сумму остатка в учётных (приходных) ценах просто делят на кол-во остатка
    Код:
        ИначеЕсли     ПредставлениеЦены="усредненная себестоимость без НДС" Тогда //себестоимость без НДС
            НомСтр="";
            Если ТЗИтоги.НайтиЗначение(Товар,НомСтр,"Номенклатура")=0 Тогда
                Цена        = 0;
                ВалютаЦены    = глРубли;
            Иначе                                
                ТЗИтоги.ПолучитьСтрокуПоНомеру(НомСтр);
                КолТовара    = ТЗИтоги.Количество;
                Цена        = ?(КолТовара=0,0,ТЗИтоги.СуммаБезНДС * Коэффициент/КолТовара);
                ВалютаЦены    = глРубли;
            КонецЕсли;
        ИначеЕсли     ПредставлениеЦены = "усредненная себестоимость с НДС" Тогда //себестоимость с НДС
    
            // ВалютаЦены - валюта учета товара
            НомСтр="";
            Если ТЗИтоги.НайтиЗначение(Товар,НомСтр,"Номенклатура")=0 Тогда
                Цена        = 0;
                ВалютаЦены    = глРубли;
            Иначе                                
                ТЗИтоги.ПолучитьСтрокуПоНомеру(НомСтр);
                КолТовара    = ТЗИтоги.Количество;
                Цена         = ?(КолТовара=0,0,ТЗИтоги.СуммаРуб * Коэффициент/КолТовара);
                ВалютаЦены    = глРубли;
            КонецЕсли;
        КонецЕсли;                            

    Вложения:

  7. TopicStarter Overlay
    Аля
    Offline

    Аля

    Регистрация:
    28 янв 2015
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    А в восьмерке такое возможно?
  8. Svb
    Offline

    Svb Опытный в 1С Команда форума

    Регистрация:
    12 янв 2011
    Сообщения:
    980
    Симпатии:
    19
    Баллы:
    29
    "средняя закупочная цена на товар" чем принципиально отличается от себестоимости?
  9. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.440
    Симпатии:
    374
    Баллы:
    104
    цена закупки не всегда равна цене поступления (себестоимости) :)
  10. TopicStarter Overlay
    Аля
    Offline

    Аля

    Регистрация:
    28 янв 2015
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    В восьмерке то такое возможно???
    --- Объединение сообщений, 30 янв 2015 ---
    В восьмерке то такое возможно???
  11. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.440
    Симпатии:
    374
    Баллы:
    104
    если напишете отчёт или допишете нужный - да
  12. Eugeneer
    Offline

    Eugeneer

    Регистрация:
    3 фев 2015
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Да, возможно. Или сами пишите или ищите готовые решения.

Поделиться этой страницей