8.х как раскрасить табличную часть документа?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем UnNone, 19 дек 2007.

  1. TopicStarter Overlay
    UnNone
    Offline

    UnNone Опытный в 1С

    Регистрация:
    21 мар 2007
    Сообщения:
    148
    Симпатии:
    0
    Баллы:
    26
    Вопрос состоит вот в чем: Есть ли какие-то способы сделать строки табличной части в документе разных цветов(хотябы двух), чередование не подходит.
    Или как использовать картинку в ячейках табличной части(в одной колонке в разных ячейках разнае картинки). Или 8-ка таких выкрутасов не предусматривает ? :(
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    1. ПриВыводеСтроки() - смотри ОформлениеСтроки
    2. Смотри пункт 1 + посмотри в типовых, как сделан значок по серийным номерам.
  3. Aidis
    Offline

    Aidis

    Регистрация:
    13 дек 2007
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    В документе создаешь событие при выводе строки
    а там через "ОформлениеСтроки" к примеру "ОформлениеСтроки.Ячейки.СтавкаНДС.ЦветФона"
  4. AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    кстати в бп 1.6 красоту навели теперь счета бу и ну желтенькие и голубенькие :)
    кстати опять же код можно посмотреть.
  5. TopicStarter Overlay
    UnNone
    Offline

    UnNone Опытный в 1С

    Регистрация:
    21 мар 2007
    Сообщения:
    148
    Симпатии:
    0
    Баллы:
    26
    Всем большое спасибо:)
  6. Akuji
    Offline

    Akuji Опытный в 1С

    Регистрация:
    5 июн 2007
    Сообщения:
    119
    Симпатии:
    0
    Баллы:
    26
    Может скопируете пару строчек что б типовую не ставить....

    И заоодно может строчку про как активировать нужную ячейку в ТЧ.строки. Допустим при изменении первой ячейки автом переходило в пятую
    ЭлемФормы.ТЧ. и что там дальше
  7. AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    Код:
    Процедура ТоварыПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    
    Если ДанныеСтроки.Резерв = ДанныеСтроки.Количество Тогда
    ОформлениеСтроки.ЦветФона = WebЦвета.СветлоЗеленый;
    ИначеЕсли ДанныеСтроки.Резерв < ДанныеСтроки.Количество Тогда
    ОформлениеСтроки.ЦветФона = WebЦвета.Желтый
    Иначе ОформлениеСтроки.ЦветФона = WebЦвета.Красный;    
    КонецЕсли;
    
    КонецПроцедуры // ТоварыПриВыводеСтроки()
    
    в про второе не совсем понятно. Надо после ввода в первую ячейку переходит в пятую или при изменении в первой менять и в пятой. ( http://www.1c-pro.ru/index.php?showtopic=5942 )
  8. Akuji
    Offline

    Akuji Опытный в 1С

    Регистрация:
    5 июн 2007
    Сообщения:
    119
    Симпатии:
    0
    Баллы:
    26
    Там просто подставляет нужное значение - не то.
    Надо напримев в тек строке при заполнении колонки скажем "Кол" при энтере автоматом перейти в колонку скажем "Цена" учитывая что она не следующая
  9. AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    Код:
    Процедура ТоварыПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования)
    
    Если Элемент.ТекущаяКолонка.Имя = "Количество" Тогда 
    ЭлементыФормы.Товары.ТекущаяКолонка = ЭлементыФормы.Товары.Колонки.Цена;
    КонецЕсли;
    
    КонецПроцедуры // ТоварыПриОкончанииРедактирования()
    

Поделиться этой страницей