7.7 Как проверить на тип значения

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем nbIpKuH_BaH9I, 30 янв 2016.

  1. TopicStarter Overlay
    nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.980
    Симпатии:
    398
    Баллы:
    104
    Всем привет. Подскажите как в 7.7 проверить на тип значения?
    Аналог в 8.
    Код:
    Если ТипЗнч(Переменная) = Тип("ДокументСсылка.ПоступлениеТоваров") Тогда
      
    КонецЕсли;
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    ТипЗначения и ТипЗначенияСТР когда определились с видом объекта для конкретизации используем Вид()
  3. TopicStarter Overlay
    nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.980
    Симпатии:
    398
    Баллы:
    104
    Олег, читал про эти методы. Но так и не понял как с ними работать. Примерчика нет?
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Если ТипЗначения(Перем)=12 Тогда //это документ
    Если Перем.Вид()="ПоступлениеТоваров" Тогда
    Сообщить("Это нам и надо");
    КонецЕсли;
    КонецЕсли;

    Можно конечно и без определения типа... Но тогда можешь нарваться на случай, когда переменная не будит иметь метода Вид()
    nbIpKuH_BaH9I нравится это.
  5. TopicStarter Overlay
    nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.980
    Симпатии:
    398
    Баллы:
    104
    А 12 это что за число? Типа документ так обозначается?
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Если ты читал СП....
    ТипЗначения(<Значение>)
    Назначение:
    Возвращает:
    тип данных значения в виде числа.
    Параметры:
    <Значение> - выражение, тип данных значения которого надо определить.
    Возвращаемые значения типов данных:
    0 - неопределенный тип данных;
    1 - числовой тип данных;
    2 - строковый тип данных;
    3 - тип данных Дата;
    10 - агрегатный тип данных 'Перечисление';
    11 - агрегатный тип данных 'Справочник';
    12 - агрегатный тип данных 'Документ';
    13 - агрегатный тип данных 'Календарь';
    14 - агрегатный тип данных 'ВидРасчета';
    100 - внешний объект ('Текст', 'Таблица', 'Запрос', 'ЖурналРасчетов' и т.п.).
    nbIpKuH_BaH9I нравится это.
  7. TopicStarter Overlay
    nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.980
    Симпатии:
    398
    Баллы:
    104
    Каюсь, не читал. Время мое ограничено. :(
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не мог удержаться чтоб не подколоть..... Обращайся)
  9. TopicStarter Overlay
    nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.980
    Симпатии:
    398
    Баллы:
    104
    Читал в инете. :)

Поделиться этой страницей