8.х Как прописать реквизиты формы

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Daron1985, 11 дек 2007.

  1. TopicStarter Overlay
    Daron1985
    Offline

    Daron1985

    Регистрация:
    11 окт 2007
    Сообщения:
    26
    Симпатии:
    0
    Баллы:
    1
    Я провожу загрузку контрагентов вот такой обработкой из файла OUT01.dbf:


    Код:
    Процедура ЗагКонтрИзКК()
    Если ФлКонтр=0 Тогда
    Сообщить("Не установлен флаг Контрагенты");
    возврат;
    КонецЕсли;
    Состояние("Загрузка контрагентов.......");
    ИсхФ.Кодировка = КодировкаXBase.OEM;
    ИсхФ.ОткрытьФайл("C:ArxivOUT01.dbf"); 
    Если ИсхФ.Открыта()=Ложь Тогда
    Сообщить("Не удалось открыть базу данных "+строка(ИсхФ.КодОшибки()) );
    Возврат;
    КонецЕсли;
    Если ИсхФ.КоличествоЗаписей() < 1 Тогда
    Сообщить("Пустой");
    Возврат;
    КонецЕсли;
    СпрК  = Справочники.Контрагенты;
    
    ИсхФ.Первая();
    Пока не ИсхФ.ВКонце() Цикл
    СпрК=Справочники.Контрагенты.НайтиПоКоду(ИсхФ.NumRec);
    Если СпрК=Справочники.Контрагенты.ПустаяСсылка() Тогда
    СпрК=Справочники.Контрагенты.СоздатьЭлемент();            
    спрК.Код                    =ИсхФ.NumRec;
    спрК.наименование           =ИсхФ.Name;
    спрК.НаименованиеПолное     = ИсхФ.Namefull;
    спрК.ЮрФизЛицо=Перечисления.ЮрФизЛицо.ЮрЛицо;
    :unsure: 
    СпрК.ИНН = ИсхФ.INN;
    СпрК.Записать();
    конецесли;
    
    ИсхФ.Следующая();
    КонецЦикла;
    Колич = 0;
    Пока Колич = 0 Цикл        
    Колич = 1;
    СпрК.ПолучитьСсылку();
    СпрК1 = Справочники.Контрагенты;
    СпрК1.НайтиПоКоду("Прочие",0);
    Если СпрК1.ПустаяСсылка()=0 Тогда
    СпрК1.НоваяГруппа();
    СпрК1.Код="Прочие";
    СпрК1.Наименование="Прочие Контрагенты";
    СпрК1.Записать();
    КонецЕсли;
    
    КонецЦикла; 
    ИсхФ.ЗакрытьФайл(); 
    //Предупреждение("Все Контрагенты загружены");    
    КонецПроцедуры  
    
    но вот в том месте где я пометил еще нужно загрузить адрес.у него поле ИсхФ.Adress -отсюда грузится адрес. но реквизитов с названием адрес нету помогите

    Используйте тэг
    Код:
    [/color]
  2. AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    Адрес храниться в регистре сведений "контактная информация"
    туда его и пиши.

Поделиться этой страницей