7.7 Как програмно открыть период?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Jivchic, 14 июн 2010.

  1. TopicStarter Overlay
    Jivchic
    Offline

    Jivchic Опытный в 1С

    Регистрация:
    4 фев 2008
    Сообщения:
    54
    Симпатии:
    0
    Баллы:
    26
    Такой механизм есть?
    надо чтобы у юзера было скрыто меню "Операции",
    но чтобы юзер открывал период оперативных итогов, или период сам автоматически открывался....
  2. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Добавьте в доступное пользователю меню Задачу:
    Посмотреть вложение 4606

    Вложения:

    • 0002.PNG
      0002.PNG
      Размер файла:
      8 КБ
      Просмотров:
      169
  3. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Открой конфигурацию ТиС.
    Там как раз имеется такой механизм.

    Код:
    	//Автоматическое открытие периода
    ДатаТА=ПолучитьДатуТА();
    Если (РабочаяДата()>ДатаТА)И
    ((ДатаМесяц(ДатаТА)<>ДатаМесяц(РабочаяДата()))ИЛИ(ДатаГод(ДатаТА)<>ДатаГод(РабочаяДата()))) Тогда
    Если МонопольныйРежим()=0 Тогда
    Ответ=Вопрос("Не открыт период!"+РазделительСтрок+
    "Для открытия периода запустите программу в монопольном режиме!"+РазделительСтрок+
    "Завершить работу программы?","Да+Нет");
    Если Ответ="Да" Тогда
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;	   
    Иначе	// монопольный режим
    Ответ=Вопрос("Не открыт период!"+РазделительСтрок+
    "Выполнить открытие периода?","Да+Нет");
    Если Ответ="Да" Тогда
    УстановитьТАНа(РабочаяДата());
    КонецЕсли;	   
    КонецЕсли;	
    КонецЕсли;
    
    

Поделиться этой страницей