8.х Как программно заполнить "партии" в документе "ввод начальных остатков"

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Azamat, 5 фев 2012.

  1. TopicStarter Overlay
    Azamat
    Offline

    Azamat Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    271
    Симпатии:
    0
    Баллы:
    26
    Как программно заполнить "партии" в документе "ввод начальных остатков". Написал такую обработку, но незнаю чего тут не хватает
    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    Док = ЭтотОбъект.ВводНачальныхОстатков;
    Объект = Док.ПолучитьОбъект();
    Стр = Объект.МПЗПриобретенные.Найти(Неопределено, "Партия");
    Пока Стр.Партия = Неопределено Цикл
    Стр.Партия = Документы.ДокументРасчетовСКонтрагентом.НайтиПоНомеру("ААА01");
    КонецЦикла; 
    Объект.Записать();
    КонецПроцедуры
    
  2. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Может как-то так:
    Код:
    Объект = Док.ПолучитьОбъект();
    Для Каждого Стр Из Объект.МПЗПриобретенные Цикл
    Если НЕ ЗначениеЗаполнено(Стр.Партия) Тогда
    Стр.Партия = Документы.ДокументРасчетовСКонтрагентом.НайтиПоНомеру("ААА01", '2011-01-01');
    КонецЕсли;
    КонецЦикла;
    Объект.Записать();
  3. TopicStarter Overlay
    Azamat
    Offline

    Azamat Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    271
    Симпатии:
    0
    Баллы:
    26
    Спасибо за помощь!))

Поделиться этой страницей