7.7 Как программно вставить картинку в файл таблицы mxl

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем krasdok, 22 ноя 2012.

  1. TopicStarter Overlay
    krasdok
    Offline

    krasdok Опытный в 1С

    Регистрация:
    22 июн 2011
    Сообщения:
    130
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте!
    Есть формы (таблицы) как отдельные файлы mxl и при необходимости распечатывается нужная.
    В шапке таблиц есть логотип картинка. Она поменялась. Форм очень много и хотелось бы в будущем упростить этот процесс. Думаю создать константу где будет прописываться путь к файлу.
    Проблема в том как сделать чтобы на форме она появлялась. Тоесть в будущем изминили путь или новый файл и на всех формах все поменялось автоматом а не в ручную картинки менять. На формах документов у меня получилось. А вот в таблицах которые в отдельных файлах находяться не получается.
    Очень жду помощи!!!
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    в макете размещаем объект типа "рисунок"
    в расшифровке указываем вызов функции Рисунок(Таб.ТекущийОбъект,Путь)

    сама функция (запихнуть ее в ГМ нужно, чтобы была везде доступна)
    Код:
    Функция Рисунок ( Куда,Откуда ) Экспорт
    Куда.Загрузить(Откуда);
    КонецФункции
    
    путь - полный путь и имя файла картинки

    + с именем объекта типа "таблица" в расшифровке не ошибитесь
  3. TopicStarter Overlay
    krasdok
    Offline

    krasdok Опытный в 1С

    Регистрация:
    22 июн 2011
    Сообщения:
    130
    Симпатии:
    0
    Баллы:
    26
    Я маленько не так делал. Либо ничего либо слово картинка вписывается. Да еще если объект называется "Таблица", то должно быть так: Таблица.ТекущийОбъект ???
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    в вызове функции должен быть указан тот объект, в который вы выводите картинку
  5. TopicStarter Overlay
    krasdok
    Offline

    krasdok Опытный в 1С

    Регистрация:
    22 июн 2011
    Сообщения:
    130
    Симпатии:
    0
    Баллы:
    26
    А разве не так нужно????

    Функция Рисунок ( Куда,Откуда ) Экспорт
    Возврат Куда.Загрузить(Откуда);
    КонецФункции
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    нет. В данном случае загружаем объект. Метод Загрузить не возвращает значения. Что приведет к ошибке
  7. TopicStarter Overlay
    krasdok
    Offline

    krasdok Опытный в 1С

    Регистрация:
    22 июн 2011
    Сообщения:
    130
    Симпатии:
    0
    Баллы:
    26
    Хотя так и сяк пробовал, что-то не получается... :sad: Что не так может быть???
  8. TopicStarter Overlay
    krasdok
    Offline

    krasdok Опытный в 1С

    Регистрация:
    22 июн 2011
    Сообщения:
    130
    Симпатии:
    0
    Баллы:
    26
    Я так и сяк пробовал не хочет... :sm_cry: Что не так???
    В ГМ:

    Функция Рисунок ( Куда,Откуда ) Экспорт
    Куда.Загрузить(Откуда);
    КонецФункции

    В модуле:

    Процедура Сформировать(Ручн = 0, ФлагЗакрытияФормы = 0)
    Если ПроверкаПериода() = 0 Тогда
    Возврат;
    КонецЕсли;
    Путь="D:\baza\snil\cnil\cnil\ExtForms\PrnForms\Tabl\logo1.bmp";
    .
    .
    .

    Если (ТипЗначенияСтр(Т) <> "Таблица")ИЛИ(Обновить=0) Тогда
    Т = СоздатьОбъект("Таблица");
    Иначе
    Т.Очистить();
    КонецЕсли;
    Т.ИсходнаяТаблица("Таблица");


    В таблице Свойства рисунка->Расшифровка:

    Рисуночки(Т.ТекущийОбъект, Путь)
  9. TopicStarter Overlay
    krasdok
    Offline

    krasdok Опытный в 1С

    Регистрация:
    22 июн 2011
    Сообщения:
    130
    Симпатии:
    0
    Баллы:
    26
    Помогите пожалуйста! Голова пухнет, а в инете инфу не могу найти по этой теме.
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В ГМ Рисунок, а в расшифровке Рисуночки
  11. TopicStarter Overlay
    krasdok
    Offline

    krasdok Опытный в 1С

    Регистрация:
    22 июн 2011
    Сообщения:
    130
    Симпатии:
    0
    Баллы:
    26
    Создал новый пустой отчет для эксперементов вывожу только шапку с картринкой. Также сделал возможность в форме выбирать файл. И все хорошо работает. Блин не пойму почему в нужном отчете пусто...
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    или дело в секции (не ту выводите) или самом объекте...
    попробуйте удалить/создать объект в макете заново
  13. TopicStarter Overlay
    krasdok
    Offline

    krasdok Опытный в 1С

    Регистрация:
    22 июн 2011
    Сообщения:
    130
    Симпатии:
    0
    Баллы:
    26
    Спасибо!!! Разобрался!!! Просто границы рисунка чуть выходили за секцию (вернее рисунок был в границах двух секций), а у меня чуть мозги не закипели...
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104

Поделиться этой страницей