8.х Как программно удалить строку из регистра сведений?

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем Natalika25, 28 окт 2011.

  1. TopicStarter Overlay
    Natalika25
    Offline

    Natalika25 Опытный в 1С

    Регистрация:
    21 сен 2011
    Сообщения:
    62
    Симпатии:
    0
    Баллы:
    26
    есть регистр сведений МестонахождениеОС, мне нужно пробежаться по нему и в цикле удалить строки, подскажите пожалуйста)
  2. uza
    Offline

    uza 1С, VBA (EXCEL), VB (.NET + WEB)

    Регистрация:
    10 июл 2007
    Сообщения:
    1.845
    Симпатии:
    1
    Баллы:
    29
    Код:
    НачатьТранзакцию();
    
    НаборЗаписей = РегистрыСведений.МестонахожденияОС.СоздатьНаборЗаписей();
    НаборЗаписей.Отбор.Регистратор.Установить([документ создавший левую запись]); //обязательно для подчиненных регистров
    НаборЗаписей.Прочитать();
    
    сзУдаляемыеЗаписи = Новый СписокЗначений;
    Для Каждого Запись Из НаборЗаписей
    Если [условие] Тогда
    сзУдаляемыеЗаписи.Добавить(Запись);
    КонецЕсли; //[условие]
    КонецЦикла;
    
    Для каждого ЭлтСз Из сзУдаляемыеЗаписи
    НаборЗаписей.Удалить(ЭлтСз.Значение);
    КонецЦикла;
    
    НаборЗаписей.Записать();
    
    ЗафиксироватьТранзакцию();
    
    

Поделиться этой страницей