8.х Как программно добавить в ТаблицуФормы колонки!?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем web.num, 17 мар 2014.

  1. TopicStarter Overlay
    web.num
    Offline

    web.num Опытный в 1С Команда форума

    Регистрация:
    6 окт 2011
    Сообщения:
    918
    Симпатии:
    4
    Баллы:
    29
    Привет всем, есть 8.2 упр интерфейс, подскажите как добавить колонки в ТаблицуФормы?
  2. Annie
    Offline

    Annie Опытный в 1С Команда форума

    Регистрация:
    10 фев 2010
    Сообщения:
    949
    Симпатии:
    23
    Баллы:
    29
    Попробуй так
    Код:
    НоваяКолонка = Элементы.Добавить("ТвояКолонка", Тип("ПолеФормы"), ТвояТаблицаНаФорме);  
    НоваяКолонка.ПутьКДанным = "Товары.Номенклатура";  //Таблица.ПолеТаблицы
  3. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29
    а где же реквезитФормыВзначение и обратно ?
  4. TopicStarter Overlay
    web.num
    Offline

    web.num Опытный в 1С Команда форума

    Регистрация:
    6 окт 2011
    Сообщения:
    918
    Симпатии:
    4
    Баллы:
    29
    Код:
        //Опишем будущие колонки
        ТЗ = Новый ТаблицаЗначений;
        Для Каждого СтрМассива Из Массив Цикл
            ТЗ.Колонки.Добавить(СтрМассива);
        КонецЦикла;
      
        //Опишем массив реквизитов
        МассивРеквизитов = Новый Массив;
        МассивТипаВыбора = Новый Массив;
        МассивТипаВыбора.Добавить(Тип("ТаблицаЗначений"));
        ОписаниеТипаВыбора = Новый ОписаниеТипов(МассивТипаВыбора);
      
        //Добавим в массив реквизитов таблицу значений
        МассивРеквизитов.Добавить(Новый РеквизитФормы("ДанныеФайла", ОписаниеТипаВыбора));
      
        //Добавим в массив реквизитов колонки таблицы
        Для Каждого Колонка Из ТЗ.Колонки Цикл
            МассивРеквизитов.Добавить(Новый РеквизитФормы(Колонка.Имя, Колонка.ТипЗначения, "ДанныеФайла"));
        КонецЦикла;
      
        ИзменитьРеквизиты(МассивРеквизитов);
      
        //Добавим Таблицу на форму
        ТаблицаДанныхФайла             = Элементы.Добавить("ТаблицаДанныхФайла", Тип("ТаблицаФормы"));
        ТаблицаДанныхФайла.ПутьКДанным = "ДанныеФайла";
        ТаблицаДанныхФайла.Отображение = ОтображениеТаблицы.Список;
      
        //Добавим колонки
        Для Каждого Колонка Из ТЗ.Колонки Цикл
            НовыйЭлемент = Элементы.Добавить(Колонка.Имя, Тип("ПолеФормы"), ТаблицаДанныхФайла);
            НовыйЭлемент.Вид = ВидПоляФормы.ПолеВвода;
            НовыйЭлемент.ПутьКДанным = "ДанныеФайла." + Колонка.Имя;
        КонецЦикла;  
        ЗначениеВРеквизитФормы(ТЗ,"ДанныеФайла");
    
    Спасибо всем )

Поделиться этой страницей