8.х ОБМЕН Как правильно удалить регистрацию изменений?

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем Yury, 26 апр 2012.

  1. TopicStarter Overlay
    Yury
    Offline

    Yury Опытный в 1С

    Регистрация:
    22 дек 2011
    Сообщения:
    355
    Симпатии:
    4
    Баллы:
    29
    Здравствуйте,

    не могу удалить регистрацию изменений, подскажите в каком направлении искать.
    Вот код отвечающий за удаление изменений:
    Код:
    попытка
    ЧтениеXML = новый ЧтениеXML;
    ЧтениеXML.ОткрытьФайл(ИмяВремФайла);
    ЧтениеСообщения = ПланыОбмена.СоздатьЧтениеСообщения();
    ЧтениеСообщения.НачатьЧтение(ЧтениеXML);
    
    Если ЧтениеСообщения.Отправитель <> УзелИнформационнойБазы тогда
    ОбщегоНазначения.СообщитьОбОшибке("Не совпадает отправитель и узел инф. базы!");
    ЧтениеСообщения.ПрерватьЧтение();
    ЧтениеXML.Закрыть();
    УдалитьФайлы(ИмяВремФайла);
    Возврат;
    КонецЕсли;
    ПланыОбмена.УдалитьРегистрациюИзменений(ЧтениеСообщения.Отправитель, ЧтениеСообщения.НомерПринятого);
    
    Пока ПолучитьXMLТип(ЧтениеXML) <> неопределено цикл
    Если (ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента)И(ЧтениеXML.ЛокальноеИмя = "DataExchange") тогда
    ЧтениеXML.Прочитать();
    СтрокаДанных = ЧтениеXML.Значение;
    Если НЕ ПустаяСтрока(СтрокаДанных) тогда
    ЗаписьТекста = новый ЗаписьТекста(ИмяВремФайлаДанных,"UTF-8");
    ЗаписьТекста.ЗаписатьСтроку(СтрокаДанных);
    ЗаписьТекста.Закрыть();
    Если НЕ ЗагрузитьВБазу(ИмяВремФайлаДанных) тогда
    ЕстьОшибка = Истина;
    Прервать;
    КонецЕсли;
    КонецЕсли;
    ЧтениеXML.Прочитать();
    ЧтениеXML.Прочитать();
    Продолжить;
    КонецЕсли;
    Данные=ПрочитатьXML(ЧтениеXML);
    КонецЦикла;
    
    исключение
    ЕстьОшибка = Истина;
    ОбщегоНазначения.СообщитьОбОшибке(ОписаниеОшибки());
    КонецПопытки;
    
    Косяк в коде или в правилах обмена?
  2. leemuar
    Offline

    leemuar Опытный в 1С

    Регистрация:
    21 окт 2010
    Сообщения:
    310
    Симпатии:
    0
    Баллы:
    26
    Что именно у вас не получается? Выдает какую-то ошибку? Если да - какую?
  3. TopicStarter Overlay
    Yury
    Offline

    Yury Опытный в 1С

    Регистрация:
    22 дек 2011
    Сообщения:
    355
    Симпатии:
    4
    Баллы:
    29
    Нет, ошибок не выдает. Если бы была ошибка было бы легче разобраться.
    Дополнительно могу сказать: для объектов обмена включена авторегистрация.
    Режим запуска толстый клиент, обычное приложение, БД файловая.

    Хоть понять куда копать. По кодам посмотрел везде так делают. Может ли это быть из-за правил обмена? И что там может быть такого, чтоб объекты не снимались с регистрации???

Поделиться этой страницей