8.х ОБМЕН Как правильно настроить риб?

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем konst, 10 авг 2009.

  1. TopicStarter Overlay
    konst
    Offline

    konst Опытный в 1С

    Регистрация:
    17 мар 2009
    Сообщения:
    71
    Симпатии:
    0
    Баллы:
    26
    Необходимо настроить риб между бухгалтериями. Для тестировки взял демо базу БП 1.6. Открыл план обмена Полный заполнил предопределенный элемент назвал его и задал код. Затем добавил еще 1 план, тоже обозвал его и дал ему код, после чего выделил его в списке и нажал кнопку "создать начальный образ". После создания образа добавил в список сущ. базу и зашел в нее.. В результате походу перенеслись кое-какие справочники, но самое главное почему-то не перенеслись в начальный образ документы. Подскажите плиз, что я не так делаю.. как сделать что б перенеслись доки.
  2. TopicStarter Overlay
    konst
    Offline

    konst Опытный в 1С

    Регистрация:
    17 мар 2009
    Сообщения:
    71
    Симпатии:
    0
    Баллы:
    26
    Разобрался и настроил риб между БП. Подскажите плиз как моно реализовать, чтоб при выгрузке из периферии проведенные доки попадали в центральную не проведенными.
  3. TopicStarter Overlay
    konst
    Offline

    konst Опытный в 1С

    Регистрация:
    17 мар 2009
    Сообщения:
    71
    Симпатии:
    0
    Баллы:
    26
    Подскажите плиз как моно определить является ли планобмен центральным узлом или периферийным
  4. TopicStarter Overlay
    konst
    Offline

    konst Опытный в 1С

    Регистрация:
    17 мар 2009
    Сообщения:
    71
    Симпатии:
    0
    Баллы:
    26
    А можно как-то запретить редактирование документа после того как он отправлен в центральный узел
  5. duh
    Offline

    duh Опытный в 1С

    Регистрация:
    21 янв 2009
    Сообщения:
    74
    Симпатии:
    0
    Баллы:
    26
    Код:
    Если Не ПланыОбмена.ИзменениеЗарегистрировано(УзелСклад,ЭтотОбъект) Тогда
    Сообщить("Документ не может быть записан  т.к. он загружен на склад");
    Отказ = Истина;
    КонецЕсли;
    
    
    Вот так можно в процедуре ПриЗаписи(), начнет срабатывать после того как прийдет ответ из центрального узла
  6. TopicStarter Overlay
    konst
    Offline

    konst Опытный в 1С

    Регистрация:
    17 мар 2009
    Сообщения:
    71
    Симпатии:
    0
    Баллы:
    26
    Хочу чтоб после отправки дока в центр, он был недоступен в периферии
    Верно ли предположить, что если в периферии сделали изменение скажем создали док... т.е. изменение зарегистрировано.. Затем отправили этот до в центр т.е. изменение нул(наверно, не зарегистрировано)..

    Потом в модуле формы при открытии
    Если НЕ ПланыОбмена.ГлавныйУзел() = Неопределено Тогда
    Если НЕ ПланыОбмена.ИзменениеЗарегистрировано(ПланыОбмена.Полный.ЭтотУзел(), ЭтотОбъект) Тогда
    ТолькоПросмотр=Истина;
    КонецЕсли;
    КонецЕсли

    Но в периферии чет выдает ошибку у метода ИзменениеЗарегистрировано не верный параметр 1
  7. duh
    Offline

    duh Опытный в 1С

    Регистрация:
    21 янв 2009
    Сообщения:
    74
    Симпатии:
    0
    Баллы:
    26
    правильно ты передаешь текущий узел, попробуй передай ПланыОбмена.ГлавныйУзел(). После отправки в главный регистрация не снимется, только после того как получишь ответ от главного что он его принял

Поделиться этой страницей