7.7 Как правильно делать запись..

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем tmpnikl, 24 янв 2013.

  1. TopicStarter Overlay
    tmpnikl
    Offline

    tmpnikl Опытный в 1С

    Регистрация:
    28 ноя 2012
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    Попросили в кадрах выбрать и перенести сотруд. в другую папку...Сделал внешнюю erp...но при записи куда-то курсор таблицы уходит(если аналогия с таблицами, то там указатель при вводе новой записи уходит в конец файла, здесь трудно что-т сказать, как ведёт себя этот укзатель записи..). точнее курсор берёт одного сотрудника из группы меняет родителяи дальше пропускает всех в этой группе и идёт в следёющую группу..
    Код:
    Процедура Сформировать()
    Ном=Группы.ТекущаяСтрока();\\ это выбор из комбобокса в какую группу переводить
    КодГруппы=Группы.ПолучитьЗначение(Ном);
    Спр=СоздатьОбъект("Справочник.Сотр");
    СпрСотр=СоздатьОбъект("Справочник.Сотр");
    Если КодГруппы <> 0 Тогда
    Если Спр.НайтиПоКоду(КодГруппы)=1 Тогда
    Если СпрСотр.ВыбратьЭлементы()=1 Тогда //справочник позиционирован
    Пока СпрСотр.ПолучитьЭлемент()=1 Цикл
    если  СпрСотр.ЭтоГруппа() = 0 тогда
    если (СпрСотр.Степень_вып=Перечисление.Степень.Маг)  тогда
    СпрСотр.Родитель=Спр.ТекущийЭлемент();
    СпрСтуд.Записать();
    КонецЕсли;
    конецесли;
    КонецЦикла;
    КонецЕсли;
    КонецЕсли;
    конецесли;
    КонецПроцедуры
    
    как сделать, чтоб после записи указатель преходил на следующую запись, а не на следующую группу, так как если этот оператор(Записать) убрать и поставить Сообщить(), то всё нормально..
  2. TopicStarter Overlay
    tmpnikl
    Offline

    tmpnikl Опытный в 1С

    Регистрация:
    28 ноя 2012
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    Всё, разобрался... надо ВыбратьЭлементы(0)=1 Тогда
Похожие темы
  1. ALEX148
    Ответов:
    4
    Просмотров:
    888
  2. TerANik
    Ответов:
    22
    Просмотров:
    737
Загрузка...

Поделиться этой страницей