8.х Как посмотреть список сохраненных документов(не проведенных)?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем neo_rasul, 9 апр 2009.

  1. TopicStarter Overlay
    neo_rasul
    Offline

    neo_rasul Опытный в 1С

    Регистрация:
    29 янв 2009
    Сообщения:
    125
    Симпатии:
    0
    Баллы:
    26
    Хочется найти все сохраненные, но не проведенные документы для их удаления, надо очень. Подскажите пожалуйста, каким образом найти эти все документы?
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Можно воспользоваться Реестром Документов, задать условия отбора. Или написать свою обработочку:)
  3. tunec
    Offline

    tunec Опытный в 1С

    Регистрация:
    2 июн 2008
    Сообщения:
    469
    Симпатии:
    0
    Баллы:
    26
    второй способ: консоль запросов. запрос по документам с условием проведен = ложь.... Самое удобное решение, т.к. можно гибко задавать условия и устраивать группировки и выводить итоги....

    ну или если не важна последующая обработка и писать запросы не умеете есть способ 3й: обработка документов. условие "проведен" галочку снять. нажать "сформировать" и список готов...
  4. Melanto
    Offline

    Melanto Опытный в 1С

    Регистрация:
    28 ноя 2007
    Сообщения:
    204
    Симпатии:
    0
    Баллы:
    26
    ...а можно так...
    Код:
    Для Каждого Объект Из Метаданные.Документы Цикл
    Если Объект.Проведение=Метаданные.СвойстваОбъектов.Проведение.Разрешить Тогда
    СтрокаИмени=Объект.ПолноеИмя();
    //    Сообщить("Документ "+СтрокаИмени);
    Запрос=Новый Запрос;
    Запрос.Текст="
    |ВЫБРАТЬ
    |    Ссылка КАК Ссылка
    |ИЗ
    |    "+СтрокаИмени+"
    |ГДЕ ПРОВЕДЕН = Ложь";
    Результат=Запрос.Выполнить().Выбрать();
    Пока Результат.Следующий() Цикл
    ДокОбъект=Результат.Ссылка.ПолучитьОбъект();
    ДокОбъект.ПометкаУдаления=Истина;
    ДокОбъект.Записать();
    КонецЦикла;
    КонецЕсли;
    КонецЦикла;
    
    
    
    
    Можно добавить перебор Документов из метаданных, но !
    Документы, не имеющие движений по регистрам (Доверенность, СчетНаОплатуПокупателю в БП, например) воспринимаются как НЕПРОВЕДЕННЫЕ...
    Так что либо список, либо руками...

    Добавлено...
  5. TopicStarter Overlay
    neo_rasul
    Offline

    neo_rasul Опытный в 1С

    Регистрация:
    29 янв 2009
    Сообщения:
    125
    Симпатии:
    0
    Баллы:
    26
    спасибо всем. разобрался.
  6. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    Не согласен. У метаданных документов есть свойство Проведение(определяющее, разрешено ли проведение документа или нет), которое вполне можно проверять при переборе.
  7. Melanto
    Offline

    Melanto Опытный в 1С

    Регистрация:
    28 ноя 2007
    Сообщения:
    204
    Симпатии:
    0
    Баллы:
    26
    Посыпаю голову пеплом! Есть! Отберите одну спасибу....

    Просто не случалось пользоваться, но спасибо от меня, век живи - век учись....
    Хотя нет - жить 100 лет - многовато...

Поделиться этой страницей