7.7 Как получить значение?

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем tema-303, 20 сен 2010.

  1. TopicStarter Overlay
    tema-303
    Offline

    tema-303

    Регистрация:
    20 сен 2010
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Подскажите пожалуйста как получить значение лицевого счета ребенка
    из таблицы документа "Начисление Родительской Платы".

    Код:
    Спр=СоздатьОбъект("Документ.РП_Начисление");
    
    Спр.ВыбратьДокументы('01.01.09','01.01.11'); 
    Спр.Выбрать("Выбрать Документ"); 
    Спр.ВыбратьСтроки();
    Спр.ПолучитьСтроку();
    Стр =СокрЛП(Строка(Спр.Ребенок));
    Текст.ДобавитьСтроку(Стр);
    // Стр=[А здесь надо получить лицевой счет]
    Текст.ДобавитьСтроку(Стр);
    Текст.Записать("C:\Пример сальдо 1.txt");
    
    
  2. TopicStarter Overlay
    tema-303
    Offline

    tema-303

    Регистрация:
    20 сен 2010
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Или может есть готовая обработка для обмена реестрами по род. плате с системой "Город"?
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Озвучте конфигурацию
  4. TopicStarter Overlay
    tema-303
    Offline

    tema-303

    Регистрация:
    20 сен 2010
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    1С Предприятие 7.7 Бухгалтерия для бюджетных учреждений.
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Нет под рукой этой конфы.
    Но выглядеть это должно приблизительно так:
    Код:
    Спр=СоздатьОбъект("Документ.РП_Начисление");  
    Спр.ВыбратьДокументы('01.01.09','01.01.11'); 
    Пока Спр.ПолучитьДокумент()=1 Цикл
    Спр.ВыбратьСтроки();
    Пока Спр.ПолучитьСтроку()=1 Цикл
    Стр =СокрЛП(Строка(Спр.Ребенок));
    Текст.ДобавитьСтроку(Стр);
    // Стр=[А здесь надо получить лицевой счет]
    КонецЦикла;
    КонецЦикла;; 
    Текст.Записать("C:\Пример сальдо 1.txt");
    
    
    
  6. TopicStarter Overlay
    tema-303
    Offline

    tema-303

    Регистрация:
    20 сен 2010
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Это понятно, но как вытащить лицевой счет?
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Выложите на файлообменник МДшник - сюда ссылку
  8. TopicStarter Overlay
    tema-303
    Offline

    tema-303

    Регистрация:
    20 сен 2010
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    МДшник не выложить, очень низкий аплоад...
    Был бы очень рад если кто-нибудь поделится готовой ерт-шкой...
  9. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Готовую вряд ли найдешь, а писать, не видя МДшника - почти не реально
  10. TopicStarter Overlay
    tema-303
    Offline

    tema-303

    Регистрация:
    20 сен 2010
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    С лицевым счетом разобрался.
    Не подскажите еще вот что:

    Есть периодический реквизит "Плательщик".
    Его тип в конфигураторе: Справочник.Контрагенты.
    Вот часть кода:
    Код:
    //...
    Пер=СоздатьОбъект("Периодический");
    //...
    Пер.ИспользоватьОбъект("Плательщик",Спр.Ребенок.Контрагент);
    Пер.ВыбратьЗначения(); 
    Пер.ПолучитьЗначение(); 
    Стр=СокрЛП(Пер.Значение); //Здесь выдает ФИО плательщика
    //...
    
    
    А как вытащить адрес этого плательщика?
  11. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    Пер.Значение.Адрес?
  12. TopicStarter Overlay
    tema-303
    Offline

    tema-303

    Регистрация:
    20 сен 2010
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Пишет: Поле агрегатного объекта не обнаружено(Адрес)
  13. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    ну да, нужно посмотреть как называется реквизит. ЮрАдрес или ЮридическийАдрес и тп.. Это же контрагент?
  14. TopicStarter Overlay
    tema-303
    Offline

    tema-303

    Регистрация:
    20 сен 2010
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    На другом форуме посоветовали
    Код:
    СписокДанных=СоздатьОбъект("СписокЗначений");
    ПлательщикАдрес = "";
    Плательщик = Спр.Ребенок.Контрагент.Плательщик.Получить(Спр.ДатаДок);
    Если Плательщик.Выбран()= 1 Тогда  
    СписокДанных.Установить( "Контекст", Плательщик);
    СписокДанных.Установить( "Дата", Спр.ДатаДок );
    СписокДанных.Установить( "ЮрАдресОрганизации", "" );
    глПолучитьДанные(СписокДанных);
    ПлательщикАдрес = СписокДанных.Получить("ЮрАдресОрганизации");
    КонецЕсли; 
    
    
    Вроде подходит.
  15. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    ну и отлично :)
    P.S. я вообще объект "Периодический" никогда не использовал.. все через методы справочника

    P.P.S. ну и если совсем без мутностей..
    Код:
    СписокДанных=СоздатьОбъект("СписокЗначений");
    ПлательщикАдрес = "";
    Плательщик = Спр.Ребенок.Контрагент.Плательщик.Получить(Спр.ДатаДок);
    Если Плательщик.Выбран()= 1 Тогда 
    ПлательщикАдрес = Плательщик.ЮрАдресОрганизации;
    КонецЕсли; 
    

Поделиться этой страницей