8.х Как получить список движений документа по регистрам?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем lorins, 10 апр 2008.

  1. TopicStarter Overlay
    lorins
    Offline

    lorins

    Регистрация:
    28 мар 2008
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    Нижеописанный код позволяет получать в отчете список всех документов конфигурации
    Имеется ли возможность помимо названия документа видеть список движений документа по регистрам?


    Код:
               //Создаю  таблицу со списком всех типов документов
    ТаблицаЗначений = Новый ТаблицаЗначений;
    ТаблицаЗначений.Колонки.Добавить("Наименование");
    Для Каждого Объект ИЗ Метаданные.Документы Цикл
    Стр=ТаблицаЗначений.Добавить();
    Стр.Наименование = Объект.Имя;
    КонецЦикла;	
    КоличествоЗначений=ТаблицаЗначений.Количество();
    
    
    Макет = ОтчетОбъект.ПолучитьМакет("СписокВсехДокументов");
    
    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
    ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
    ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
    ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");
    
    ТабДок.Очистить();
    ТабДок.Вывести(ОбластьЗаголовок);
    ТабДок.Вывести(ОбластьШапкаТаблицы);
    ТабДок.НачатьАвтогруппировкуСтрок();
    
    Для Каждого СтрокаТаблицыЗначений Из ТаблицаЗначений Цикл
    ОбластьДетальныхЗаписей.Параметры.Заполнить(СтрокаТаблицыЗначений);
    ТабДок.Вывести(ОбластьДетальныхЗаписей, 0);
    КонецЦикла;
    
    
    ТабДок.ЗакончитьАвтогруппировкуСтрок();
    ТабДок.Вывести(ОбластьПодвалТаблицы);
    ОбластьПодвал.Параметры.ИтогоСтрок = "Итого строк: " + КоличествоЗначений;
    ТабДок.Вывести(ОбластьПодвал);
    

    Внешний отчет прилагаю
  2. TopicStarter Overlay
    lorins
    Offline

    lorins

    Регистрация:
    28 мар 2008
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    внешний отчет

    Вложения:

  3. AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    Код:
    	Для Каждого Объект ИЗ Метаданные.Документы Цикл
    Стр=ТаблицаЗначений.Добавить();
    Стр.Наименование = Объект.Имя;
    Для Каждого Движение из Объект.Движения Цикл
    Сообщить(Объект.Имя + "  " + Движение.Имя);	
    КонецЦикла;
    КонецЦикла;	 
    
  4. TopicStarter Overlay
    lorins
    Offline

    lorins

    Регистрация:
    28 мар 2008
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    AlexFF, спасибо, все получилось!

Поделиться этой страницей