7.7 Как получить последнюю строчку в справочнике?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем smiler, 6 окт 2008.

  1. TopicStarter Overlay
    smiler
    Offline

    smiler

    Регистрация:
    6 окт 2008
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Доброго времени суток.
    Есть форма, через которую оператор записывает в справочник "Справочник.ПоказанияСчетчика" факт оплаты за услугу, тобишь новые показания счётчика.
    Есть отчёт, который вываливает на печать все эти оплаты.
    Нужно в другом отчёте в печатную форму добавить ПОСЛЕДНЮЮ строчку (тоесть самую последнюю, самую "свежую") строчку из вышеобозначенного отчёта.
    Отчёт всех оплат реализован так:

    Код:
    Процедура ПечатьСчетчик()  
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Счетчик");
    Счетчик.ВыбратьСтроки();
    Таб.ВывестиСекцию("Шапка");
    
    СпрСчетчики = СоздатьОбъект("Справочник.ПоказанияСчетчика");
    СпрСчетчики.ИспользоватьВладельца(ТекущийЭлемент()); 
    СпрСчетчики.ВыбратьЭлементы();  
    НомСт=0; 
    Пока СпрСчетчики.ПолучитьЭлемент() = 1 Цикл
    Ст=0;
    Ном=0;
    История = СоздатьОбъект("Периодический");
    История.ИспользоватьОбъект("ПоказанияСчетчика",СпрСчетчики.ТекущийЭлемент());
    История.ВыбратьЗначения();
    Пока История.ПолучитьЗначение() = 1 Цикл  
    Если Ст=0 Тогда
    НомСт=НомСт+1;
    Таб.ВывестиСекцию("Счетчик");   
    Ст=1;
    КонецЕсли;
    Ном=Ном+1;             
    Таб.ВывестиСекцию("Строка");
    КонецЦикла;     
    КонецЦикла;
    
    Таб.ВывестиСекцию("Подвал");
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Справка по счетчикам",,1);
    КонецПроцедуры // Печать
    
    
    Вопрос, как "выбрать" из справочника "Справочник.ПоказанияСчетчика" самые свежие показания?
    Спасибо.
  2. TopicStarter Overlay
    smiler
    Offline

    smiler

    Регистрация:
    6 окт 2008
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    можно конечно их все сравниваь, но это сложно..
    просто нужно как-то обратиться к самой последней строчке..
  3. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Почитай про эти методы справочника:
    ОбратныйПорядок()
    ПорядокКодов();
    ПорядокНаименований();
    ПорядокРеквизита();
  4. TopicStarter Overlay
    smiler
    Offline

    smiler

    Регистрация:
    6 окт 2008
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    в общем мне надо повернуть выборку попой к верху и взять первую строчку.. я так понял?
  5. TopicStarter Overlay
    smiler
    Offline

    smiler

    Регистрация:
    6 окт 2008
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    вопрос снят ;)
  6. TopicStarter Overlay
    smiler
    Offline

    smiler

    Регистрация:
    6 окт 2008
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    разобрался )
    Спасибо WaRDeR за пинок в нужном направлении ;)
  7. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    А зачем тебе цикл? бери первое "ПолучитьЗначение" и работай с ним.
    Ну если надо несколько - тогда цикл + прерывание в нужном моменте.

    Удачи :)

Поделиться этой страницей