8.х Как получить название таблицы?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Pest, 3 май 2008.

  1. TopicStarter Overlay
    Pest
    Offline

    Pest

    Регистрация:
    28 апр 2008
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Приветствую!

    На форме есть страницы, на каждой таблчное поле и кнопочка, требуется в обработчике кнопочки получить имя таблицы таблицы (для работы с оной) с текущей страницы. Подскажите плиз как.

    Спасибо )
  2. gamser
    Offline

    gamser Опытный в 1С

    Регистрация:
    27 окт 2006
    Сообщения:
    112
    Симпатии:
    0
    Баллы:
    26
    Код:
    Для каждого ЭлементФормы из ЭлементыФормы Цикл
    Если ТипЗнч(ЭлементФормы)=Тип("ТабличноеПоле") Тогда
    Если ЭлементФормы.Имя="ТвоеИмя" Тогда
    ф=1;
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;
    
    

Поделиться этой страницей