8.х Как получить из Запроса значения кроме обхода циклом

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Ivan2014, 15 июл 2014.

  1. TopicStarter Overlay
    Ivan2014
    Offline

    Ivan2014 Опытный в 1С

    Регистрация:
    10 апр 2014
    Сообщения:
    384
    Симпатии:
    2
    Баллы:
    29
    Прошу помочь. Не много глупый вопрос.
    Бывает из запроса получаю одно единственное значение, например, когда использую виртуальную таблицу "Срез последних".
    Как в этом случае получить значения не используя код:
    Код:
    Таблица=Запрос.Выполнить().Выгрузить();
         Для Каждого Элемент Из Таблица Цикл
                     Значение=Элемент;
    КонецЦикла;
    
    Как в этом случае можно сократить код?
  2. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.980
    Симпатии:
    398
    Баллы:
    104
    Код:
    Выборка = Запрос.Выполнить().Выбрать();
    Выборка.Следующий();
    ВашеЗначение = Выборка.ВашеЗначение;
    Ivan2014 нравится это.
  3. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Нужно добавить проверку
    Код:
    Если Выборка.Следующий() Тогда
        ВашеЗначение = Выборка.ВашеЗначение;
    КонецЕсли;
    
    Иначе словим ошибку при пустом запросе ;)
    Ivan2014 нравится это.
  4. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    Код:
    Таблица=Запрос.Выполнить().Выгрузить();
        // Для Каждого Элемент Из Таблица Цикл
      Если Не Таблица.Количество() = 0 Тогда                Значение=Таблица[0]["ИмяВашегоРеквизита"];
    КонецЕсли;
    //КонецЦикла;
    Ivan2014 нравится это.

Поделиться этой страницей