8.х Как получить имя каталога на веб клиенте

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Antipod13, 5 сен 2019.

  1. TopicStarter Overlay
    Antipod13
    Offline

    Antipod13

    Регистрация:
    6 дек 2017
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Ничего в интернете не нашел, все что есть выдает ошибку об ограничении использования модальных окон.
  2. Катюфка
    Offline

    Катюфка Профессионал в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    537
    Симпатии:
    83
    Баллы:
    54
    Здравствуйте.
    А так не подойдет?

    Код:
    &НаКлиенте
    Процедура ПоместитьФайлИнтерактивно(Команда)
        ОбработкаОкончанияПомещения = Новый ОписаниеОповещения
            ("ОбработчикОкончанияПомещения", ЭтотОбъект);
    
        НачатьПомещениеФайла(ОбработкаОкончанияПомещения, , , Истина,     
            ЭтотОбъект.УникальныйИдентификатор);
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ОбработчикОкончанияПомещения(Результат, Адрес, 
            ВыбранноеИмяФайла, ДополнительныеПараметры) Экспорт
        Если Результат Тогда
            Сообщить(ВыбранноеИмяФайла);
        Иначе
            Сообщить("Файл не был помещен.");
        КонецЕсли 
    КонецПроцедуры