7.7 Как получить цену из Справочника в Докуменнт

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем geba, 23 июн 2010.

  1. TopicStarter Overlay
    geba
    Offline

    geba

    Регистрация:
    27 авг 2009
    Сообщения:
    41
    Симпатии:
    0
    Баллы:
    1
    Конфигурация

    Есть справочник.номенклатура Вкладка Цены, там таблица с разными ценами.(накладная и расчетная.)

    Документ.ЗаданиеНаБХС. Как вытянуть цену сирья расчетную в документ
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Вы чем упаковывали? 7-Zip 9.09, WinRar сообщают об ошибке в архиве...
  3. TopicStarter Overlay
    geba
    Offline

    geba

    Регистрация:
    27 авг 2009
    Сообщения:
    41
    Симпатии:
    0
    Баллы:
    1
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Там есть справочник Цены который в свою очередь подченетн справочнику ТМЦ.
    Для ТМЦ1 например получить цену так:
    Код:
    Цена=0;
    ЗаЕдиницу="";
    Спр=СоздатьОбъект("Справочник.Цены");
    Спр.ИспользоватьВладельца(ТМЦ1);
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    Если Спр.ПометкаУдаления()=1 Тогда Продолжить; КонецЕсли;
    Если Спр.КатегорияЦены=НужнаяКатегоря Тогда
    Цена=Спр.Цена.Получить(ДатаДок);
    ЗаЕдиницу=Спр.Единица.Получить(ДатаДок);
    Прервать;
    КонецЕсли;
    КонецЦикла;
    
    
    
    
    
    В данном случае:
    НужнаяКатегория это элемент справочника КатегорииЦен (можете завести константу или выбирать в диалоговой форме - дело вкуса)
    ДатаДок - дата документа ЗаданиеНаБХС (т.к. я понимаю вычисление будет происходить внутри именно этого документа)
  5. TopicStarter Overlay
    geba
    Offline

    geba

    Регистрация:
    27 авг 2009
    Сообщения:
    41
    Симпатии:
    0
    Баллы:
    1
    Код:
    Цена=0;
    ЗаЕдиницу="";
    Спр=СоздатьОбъект("Справочник.Цены");
    Спр.ИспользоватьВладельца(Слой1);
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    Если Спр.ПометкаУдаления()=1 Тогда Продолжить; КонецЕсли;
    Если КатегорияЦены=Категоря Тогда
    Цена=Спр.Цена.Получить(ДатаДок);
    ЗаЕдиницу=Спр.Единица.Получить(ДатаДок);
    Прервать;
    КонецЕсли;
    КонецЦикла;
    
    
    Делаю для Слой1

    Выдает
    Если КатегорияЦены<<?>>=Категоря Тогда
    {Документ.ЗаданиеБХС.Форма.Модуль(78)}: Переменная не определена (КатегорияЦены)

    Что не так???
    Код:
    Цена=0;
    ЗаЕдиницу="";
    Спр=СоздатьОбъект("Справочник.Цены");
    Спр.ИспользоватьВладельца(Слой1);
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    Если Спр.ПометкаУдаления()=1 Тогда Продолжить; КонецЕсли;
    Если КатегорияЦены=Категоря Тогда
    Цена=Спр.Цена.Получить(ДатаДок);
    ЗаЕдиницу=Спр.Единица.Получить(ДатаДок);
    Прервать;
    КонецЕсли;
    КонецЦикла;
    
    
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Спр.КатегорияЦены
  7. TopicStarter Overlay
    geba
    Offline

    geba

    Регистрация:
    27 авг 2009
    Сообщения:
    41
    Симпатии:
    0
    Баллы:
    1
    А как завести константу, чето не пойму???
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В конфигураторе... Новая константа, тип - справочник.КатегорииЦен
  9. TopicStarter Overlay
    geba
    Offline

    geba

    Регистрация:
    27 авг 2009
    Сообщения:
    41
    Симпатии:
    0
    Баллы:
    1
    Не етоя понял как ее в процедуру включить и прсвоить значение справочник.КатегорииЦен "расчетная"
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Значение присваиваете в режиме предприятия (Меню-Операции-Константы)
    В обработке же:
    Код:
    Если КатегорияЦены=Константа. Категоря Тогда   // Категоря - имя новой константы
    
    

Поделиться этой страницей