8.х Как перезаписать данные РегистраСведений , которые были выбранные запросом.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем alp, 10 май 2010.

  1. TopicStarter Overlay
    alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    Код:
    Код:
    Запрос = Новый Запрос;
    Запрос.Текст=
    "ВЫБРАТЬ
    |	ОбновлениеДанных.Пользователь,
    |	ОбновлениеДанных.Закладка,
    |	ОбновлениеДанных.Обновление
    |ИЗ
    |	РегистрСведений.ОбновлениеДанных КАК ОбновлениеДанных
    |ГДЕ
    |	ОбновлениеДанных.Пользователь = &Пользователь
    |	И ОбновлениеДанных.Закладка = &Закладка";
    
    Запрос.УстановитьПараметр("Пользователь",Пользователь);
    Запрос.УстановитьПараметр("Закладка",Закладка);
    Результат = Запрос.Выполнить();
    Если Результат.Пустой() Тогда
    Возврат Неопределено;
    КонецЕсли;
    Выборка = Результат.Выбрать();
    Пока Выборка.Следующий() Цикл
    .......................................................................
    //Как перезаписать данные ?? Здесь ресурс обновление имеет тип "Булево" и 
    // имеет занчение "Истина", мне надо поменять их на "Ложь".
    
    
    
    Подскажите как это зделать ???
  2. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.410
    Симпатии:
    316
    Баллы:
    104
    У вас регистр сведений независимый? Переодический?
    Не хотите использовать МенеджерЗаписи (РегистрСведенийНаборЗаписей)?
  3. TopicStarter Overlay
    alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    Не завимый и не периодический, Вы имеете ввиду так:?
    Код:
    Выборка = РегистрыСведений.ОбновлениеДанных.Выбрать(Отбор);
    Пока Выборка.Следующий() Цикл
    МенеджерЗаписи =Выборка.ПолучитьМенеджерЗаписи(); 
    МенеджерЗаписи.Обновление = Значение;
    МенеджерЗаписи.Записать();
    КонецЦикла;	
    
    
    
  4. gosn1ck
    Offline

    gosn1ck Опытный в 1С

    Регистрация:
    13 авг 2009
    Сообщения:
    1.329
    Симпатии:
    1
    Баллы:
    26
    Код:
    НаборЗаписей = РегистрыСведений.Валюты.СоздатьНаборЗаписей(); 
    НаборЗаписей.Отбор.Период.Установить(ДатаЗаписи); 
    
    НаборЗаписей.Прочитать(); 
    
    Для Каждого Запись Из НаборЗаписей Цикл 
    
    // Чтение и сообщение данных полей записи. 
    Сообщить(Строка(Запись.Период) + " " + Строка(Запись.Валюта) + " " + Строка(Запись.Курс)); 
    
    // Изменение данных полей записи. 
    Запись.Курс = 0; 
    
    КонецЦикла; 
    
    НаборЗаписей.Записать();
    
  5. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.410
    Симпатии:
    316
    Баллы:
    104
    Уже ответили. Запрос не нужен будет.
  6. Максим
    Offline

    Максим Опытный в 1С

    Регистрация:
    28 фев 2008
    Сообщения:
    688
    Симпатии:
    8
    Баллы:
    29
    Вам нужно присваивать значение не только этому ресурсу типа булево, но и всем остальным иначе они будут пустыми
  7. TopicStarter Overlay
    alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    Всем спасибо за помощь!

Поделиться этой страницей