8.х Как пересчитать данные по всем строкам в таблице?

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем loginnn, 8 июн 2010.

  1. TopicStarter Overlay
    loginnn
    Offline

    loginnn

    Регистрация:
    31 май 2010
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    Всем доброго времени суток.

    У меня такая проблема не как не могу пересчитать данные по всем строкам табличной части.
    Добавал сам числовое поле ввода в форму. На процедуру его изменения повесил обработку в которой забиваю весь нужный столбец одним значение которое было указано в числовом поле ввода.

    Но надо еще чтобы в данном столбце по всем строкачкам выполнялся пересчет у меня он сейчас выполняется только по одной строке, по той которая активна (выделена)

    Как сделать так, чтобы при заполнении всего столбца пересчитывались все строки таблицы, а не только выделенная???

    вот мой код

    Код:
    Процедура ВводСкидкаПриИзменении(Элемент)
    Для Каждого ЭлементСписка Из Товары Цикл
    ЭлементСписка.ПроцентСкидкиНаценки = ЭлементыФормы.Скидка.Значение;
    
    СтрокаТабличнойЧасти = ЭлементыФормы.Товары.ТекущиеДанные;
    // Рассчитать реквизиты табличной части.
    ОбработкаТабличныхЧастей.РассчитатьСуммуТабЧасти(СтрокаТабличнойЧасти, ЭтотОбъект);
    ОбработкаТабличныхЧастей.РассчитатьСуммуНДСТабЧасти(СтрокаТабличнойЧасти, ЭтотОбъект);
    КонецЦикла;
    КонецПроцедуры
    
    
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.548
    Симпатии:
    716
    Баллы:
    204
    Код:
    Процедура ВводСкидкаПриИзменении(Элемент) 
    Для Каждого ЭлементСписка Из Товары Цикл
    ЭлементСписка.ПроцентСкидкиНаценки = ЭлементыФормы.Скидка.Значение;
    //СтрокаТабличнойЧасти = ЭлементыФормы.Товары.ТекущиеДанные; // Рассчитать реквизиты табличной части.
    ОбработкаТабличныхЧастей.РассчитатьСуммуТабЧасти(ЭлементСписка, ЭтотОбъект);
    ОбработкаТабличныхЧастей.РассчитатьСуммуНДСТабЧасти(ЭлементСписка, ЭтотОбъект);
    КонецЦикла;
    КонецПроцедуры
    
    
  3. TopicStarter Overlay
    loginnn
    Offline

    loginnn

    Регистрация:
    31 май 2010
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    Большое спасибо за помощь новичку

Поделиться этой страницей