8.х Как передать значение реквизита формы документа в открываемый справочник

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем denis_msz, 15 фев 2011.

  1. FUX
    Offline

    FUX

    Регистрация:
    10 сен 2011
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Кому интересен ниже приведен код из моего модуля. Задача стояла передать значение склада , счета и фирмы в справочник номенклатура, непосредственно в самом справочнике имелась процедура по определению остатков по по выбранному складу и фирме, но имеется различие от вышеизложенного примера, в документе в самой таблице выбираются непосредсвенно счета и уже потом аналитика к данным счетам и уже если счет выбирался товары, тогда возникала необходимость в передачи в справочник значений склад , счет и фирма.

    Код:
    Процедура ТМЦТМЦ1НачалоВыбора(Элемент, СтандартнаяОбработка)
    СтрокаТЗ=Элементыформы.ТМЦ.ТекущаяСтрока;
    Если СтрокаТЗ.СчетТМЦ = ПланыСчетов.Основной.A217_1 Тогда
    СтандартнаяОбработка = ложь;
    Форма		 = Справочники.Номенклатура.ПолучитьФормуВыбора(,Элемент);
    Форма.Склад   = Склад.Ссылка;
    Форма.Счет    = СтрокаТЗ.СчетТМЦ;
    Форма.Фирма   = Фирма;
    
    
    Если СтрокаТЗ.ТМЦ1 <> Справочники.Номенклатура.ПустаяСсылка() Тогда
    Форма.ЭлементыФормы.СправочникСписок.ТекущаяСтрока = СтрокаТЗ.ТМЦ1;
    ВыбраннаяНоменклатура = СтрокаТЗ.ТМЦ1;
    Иначе ВыбраннаяНоменклатура = 0;
    КонецЕсли;
    
    СтрокаТЗ.ТМЦ1 = Форма.ОткрытьМодально();
    
    Если ЗначениеЗаполнено(СтрокаТЗ.ТМЦ1) Тогда
    ТМЦТМЦ1ПриИзменении(Элемент);
    ИначеЕсли ВыбраннаяНоменклатура <> 0 Тогда
    СтрокаТЗ.ТМЦ1=ВыбраннаяНоменклатура;
    ТМЦТМЦ1ПриИзменении(Элемент);
    ИначеЕсли ВыбраннаяНоменклатура = 0 Тогда
    СтрокаТЗ.ТМЦ1=Справочники.Номенклатура.ПустаяСсылка();
    КонецЕсли;
    
    СтрокаТЗ.ТМЦ2 = Склад.Ссылка;
    КонецЕсли;
    КонецПроцедуры
    
    

Поделиться этой страницей