[РЕШЕНО] Как передать переменную с клиента на сервер?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Nik02071, 3 апр 2015.

  1. TopicStarter Overlay
    Nik02071
    Offline

    Nik02071 Опытный в 1С

    Регистрация:
    12 ноя 2008
    Сообщения:
    347
    Симпатии:
    1
    Баллы:
    29
    На клиенте получил значение переменной. Как передать ее на сервер используя ВременноеХранилище?
    Код:
    &НаСервереБезКонтекста
    Процедура  ПечатьТ13НаСервере()
        // Получить ссылку документа на сервере
       
       
        ДатаДок= ПолучитьИзВременногоХранилища("Адр2");
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ПечатьТ13(Команда)
                         
    Массив=    Табель.ВыгрузитьЗначения();
    Для Каждого  Элемент Из Массив цикл
        //Получить номер документа
        НомДок=Сред(Элемент,7,12);
        ДатаДок=Прав(Элемент,10);
        //ДатаДок=Дата(ДатаДок);
        День=Лев(ДатаДок,2);
         Год=Прав(ДатаДок,4);
          Месяц=Сред(ДатаДок,4,2);
           ДатаДок=Год+Месяц+День;
            Дата=Дата(ДатаДок);
        //Сообщить(ТипЗнч(Дата));
        //Сообщить(Дата);
       
       
       
    КонецЦикла;
    //Ид1=Новый УникальныйИдентификатор;
    //Адр1=ПоместитьВоВременноеХранилище(НомДок);
    //Ид2=Новый УникальныйИдентификатор;
    Адр2=ПоместитьВоВременноеХранилище(Дата);
    
    
    
        ПечатьТ13НаСервере();
    КонецПроцедуры
    
    --- Объединение сообщений, 3 апр 2015 ---
    Говорит неправильный путь к файлу Адр2
    Последнее редактирование: 3 апр 2015
  2. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    ПолучитьИзВременногоХранилища, не?
    --- Объединение сообщений, 3 апр 2015 ---
    предположу, исходя из описания СП
    Код:
    ПоместитьВоВременноеХранилище(Дата, "Адр2");
  3. TopicStarter Overlay
    Nik02071
    Offline

    Nik02071 Опытный в 1С

    Регистрация:
    12 ноя 2008
    Сообщения:
    347
    Симпатии:
    1
    Баллы:
    29
    Спасиобо! разобрался

Поделиться этой страницей