7.7 Как передать Форма.Параметр в поле ввода?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Asttoxa, 8 сен 2011.

  1. TopicStarter Overlay
    Asttoxa
    Offline

    Asttoxa Опытный в 1С

    Регистрация:
    18 май 2010
    Сообщения:
    525
    Симпатии:
    0
    Баллы:
    26
    Есть поле ввода на форме типа справочник. При его вызове нужно передать в Форму списка справочника параметр.
    Ума не приложу как передать параметр в форму списка. Знаю как передать параметр если вызывать метод подбора, но это для многострочной части!
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    На форме в процедуре формы ПриНачалеВыбораЗначения передаете параметр через ПараметрФормы. В форме списка ловим параметр в процедуре ПриОткрытии
  3. TopicStarter Overlay
    Asttoxa
    Offline

    Asttoxa Опытный в 1С

    Регистрация:
    18 май 2010
    Сообщения:
    525
    Симпатии:
    0
    Баллы:
    26
    За процедуру спасибо. Никогда ей не пользовался поэтому не знал :(
    Как перехватывать понял. Как в форме списка ловить и распознавать Форма.Параметр знаю только не совсем понял как направить нужный контент в Форма.Параметр. В процедуре я долежн к чему то присвоить? К какой переменной я должен присвоить чтобы она попала в Форму списка??

    Процедура ПриНачалеВыбораЗначения(ИдентЭлемДиалога, ФлагСтандОбр)

    Если ИдентЭлемДиалога = "ТехникаКлиента" Тогда
    Переменная="Зер гуд";
    КонецЕсли;

    КонецПроцедуры
  4. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Как-то так:
    Код:
    Процедура ПриНачалеВыбораЗначения(ИдентЭлемДиалога, ФлагСтандОбр)
    Если ИдентЭлемДиалога = "ТехникаКлиента" Тогда
    ФлагСтандОбр = 0;
    Переменная = "Зер гуд";
    ОткрытьПодбор("Справочник.ИмяСправочника", "ИмяФормы", Переменная, 0, ТехникаКлиента);
    КонецЕсли;
    КонецПроцедуры
    
  5. TopicStarter Overlay
    Asttoxa
    Offline

    Asttoxa Опытный в 1С

    Регистрация:
    18 май 2010
    Сообщения:
    525
    Симпатии:
    0
    Баллы:
    26
    А вон оно что.... Тоесть мы запрещаем открывать по своему и открываем сами. Тогда понятно. Спасибо.

Поделиться этой страницей