7.7 Как открыть существующий подчиненный документ

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем M a x i m, 19 окт 2009.

  1. TopicStarter Overlay
    M a x i m
    Offline

    M a x i m Опытный в 1С

    Регистрация:
    6 окт 2008
    Сообщения:
    212
    Симпатии:
    0
    Баллы:
    26
    Добрый день.
    Есть Расходная накладная, на основании которой создается документ Удостоверение качества. Хочу сделать обработку для кнопки в форме Расх.накл., которая находит подчиненное Уд.кач-ва и обновляет его табличную часть согласно док.родителю. Это нужно в тех случаях, когда вносятся изменения в документ-родитель и нужно, чтобы эти изменения кликом по кнопи отразились в подч. документе. Я добился успешного поиска подчиненного дока, но не могу открыть его форму. Как?

    собссно код:
    Код:
    Процедура ОбновитьУдКачества(); 
    
    НаличиеУдКач = 0;
    УдКач = СоздатьОбъект("Документ"); 
    УдКач.ВыбратьПодчиненныеДокументы(, , ТекущийДокумент());
    Пока УдКач.ПолучитьДокумент() = 1 Цикл
    Если УдКач.Вид() = "УдостоверениеКачества" Тогда
    Сообщить("Найдено " + УдКач);
    ОткрытьФорму("УдКач", ,);
    НаличиеУдКач = НаличиеУдКач + 1;
    КонецЕсли;
    КонецЦикла;
    
    Если НаличиеУдКач = 0 Тогда                
    Предупреждение("Удостоверение качества для данной отгрузки не существует");
    ИначеЕсли НаличиеУдКач > 1 Тогда
    Предупреждение("Внимание, для данной отгрузки существует " + НаличиеУдКач + " удостоверений качества. Обновлено будет удостоверение, которое найдено последним.");
    КонецЕсли;   
    
    
    ОткрытьФорму(УдКач,,ТекущийДокумент());
    
    КонецПроцедуры //ОбновитьУдКачества
    
    

    p.s. ПУБ 2.6
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    Процедура ОбновитьУдКачества(); 
    ТекДок="";
    НаличиеУдКач = 0;
    УдКач = СоздатьОбъект("Документ"); УдКач.ВыбратьПодчиненныеДокументы(, , ТекущийДокумент());
    Пока УдКач.ПолучитьДокумент() = 1 Цикл
    Если УдКач.Вид() = "УдостоверениеКачества" Тогда
    Сообщить("Найдено " + УдКач);
    ТекДок=УдКач.ТекущийДокумент();
    НаличиеУдКач = НаличиеУдКач + 1;
    КонецЕсли;
    КонецЦикла;
    Если НаличиеУдКач = 0 Тогда                
    Предупреждение("Удостоверение качества для данной отгрузки не существует");
    ИначеЕсли НаличиеУдКач > 1 Тогда
    Предупреждение("Внимание, для данной отгрузки существует " + НаличиеУдКач + " удостоверений качества. Обновлено будет удостоверение, которое найдено последним.");
    КонецЕсли;
    Если ПустоеЗначение(ТекДок)=0 Тогда
    ОткрытьФорму(ТекДок);
    КонецЕсли;
    КонецПроцедуры //ОбновитьУдКачества
    
    
    
  3. TopicStarter Overlay
    M a x i m
    Offline

    M a x i m Опытный в 1С

    Регистрация:
    6 окт 2008
    Сообщения:
    212
    Симпатии:
    0
    Баллы:
    26
    Спасибо, заработало.

Поделиться этой страницей