7.7 Как открыть конкретную процедуру из внешней обработки

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем x(mxcrew), 11 ноя 2009.

  1. TopicStarter Overlay
    x(mxcrew)
    Offline

    x(mxcrew)

    Регистрация:
    11 ноя 2009
    Сообщения:
    36
    Симпатии:
    0
    Баллы:
    1
    Подскажите

    Есть внешняя обработка, необходимо по расписанию автоматически вызывать ее и нажимать на кнопку (вызывать конкретную процедуру).

    С расписанием я разобрался но со второй частью никак не могу разобраться.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Програмно из самой обработки нажимать кнопку?

    Код:
    //перед вызовом внешней процедуры
    Парам=СоздатьОбъект("СписокЗначений");
    Парам.Установить("Наждать","Нажать");
    ОткрытьФорму("Отчет",Парам,ПутьОбработка);
    
    //в обработке:
    Процедура ПриОткрытии()
    
    Парам=Форма.Параметр;
    Если ПустоеЗначение(Парам)=0 Тогда
    Если Парам.Получить("Нажать")="Нажать" Тогда
    ВыпролимНужнуюПроцедуру();
    КонецЕсли;
    КонецЕсли;
    
    КонецПроцедуры
    
    
    
  3. TopicStarter Overlay
    x(mxcrew)
    Offline

    x(mxcrew)

    Регистрация:
    11 ноя 2009
    Сообщения:
    36
    Симпатии:
    0
    Баллы:
    1
    Большое спасибо все получилось.

    Огромное СПАСИБО!!!

Поделиться этой страницей