7.7 Как открыть два dbf файла?

Тема в разделе "Обмен данными в "1С:Предприятие 7.7"", создана пользователем rusrmm, 14 мар 2011.

  1. TopicStarter Overlay
    rusrmm
    Offline

    rusrmm

    Регистрация:
    25 фев 2009
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Добрый день, попытался открыть два dbf файла для добовления информации из одного в другой, невышло((

    Вообще это возможно?

    как делал:

    Код:
    ИмяФайла = ФС.НайтиПервыйФайл(ПутьКПапкеСdbfФайлами+"*.dbf");
    Файл = СоздатьОбъект("XBASE");
    ИмяФайла2 = ФС.НайтиПервыйФайл(ПутьКПапкеСdbfФайлами2+"*.dbf");
    Файл2 = СоздатьОбъект("XBASE");
    
    Пока ПустаяСтрока(ИмяФайла) = 0 Цикл
    Если (ИмяФайла <> "..") И (ИмяФайла <> ".") Тогда 
    Файл.ОткрытьФайл(ПутьКПапкеСdbfФайлами+ИмяФайла,"");
    сообщить(ИмяФайла);
    Файл.КодоваяСтраница(1);
    Файл.Первая();   
    Пока Файл.ВКонце()=0 Цикл 
    Пока ПустаяСтрока(ИмяФайла2) = 0 Цикл
    Если (ИмяФайла2 <> "..") И (ИмяФайла2 <> ".") Тогда 
    Файл2.ОткрытьФайл(ПутьКПапкеСdbfФайлами2+ИмяФайла2,"");
    сообщить(ИмяФайла);
    Файл2.КодоваяСтраница(1);
    Файл2.Первая();
    Пока Файл2.ВКонце()=0 Цикл
    
    
    
    ************************
    
    ************************
    
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;
    КонецЕсли;
    Файл.ЗакрытьФайл();
    ИмяФайла = ФС.НайтиСледующийФайл();       
    КонецЦикла;
    
    КонецПроцедуры
    
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    А отладчиком пройтись?

    Что именно не получилось?

    По приведенному коду вообще сложно что-то сказать. Могу лишь предположить, что ошибка тут
    Код:
    Файл.ЗакрытьФайл();
    
    Т.к. закрываешь файл, который еще не открыл.
Похожие темы
  1. Алексей1989
    Ответов:
    2
    Просмотров:
    459
Загрузка...

Поделиться этой страницей