7.7 как определить формулу для подсчета кол-ва коробок ?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Чайник, 14 авг 2008.

  1. TopicStarter Overlay
    Чайник
    Offline

    Чайник

    Регистрация:
    16 июл 2008
    Сообщения:
    20
    Симпатии:
    0
    Баллы:
    1
    уже сбился...

    вот что есть в цикле :

    Код:
    //ПечФорма = "Накладная";
    Язык = глЯзык(); 	
    Таб.ИсходнаяТаблица(Название);
    глУстПропись(Валюта,Язык);
    
    ПечОснование=глСтрокаОснование(Контекст,Договор,ДокументОснование);	
    
    Фирма.ИспользоватьДату(ДатаДок,1);
    Таб.ВывестиСекцию("Шапка");
    Ном = 1;
    ВСоставе = 0;
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл                
    Если Набор.Выбран()=1 Тогда
    Если ПустоеЗначение(ВСоставе)=1 Тогда
    Таб.ВывестиСекцию("ВСоставе");
    ВСоставе=Набор;
    ИначеЕсли ВСоставе<>Набор Тогда
    Таб.ВывестиСекцию("ВСоставе");
    ВСоставе=Набор;
    КонецЕсли;
    Иначе
    Если ПустоеЗначение(ВСоставе)=0 Тогда
    ВСоставе=0;
    КонецЕсли;
    КонецЕсли;
    ПечЦена = глФРМ(глПересчет(ЦенаБезНДС,Валюта,Курс,ВП,ДатаДок),ВП,0);
    ПечСумма = глФРМ(глПересчет(СуммаБезСкидки,Валюта,Курс,ВП,ДатаДок),ВП,0);
    Таб.ВывестиСекцию("Строка");
    Ном = Ном+1;
    КонецЦикла;
    Если Итог("СуммаСкидки")<>0 Тогда
    ПечСкидка = глФРМ(глПересчет(Итог("СуммаСкидки"),Валюта,Курс,ВП,ДатаДок),ВП,0);
    Таб.ВывестиСекцию("Скидка");    
    КонецЕсли;
    ПечБезНДС = глФРМ(глПересчет(Итог("СуммаБезНДС"),Валюта,Курс,ВП,ДатаДок),ВП,0);
    ПечНДС = глФРМ(глПересчет(Итог("СуммаСНДС") - Итог("СуммаБезНДС"),Валюта,Курс,ВП,ДатаДок),ВП,0);
    ПечСНДС = глФРМ(глПересчет(Итог("СуммаСНДС"),Валюта,Курс,ВП,ДатаДок),ВП,0);	
    ПечНДСПропись = " "+Формат(глПересчет(Итог("СуммаСНДС") - Итог("СуммаБезНДС"),Валюта,Курс,ВП,ДатаДок),"Ч12.2")+" "+ВП.Кратко;
    ПечСНДСПропись = глСуммаПрописью(глПересчет(Итог("СуммаСНДС"),Валюта,Курс,ВП,ДатаДок),ВП);  
    Таб.ВывестиСекцию("Дно");
    //Если БыстраяПечать = 1 Тогда
    //	Таб.ПараметрыСтраницы(,,,,,,,,,1,,);
    //	Таб.КоличествоЭкземпляров(Константа.ПечКолЭкзНакладнойПриБыстройПродаже);
    //	Таб.Напечатать(глОтладка);
    //Иначе	
    Таб.Защита(Константа.ФлагЗащитыТаблиц);
    Таб.ТолькоПросмотр(1);
    Таб.Опции(0,0,,);
    Таб.Показать("ПЕЧАТЬ: Расходная накладная","");
    


    вот и все....

    ни**** понять не могу, темболее колонки ( Мест ) в цикле нету...
  2. TopicStarter Overlay
    Чайник
    Offline

    Чайник

    Регистрация:
    16 июл 2008
    Сообщения:
    20
    Симпатии:
    0
    Баллы:
    1
    вот что вышло :

    Код:
        Ном=1;
    Вмест=0;
    Сорт = СоздатьОбъект("ТаблицаЗначений");
    Сорт.НоваяКолонка("Мест");
    Сорт.Мест = ?(Товар.Мест = 0,0,Количество/Товар.Мест);
    Сорт.Сортировать("1+");
    Сорт.ВыбратьСтроки();
    Пока Сорт.ПолучитьСтроку() = 1 Цикл
    Таб.ВывестиСекцию("Строка");
    КонецЦикла;
    КонецПроцедуры
    
    
    но считает в 0 !!!

    Хелп.....
  3. Kaboom
    Offline

    Kaboom Опытный в 1С

    Регистрация:
    2 июл 2007
    Сообщения:
    158
    Симпатии:
    0
    Баллы:
    26
    Код:
    ВСоставе = 0;
    ИтогоМест = 0; //<-----------
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл                
    Если Набор.Выбран()=1 Тогда
    Если ПустоеЗначение(ВСоставе)=1 Тогда
    Таб.ВывестиСекцию("ВСоставе");
    ВСоставе=Набор;
    ИначеЕсли ВСоставе<>Набор Тогда
    Таб.ВывестиСекцию("ВСоставе");
    ВСоставе=Набор;
    КонецЕсли;
    Иначе
    Если ПустоеЗначение(ВСоставе)=0 Тогда
    ВСоставе=0;
    КонецЕсли;
    КонецЕсли;
    ПечЦена = глФРМ(глПересчет(ЦенаБезНДС,Валюта,Курс,ВП,ДатаДок),ВП,0);
    ПечСумма = глФРМ(глПересчет(СуммаБезСкидки,Валюта,Курс,ВП,ДатаДок),ВП,0);
    Таб.ВывестиСекцию("Строка");
    Ном = Ном+1;
    ИтогоМест = ИтогоМест + ?(Товар.Мест = 0,0,Количество/Товар.Мест);//<-----------
    КонецЦикла;
    
    В секцию "Дно", в ячейку "Мест" нужно вставить ИтогоМест#Ч015.2 и также установить вид как Выражение
  4. bob
    Offline

    bob Опытный в 1С

    Регистрация:
    7 май 2008
    Сообщения:
    386
    Симпатии:
    0
    Баллы:
    26
    Итог
    Вычислить сумму по колонке таблицы значений.

    Синтаксис:

    Итог(<Колонка>)

    Англоязычный синоним:

    Total

    Параметры:

    <Колонка>
    Номер или идентификатор колонки, по которой считать сумму.


    Возвращаемое значение:

    Сумма по колонке.

    Описание:

    Метод Итог вычисляет сумму по заданной колонке таблицы значений.

    Пример:

    Табл.Итог(2);

Поделиться этой страницей