8.х Как обратиться к внешней печатной форме в бухгалтерии 3.0

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Heisenberg, 15 янв 2015.

  1. TopicStarter Overlay
    Heisenberg
    Offline

    Heisenberg

    Регистрация:
    15 янв 2015
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Собственно, сабж.

    Есть обработка в бух-ии 2.0, где в ТЗ выносится список ссылок на Счета-фактуры.
    После чего для каждой выбранной СФ, печатаю ее с помощью внешней печатной формы:

    Код:
    Процедура ПечатьСФ(Объект)
    ДеревоМакетовПечати = УниверсальныеМеханизмы.ПолучитьДеревоМакетовПечати(Объект.Ссылка, Объект.ПолучитьСтруктуруПечатныхФорм());
    Макеты = ПреобразоватьДеревоВСписок(ДеревоМакетовПечати);
    Если Объект.ВидСчетаФактуры = Перечисления.ВидСчетаФактурыВыставленного.НаАванс Тогда
    СтрМакета = ДеревоМакетовПечати.Строки.Найти("СПбЦСС_СчетФактура1137 (На аванс)", "Текст");
    Иначе
    СтрМакета = ДеревоМакетовПечати.Строки.Найти("СПбЦСС_СчетФактура1137", "Текст");
    КонецЕсли;
    Если (СтрМакета<>Неопределено) И (СтрМакета.Расшифровка<>Неопределено) И (ТипЗнч(СтрМакета.Расшифровка)=Тип("Структура")) И (СтрМакета.Расшифровка.СсылкаНаВнешнююОбработку<>Неопределено) Тогда
    ТабДокумент = Новый ТабличныйДокумент;
    ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_СчетФактураВыданный_СчетФактура1137";
    ТабДокумент = НапечататьВнешнююФорму(Объект.Ссылка, СтрМакета.Расшифровка, НаПечать);
    УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 0, НаПечать, ОбщегоНазначения.СформироватьЗаголовокДокумента(Объект, Объект.Метаданные().Представление()), НаПечать, Объект.Ссылка);
    Иначе
    Объект.Печать(СтрМакета.Значение, , НаПечать, НаПечать);
    КонецЕсли;
    КонецПроцедуры
    Как реализовать подобное в бухгалтерии 3.0?
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.760
    Симпатии:
    509
    Баллы:
    204
    На управляемых формах кодили когда-нибудь ?
  3. TopicStarter Overlay
    Heisenberg
    Offline

    Heisenberg

    Регистрация:
    15 янв 2015
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Да, кодил. Внешняя форма уже написана под 3.0, теперь нужно понять как открыть ее из обработки. В 2.0 делал так, как описано выше, но в 3.0 многих функций и модулей из 2.0 не существует или они были переименованы.
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.760
    Симпатии:
    509
    Баллы:
    204
    Если у вас это форма обработки, можно попробывать через ЭтотОбъект.
  5. TopicStarter Overlay
    Heisenberg
    Offline

    Heisenberg

    Регистрация:
    15 янв 2015
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Не совсем Вас понял. Вопрос заключается в том, как называются в новой версии бухгалтерии функции, действующие аналогично вышеописанным. Что в них передается и т.д..
  6. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.760
    Симпатии:
    509
    Баллы:
    204
    Пффф, ну вы спросили....некоторых вообще может не быть.
  7. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
  8. TopicStarter Overlay
    Heisenberg
    Offline

    Heisenberg

    Регистрация:
    15 янв 2015
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Нашел сотню гайдов как создать внешнюю печатную форму, но как ее программно использовать - ни одного. Не может же быть, что это невозможно.

    Спасибо, но не нашел там своей ситуации.
  9. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.760
    Симпатии:
    509
    Баллы:
    204
    По сути вам нужно написать заново код :), так проще и быстрее будет. Если в коде не разбираетесь - советую обратиться к спецам, фриланс никто не отменял :)

Поделиться этой страницей