8.х Как обойти дату запрета изменения данных для определенного документа?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Asintelekt, 26 авг 2009.

  1. TopicStarter Overlay
    Asintelekt
    Offline

    Asintelekt Опытный в 1С

    Регистрация:
    23 авг 2008
    Сообщения:
    59
    Симпатии:
    0
    Баллы:
    26
    Платформа – 1С:Предприятие 8.1 (8.1.14.72)
    Конфигурация - Зарплата и Управление Персоналом, редакция 2.5 (2.5.14.3)

    В конфигурации сделаны следующие настройки:
    1) Установлена даты запрета изменения данных (Сервис – Пользователи и права доступа – Установка даты запрета изменения данных).
    2) Дата запрета применяется для всех пользователей (Предприятие – Настройка параметров учета – Применять дату запрета для пользователей с «Полными правами» (Истина)).
    Есть пара документов, которые надо редактировать до даты запрета, как решить данную задачу?

    Заранее спасибо!
  2. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Общие модули НастройкаПравДоступа и ПолныеПрава. Их процедуры кури.

    Вообще можно было не задавать вопрос, а запустить отладчик в момент записи и просто просмотреть входы в процедуры. Там все прозрачно.
  3. TopicStarter Overlay
    Asintelekt
    Offline

    Asintelekt Опытный в 1С

    Регистрация:
    23 авг 2008
    Сообщения:
    59
    Симпатии:
    0
    Баллы:
    26
    Я целый день пытался сделать и каждый раз думал, что все прозрачно:)
    Но где-то все время вылазили косяки.
    Два пункта точно правильно сделал:
    1) Закоментил в этих доках в Событии "приОткрытии" проверку даты редактирования.
    2) Снял источник в подписях на события для документов

    Но так же есть подписи на регистры, с которыми мучаюсь целый день:(
  4. TopicStarter Overlay
    Asintelekt
    Offline

    Asintelekt Опытный в 1С

    Регистрация:
    23 авг 2008
    Сообщения:
    59
    Симпатии:
    0
    Баллы:
    26
    А в регистрах делал так:


    Код:
    Процедура ПередЗаписьюРегистраНакопленийПроверкаДоступностиПериода(Источник, Отказ, Замещение) Экспорт
    Если Источник.Отбор.Регистратор.Значение.Ссылка.Метаданные() <> Документы.УвольнениеИзОрганизаций.ПустаяСсылка().Метаданные() Тогда //Asintelekt
    
    ПроверкаПериодаЗаписейРегистров(Источник, Отказ, "РегистрНакопления");
    КонецЕсли; //Asintelekt
    
    #Если Клиент Тогда
    
    Если Отказ Тогда
    Сообщить("Редактирование данных этого периода запрещено. Изменения не могут быть записаны...", СтатусСообщения.Важное);
    КонецЕсли;
    #КонецЕсли
    
    КонецПроцедуры // ПередЗаписьюРегистраНакопленийПроверкаДоступностиПериода
    
    Код:
    Процедура ПередЗаписьюРегистраСведенийПроверкаДоступностиПериода(Источник, Отказ, Замещение) Экспорт
    Если Источник.Отбор.Регистратор.Значение.Ссылка.Метаданные() <> Документы.УвольнениеИзОрганизаций.ПустаяСсылка().Метаданные() Тогда //Asintelekt
    
    ПроверкаПериодаЗаписейРегистров(Источник, Отказ, "РегистрСведений");    
    КонецЕсли; //Asintelekt    
    
    #Если Клиент Тогда
    
    Если Отказ Тогда
    Сообщить("Редактирование данных этого периода запрещено. Изменения не могут быть записаны...", СтатусСообщения.Важное);
    КонецЕсли;
    #КонецЕсли
    
    КонецПроцедуры // ПередЗаписьюРегистраСведенийПроверкаДоступностиПериода
    

    В итоге ошибка при проведении:
    http://xmage.ru/view.php?id=4ktgwl8z

Поделиться этой страницей