8.х Как изменить реквизит в РегистреСведений

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем v0233, 2 апр 2011.

  1. TopicStarter Overlay
    v0233
    Offline

    v0233 Опытный в 1С

    Регистрация:
    23 авг 2010
    Сообщения:
    167
    Симпатии:
    0
    Баллы:
    26
    Добрый день, хочу изменить реквизит через запрос но у меня не получается выдает ошибку, (побывал ссылку но так же ошибка).

    Код:
    	 ЗапросДолг=Новый запрос;
    ЗапросДолг.Текст="Выбрать Период, Долг, ОтчиталсяЗаДолг из РегистрСведений.ДолгиМастеров Где ОтчиталсяЗадолг=ЛОЖЬ И Мастер=&Мастер";
    ЗапросДолг.УстановитьПараметр("Мастер",Мастер);
    ВДолг=ЗапросДолг.Выполнить().Выбрать();
    
    
    Пока ВДолг.Следующий()>0 Цикл
    Объект=Вдолг.ПолучитьОбъект(Вдолг.ОтчиталсяЗаДолг);
    Объект=Истина;
    
    КонецЦикла; 
    
  2. sergejk74
    Offline

    sergejk74 Опытный в 1С

    Регистрация:
    15 ноя 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Если непременно через запрос то попробуй так

    Код:
        Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    |    ДолгиМастеров.Мастер,
    |    ДолгиМастеров.ОтчиталсяЗаДолг,
    |    ДолгиМастеров.Период,
    |    ДолгиМастеров.Долг
    |ИЗ
    |    РегистрСведений.ДолгиМастеров КАК ДолгиМастеров
    |ГДЕ
    |    ДолгиМастеров.Мастер = &Мастер
    |    И (НЕ ДолгиМастеров.ОтчиталсяЗаДолг)";
    
    Запрос.УстановитьПараметр("Мастер", Мастер);
    Результат = Запрос.Выполнить();
    Если Не Результат.Пустой() Тогда
    ВыборкаДетальныеЗаписи = Результат.Выбрать();
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    Набор = РегистрыСведений.ДолгиМастеров.СоздатьНаборЗаписей();
    Набор.Отбор.Мастер.Установить(ВыборкаДетальныеЗаписи.Мастер);
    Набор.Отбор.Период.Установить(ВыборкаДетальныеЗаписи.Период);
    Запись = Набор.Добавить();
    Запись.Период = ВыборкаДетальныеЗаписи.Период;
    Запись.Мастер = ВыборкаДетальныеЗаписи.Мастер;
    Запись.ОтчиталсяЗаДолг = Истина;
    Запись.Долг = ВыборкаДетальныеЗаписи.Долг;
    Набор.Записать();
    КонецЦикла;
    КонецЕсли;
    
    

Поделиться этой страницей