7.7 Как изменить Обработку V77Exp.ert что бы она не выгружала определенные документы

Тема в разделе "Обмен данными в "1С:Предприятие 7.7"", создана пользователем Bond_HD, 3 дек 2013.

  1. TopicStarter Overlay
    Bond_HD
    Offline

    Bond_HD

    Регистрация:
    3 дек 2013
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Я выгружаю данные из одной Торговля и Склад 7.7 в другую, используя стандартные обработки выгрузки загрузки (V77Exp.ert) "Конвертацию данных" на платформе 8,2. В базе источник, в нужном мне документе, сделал реквизит ФлВыгрузки, на форме его размещаю как флажок. Нужно мне следующее, мне нужно дополнить обработку (или правило точно не знаю), так чтобы обработка не выгружала(пропускала) те документы в которых флажок нажат, а остальные выгружала как обычно.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В КД перед выгрузкой объекта
    Код:
     Если Объект.ВашРеквизит=0 Тогда
    Отказ = 1;
    КонецЕсли;
    
  3. TopicStarter Overlay
    Bond_HD
    Offline

    Bond_HD

    Регистрация:
    3 дек 2013
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Выдает ошибку говорит:

    ПВД_ПередВыгрузкойОбъекта_Реализация<<?>>(ИмяПКО, Правило, Объект, ИсходящиеДанные, ВходящиеДанные)
    Функция не обнаружена (ПВД_ПередВыгрузкойОбъекта_Реализация)
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
  5. TopicStarter Overlay
    Bond_HD
    Offline

    Bond_HD

    Регистрация:
    3 дек 2013
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    [​IMG]

    Пробовал и так
    Если Объект.ФлВыгрузки=1 Тогда
    Отказ = 1;
    КонецЕсли;

    Результат не меняется
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    не в правилах конвертации объекта....А в свойствах конвертации (на правилах 2 раза ЛКМ)! И еще (раз у вас флаг только в самой реализации)..
    Код:
    Если ТипЗначенияСтр(Объект) = "Документ" Тогда
    Если (Объект.Вид() = "Реализация") Тогда
    Если (Объект.ФлВыгрузки=0) Тогда //наверное тут так
    Отказ = 1;
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    
  7. TopicStarter Overlay
    Bond_HD
    Offline

    Bond_HD

    Регистрация:
    3 дек 2013
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    можно немного поконкретнее как в эти "свойства конвертации" попасть ?
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    я уже написал... 2 раза ЛКМ по правилам.

Поделиться этой страницей