8.х Как использовать функцию НайтиПоСсылкам()

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Bkmz, 14 июл 2017.

  1. TopicStarter Overlay
    Bkmz
    Offline

    Bkmz Опытный в 1С

    Регистрация:
    6 июл 2013
    Сообщения:
    430
    Симпатии:
    12
    Баллы:
    29
    Вот такой код:

    Код:
    Процедура НайтиСсылкиНажатие(Элемент)
        Если ЗначениеЗаполнено(Номенклатура) Тогда
            СписокНоменклатуры = Новый Массив;
            СписокНоменклатуры.Добавить(Номенклатура);
            МассивДокументов = Новый Массив;
            Для каждого Документ Из Метаданные.Документы Цикл
                МассивДокументов.Добавить(Документ);
            КонецЦикла;
            СсылкиНаДоки = НайтиПоСсылкам(СписокНоменклатуры, МассивДокументов);   
        КонецЕсли;
    КонецПроцедуры
    Дает мне вот такой результат:

    [​IMG]


    В чем ошибка? По встроенной справке не понятно что ему надо
    Последнее редактирование: 14 июл 2017
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    9.347
    Симпатии:
    973
    Баллы:
    204
    Скриншот результата в сообщение вставьте в виде картинки, а не ссылки на сторонний ресурс.
  3. bajiepka
    Offline

    bajiepka Профессионал в 1С

    Регистрация:
    26 сен 2014
    Сообщения:
    448
    Симпатии:
    30
    Баллы:
    54
    Попробуйте добавить в массив ссылок на метаданные один документ
  4. 1с-ник
    Offline

    1с-ник Профессионал в 1С Заблокирован

    Регистрация:
    5 окт 2014
    Сообщения:
    998
    Симпатии:
    162
    Баллы:
    104
    Нужно внимательней читать С-П.
    Код:
    СсылкиНаДоки = НайтиПоСсылкам(СписокНоменклатуры, Новый Массив, МассивДокументов); 

Поделиться этой страницей