7.7 Как "добраться" до документа

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Kashey, 28 ноя 2008.

  1. TopicStarter Overlay
    Kashey
    Offline

    Kashey

    Регистрация:
    11 ноя 2008
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    получить ссылку на документ, на основании которого было введено это субконто

    не следующий код ругается "Поле агрегатного объекта не обнаружено (ВыбратьОперации)"
    что не так я делаю?

    Код:
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты,, 1);
    Ит.ИспользоватьСубконто(ВидыСубконто.Договоры,, 1);
    Ит.ВключатьСубсчета(-1,);
    Ит.ВыполнитьЗапрос(, ВыбКонПериода,,,, 1,"Операция", "С");
    Ит.ВыбратьСчета();
    Пока Ит.ПолучитьСчет()=1 Цикл
    Ит.ВыбратьСубконто(1);	
    Пока Ит.ПолучитьСубконто(1) = 1 Цикл
    Таб.ВывестиСекцию("Субконто1");
    Ит.ВыбратьСубконто(2);
    Пока Ит.ПолучитьСубконто(ВидыСубконто.Договоры) = 1 Цикл 
    Ит.ВыбратьОперации();
    Пока Ит.ПолучитьОперацию()=1 Цикл
    Док=Ит.Операция.Документ;
    Cообщить (Док);
    КонецЦикла;
    Таб.ВывестиСекцию("Субконто2");
    КонецЦикла;
    КонецЦикла;
    КонецЦикла;
    
  2. MagTux
    Offline

    MagTux Опытный в 1С

    Регистрация:
    28 ноя 2008
    Сообщения:
    58
    Симпатии:
    0
    Баллы:
    26
    У меня не очень большой опыт работы с бух. итогами, но...
    Метода ВыбратьОперации() и ПолучитьОперацию() у итогов не существует. Используй методы ВыбратьПериоды() и ПолучитьПериод().
  3. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    Код:
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");   
    Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты,, 1);    
    Ит.ИспользоватьСубконто(ВидыСубконто.Договоры,, 1);   
    Ит.ВключатьСубсчета(-1,);    
    Ит.ВыполнитьЗапрос(, ВыбКонПериода,,,, 1,"Операция", "С");    Ит.ВыбратьСчета();    
    Пока Ит.ПолучитьСчет()=1 Цикл 
    Ит.ВыбратьСубконто(1);
    Пока Ит.ПолучитьСубконто(1) = 1 Цикл
    Таб.ВывестиСекцию("Субконто1");
    Ит.ВыбратьСубконто(2);
    Пока Ит.ПолучитьСубконто(ВидыСубконто.Договоры) = 1 Цикл
    Ит.ВыбратьПериоды();
    Пока Ит.ПолучитьПериод()=1 Цикл
    Док=Ит.Операция;
    Cообщить (Док);
    КонецЦикла;
    Таб.ВывестиСекцию("Субконто2");
    КонецЦикла;
    КонецЦикла;
    КонецЦикла;
    
    
    
    :unsure:

Поделиться этой страницей