8.х Как добавить фактическое количество в пересчет товаров.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Артемka, 21 май 2015.

  1. TopicStarter Overlay
    Артемka
    Offline

    Артемka Опытный в 1С

    Регистрация:
    13 июл 2014
    Сообщения:
    74
    Симпатии:
    1
    Баллы:
    29
    Есть терминал сбора данных Casio dt-930 который через блютус передает текстовый файлик со штрихкодами. Из этого файлика нужно загружать в тч документов номенклатуру и количество.

    Во внешней обработке сделал табличную часть в которую загружаю данные из файла затем хочу данные перегрузить в тч нужного документа.
    С простыми документами нет проблем а в "пересчете товаров" надо к нужной номенклатуре подставить фактическое количество. Как это лучше реализовать?

    Код:
    Процедура ВыгрузитьВДокументНаСервере()
       Если ТипЗнч(Объект.ДокументДляЗагрузки) = Тип("ДокументСсылка.ПоступлениеТоваров") Тогда
            Документ = Объект.ДокументДляЗагрузки.ПолучитьОбъект();
            Документ.Товары.Очистить();
            Для Каждого Строка Из Объект.Товары Цикл
            Док = Документ.Товары.Добавить();
            Док.Номенклатура = Строка.Номенклатура;
            Док.Количество = Строка.Количество;
            Док.КоличествоУпаковок = Строка.Количество;
            Док.Цена = Строка.Цена
        КонецЦикла;
            Документ.Записать(РежимЗаписиДокумента.Запись);
        КонецЕсли;
    
        Если ТипЗнч(Объект.ДокументДляЗагрузки) = Тип("ДокументСсылка.ПересчетТоваров") Тогда
    
        ..............
    
         КонецЕсли;
    
Похожие темы
  1. ramzes80
    Ответов:
    1
    Просмотров:
    1.987
  2. jumper
    Ответов:
    1
    Просмотров:
    810
  3. Katrin
    Ответов:
    7
    Просмотров:
    614
  4. Thunder
    Ответов:
    10
    Просмотров:
    848
  5. НиколайН
    Ответов:
    0
    Просмотров:
    146
Загрузка...

Поделиться этой страницей