7.7 Как добавить еще одну печатную форму

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Beregmira, 20 май 2011.

  1. TopicStarter Overlay
    Beregmira
    Offline

    Beregmira

    Регистрация:
    6 май 2011
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Проблема:
    В ЗиК в приказах на прием-увольнения требуется вести два варианта формы при выводе на печать, то есть, в зависимости от того, кто будет подписывать документ - руководители, либо заместители по доверенности. :aua:

    Что хочется:
    Добавить к кнопке печати список с выбором добавленной новой формы. :D

    Такой выбор есть в некоторых формах Приказов, хочу такую же к другим.

    Спасибо, всем кто откликнется! :angry:
  2. yzek
    Offline

    yzek Опытный в 1С

    Регистрация:
    13 окт 2010
    Сообщения:
    713
    Симпатии:
    0
    Баллы:
    26
    Как вариант:
    1. В форме документа объявляете переменные
    Код:
    Перем СписокПечатныхФорм, Вариант;
    
    2. Там же создаете список значений
    Код:
    СписокПечатныхФорм = СоздатьОбъект("СписокЗначений"); 
    СписокПечатныхФорм.ДобавитьЗначение("Вариант1","Для подписи руководителя"); 
    СписокПечатныхФорм.ДобавитьЗначение("Вариант2","Для подписи доверенного лица");
    
    3. Привязываете к кнопке процедуру
    Код:
    ПоКнопкеВыбор(СписокПечатныхФорм);
    
    4. В процедуре, присваиваете переменной Вариант значение
    Код:
    Процедура ПоКнопкеВыбор(СписокПечатныхФорм)
    Перем Значение;
    Если СписокПечатныхФорм.ВыбратьЗначение(Значение,,,,1)>0 Тогда
    Если Значение="Вариант1" Тогда   
    Вариант = 1;
    ИначеЕсли Значение="Вариант2" Тогда
    Вариант = 2;             
    КонецЕсли;
    КонецЕсли;
    
    5. И в процедуре печати
    Код:
    Таб=СоздатьОбъект("Таблица");
    Если Вариант=1 Тогда
    Таб.ИсходнаяТаблица("Таблица1"); //Таблица1 - исходная таблица
    ИначеЕсли Вариант=2 Тогда
    Таб.ИсходнаяТаблица("Таблица2"); //Таблица2 - таблица, которую вам нужно подготовить
    КонецЕсли;
    
    Удачи.
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не совсем хорошо.... Каждый раз теперь при обновлении помнить что есть доп. код. Лучше бы сделать через дополнительную печатную форму.
  4. SirStefan
    Offline

    SirStefan Опытный в 1С

    Регистрация:
    20 апр 2010
    Сообщения:
    79
    Симпатии:
    0
    Баллы:
    26
    По моему в ЗиК на этих документах нет механизма внешних печатных форм.
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В ЗиК вообще нет механизма регистрации печатных форм. Я просто не совсем до конца выразился - нужно через доп. возможности.

Поделиться этой страницей