7.7 Как через ADO записать значение ячейки в Excel?

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем РЕК, 10 мар 2008.

  1. TopicStarter Overlay
    РЕК
    Offline

    РЕК

    Регистрация:
    10 янв 2008
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Подскажите, пожалуйста! Не получается...Вот код:

    Код:
    Если ИмяФайла="" Тогда
    ВыбФайл();
    КонецЕсли;
    ВыбЛиста();
    DB = СоздатьОбъект("ADODB.Connection");
    rs = СоздатьОбъект("ADODB.Recordset");
    DB.ConnectionString = "Provider=Microsoft.Jet.OLEDB.4.0; Data Source="+ИмяФайла+"; Extended Properties=""Excel 8.0;"+?(флХедер=1,"","HDR=NO;")+"IMEX=1""";
    DB.Mode = 3;
    DB.Open();
    Тов = СоздатьОбъект("Справочник.Товары");
    ТекСтрока = 0;
    ТекСтрокаМинус=0;
    Пока rs.EOF=0 Цикл  
    КодТовара = СокрЛП(rs.Fields.Item(6).Value);
    Если Тов.НайтиПоКоду(КодТовара)=1 Тогда
    Сообщить("Найден товар "+ Тов.Наименование);
    rs.Fields.Item(5).Value = Строка(Тов.CODE_DOM);
    
    Иначе
    ТекСтрокаМинус=ТекСтрокаМинус+1;
    Сообщить("нет");
    КонецЕсли;
    ТекСтрока = ТекСтрока + 1;
    rs.MoveNext();
    КонецЦикла;
    Сообщить("Всего: "+Строка(Число(ТекСтрока)-Число(ТекСтрокаМинус)));
    rs.UpdateBatch();
    rs.Close();
    DB.Close();
    rs="";
    DB="";
    

Поделиться этой страницей