8.х Как блокировать всплывающие диалоговые окна?

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем worker-good, 13 июл 2011.

  1. TopicStarter Overlay
    worker-good
    Offline

    worker-good

    Регистрация:
    13 июл 2011
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Доброго времени суток!
    В результате выполнения внешней обработки в конфигурации УПП, несколько раз выдается диалоговое сообщение: "Установить счета бух. и налогового учета в соответствии со значениями по умолчанию?" "Да", "Нет". Как изменить внешнюю обработку, чтобы диалоговое сообщение не выводилось, а все автоматически было "Да"?

    Текст внешней обработки:
    Код:
    Процедура Сформировать() Экспорт
    Выборка = Документы.РеализацияТоваровУслуг.Выбрать(Дата1,КонецДня(Дата2));
    Пока Выборка.Следующий() Цикл
    Если Не Выборка.ПометкаУдаления и Выборка.Проведен Тогда
    Док = Выборка.ПолучитьОбъект();
    Сообщить(СокрЛП(Выборка.Ссылка));
    Док.ОтражатьВБухгалтерскомУчете=Истина;
    Док.ОтражатьВНалоговомУчете=Истина;
    Если Не СчетаУчетаВДокументах.ИнтерактивноПерезаполнитьСчетаУчета(Док, Истина, Новый Структура("Товары,ВозвратнаяТара,Услуги,СоставНабора"), Истина, Истина) Тогда
    Сообщить(СокрЛП(Выборка.Ссылка) +" - Счета БУ и НУ не установлены!",СтатусСообщения.ОченьВажное);
    Иначе
    Док.Записать(РежимЗаписиДокумента.Проведение);
    КонецЕсли;
    
    КонецЕсли;
    КонецЦикла;
    Предупреждение("Обработка завершена!");
    КонецПроцедуры
    
    Заранее благодарен.
  2. shurikvz
    Online

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Проблема у вас в вызове этой функции: СчетаУчетаВДокументах.ИнтерактивноПерезаполнитьСчетаУчета().
    Попробуйте использовать вместо нее "СчетаУчетаВДокументах.ЗаполнитьСчетаУчетаТабличнойЧасти()".

    Upd:
    Или процедуру объекта "ЗаполнитьСчетаУчетаШапки()".

Поделиться этой страницей