7.7 Как автоматом создать дополнительный документ при проведении основного?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Berserk, 25 май 2010.

  1. TopicStarter Overlay
    Berserk
    Offline

    Berserk

    Регистрация:
    11 янв 2010
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте, господа эксперты.
    Нужна ваша помощь в решении данной задачи.
    Ситуация следующая:
    у нас в базе, при работе с материалами, сначала создается складское перемещение (требование-накладная), а затем перемещение в производство. Так вот, хотелось бы чтобы, чтобы при проведении складского перемещения, перемещение в производство создавалось автоматически, сохранялось,но не проводилось, сохраняя часть данных из складского перемещения (номенклатуру и склад приемник).

    Вопрос заключается в том, насколько это возможно и есть ли какие-то подводные камни?
    Моих скудных познаний, пока что хватило только на это :
    Процедура ПриЗаписи()
    ......
    ДокВпроизв = СоздатьОбъект("Документ.ТребованиеНакладная");
    ДокВпроизв.Новый();
    ДокВпроизв.Записать();
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Правильно мыслите...
    Только:

    1) Не при записи, а при закрытии
    2) код приблизительно такой

    Код:
    Процедура ПриЗакрытии()
    
    Если Выбран()=1 Тогда //документ действительно записали
    //т.к. документ млжет закрываться несколько раз, проверим - вдруг уже есть
    Док = СоздатьОбъект("Документ");
    Док.ВыбратьПодчиненныеДокументы(,,ТекущийДокумент());
    УжеЕсть=0;
    Пока Док.ПолучитьДокумент()=1 Цикл
    Если Док.Вид()="ТребованиеНакладная" Тогда
    УжеЕсть=1;
    Прервать; //нашли
    КонецЕсли;
    КонецЦикла;
    Если УжеЕсть=0 Тогда
    //здесть создаем документ - код у вас есть
    КонецЕсли;
    КонецЕсли;
    
    
    
    
    3) Маленький совет. Для того чтобы ничего не пропустить при заполнении реквизитов ТребованиеНакладная посмотрите в ней процедуру ВводНового и сделайте по аналогии

Поделиться этой страницей