7.7 Как автоматически изменить константу ДатаЗапретаРедактирования

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем Максим, 18 ноя 2010.

  1. TopicStarter Overlay
    Максим
    Offline

    Максим Опытный в 1С

    Регистрация:
    28 фев 2008
    Сообщения:
    684
    Симпатии:
    7
    Баллы:
    29
    Здравствуйте!
    1С ТиС 7.7 :angry:
    Нужно чтобы при смене рабочей, менялось значение константы "ДатаЗапретаРедактирования".
    Можно ли подвязаться к какому-нибудь обработчику событий? Или как ни-будь по другому реализовать?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В глобальном модуле:

    Код:
    Процедура ПриНачалеРаботыСистемы()
    ...
    //тут можно еще проверку поставить на больше-меньше чтобы
    //ушлый юзер не баловался с системной датой
    Константа.ДатаЗапретаРедактирования=ТекущаяДата()-1;
    //установили дату запрета на вчерашний день
    ...
    КонецПроцедуры
    
    
  3. TopicStarter Overlay
    Максим
    Offline

    Максим Опытный в 1С

    Регистрация:
    28 фев 2008
    Сообщения:
    684
    Симпатии:
    7
    Баллы:
    29
    А если, 1с не закрывали на ночь это сработает?
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Нет не сработает
    Надо тогда так:
    Код:
    Процедура ОбработкаКонтроля()
    //необходимо учесть ушлость юзеров + добавить еще одну константу
    //которая бы отключала проверку - иначе задним числом ничего уже не поправите сами))))
    Если Константа.ДатаЗапретаРедактирования<ТекущаяДата()-1 Тогда
    Константа.ДатаЗапретаРедактирования=ТекущаяДата()-1;
    КонецЕсли
    КонецПроцедуры
    Процедура ПриНачалеРаботыСистемы()
    ...
    ОбработкаОжидания("ОбработкаКонтроля",1200);
    ..
    КонецПроцедуры
    
    
    
    
    

Поделиться этой страницей