8.х УПП КА Поступление из переработки

Тема в разделе ""1С:Управление производственным предприятием УПП"", создана пользователем Новичок55, 17 мар 2011.

  1. TopicStarter Overlay
    Новичок55
    Offline

    Новичок55

    Регистрация:
    17 мар 2011
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    не проводится документ поступление из переработки

    ошибка:

    Ошибка при выполнении обработчика - 'ОбработкаПроведения'
    по причине:
    {ОбщийМодуль.УправлениеЗапасами.Модуль(865)}: Ошибка при вызове метода контекста (Выполнить)

    по причине:

    по причине:
    {(21, 1)}: Несовместимые типы
    <<?>>Док.ЗаказРезерв.Заказчик КАК ЗаказчикВнутреннегоЗаказа,


    подскажите пожалуйста что я делаю не так?
  2. Наташа
    Offline

    Наташа Опытный в 1С

    Регистрация:
    14 авг 2010
    Сообщения:
    1.442
    Симпатии:
    2
    Баллы:
    29
    Конфа типовая?
  3. TopicStarter Overlay
    Новичок55
    Offline

    Новичок55

    Регистрация:
    17 мар 2011
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1

    да типовая. нашла в итс что в документе нужно указывать заказ с видом операции "переработка"
    но в КА нет возможности выбрать эту операцию. это скорее всего для УПП или БУХ
  4. afinogen
    Offline

    afinogen Опытный в 1С

    Регистрация:
    28 фев 2011
    Сообщения:
    160
    Симпатии:
    0
    Баллы:
    26
    текст запроса выкладывайте
  5. TopicStarter Overlay
    Новичок55
    Offline

    Новичок55

    Регистрация:
    17 мар 2011
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1

    Код:
    Функция СформироватьЗапросПоТабличнойЧасти(ДокументОбъект, ИмяТабличнойЧасти, СтруктураПолей,
    СтруктураСложныхПолей = Неопределено) Экспорт
    
    
    ТекстЗапроса = "";
    
    ДокументМетаданные = ДокументОбъект.Метаданные();
    
    Для Каждого Реквизит Из СтруктураПолей Цикл
    
    ТекстЗапроса  = ТекстЗапроса + ",
    |Док." + Реквизит.Значение + 
    " КАК " + СокрЛП(Реквизит.Ключ);
    
    КонецЦикла;
    
    ТекстСоединение="";
    
    Запрос = Новый Запрос;
    
    Если ТипЗнч(СтруктураСложныхПолей) = Тип("Структура") Тогда // Добавим к запросу конструкции.
    
    Для Каждого Элемент Из СтруктураСложныхПолей Цикл
    
    ТекстЗапроса  = ТекстЗапроса + ",
    | " + Элемент.Значение + 
    " КАК " + СокрЛП(Элемент.Ключ);
    
    КонецЦикла;
    
    Если СтруктураСложныхПолей.Свойство("Проект") Тогда
    
    ТекстСоединение="
    |ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.УстановкаПроектовДляНоменклатуры.СрезПоследних(&ДатаДок, НоменклатураПроекта В (ВЫБРАТЬ Номенклатура ИЗ Документ." + ДокументМетаданные.Имя + "."+ СокрЛП(ИмяТабличнойЧасти) + " ГДЕ Ссылка = &ДокументСсылка)) КАК ПроектыНоменклатуры
    |ПО Док.Номенклатура=ПроектыНоменклатуры.НоменклатураПроекта";
    
    Запрос.УстановитьПараметр("ДатаДок",ДокументОбъект.Дата);
    
    
    КонецЕсли;
    
    КонецЕсли;
    
    Запрос.Текст = "ВЫБРАТЬ 
    | Док.НомерСтроки " + ТекстЗапроса + "
    | ИЗ 
    |      Документ." + ДокументМетаданные.Имя + "."+ СокрЛП(ИмяТабличнойЧасти) + 
    " КАК Док"+ТекстСоединение+" 
    |     ГДЕ Док.Ссылка = &ДокументСсылка
    | УПОРЯДОЧИТЬ ПО 
    | 		Док.НомерСтроки";
    
    
    // Установим параметры запроса.
    Запрос.УстановитьПараметр("ДокументСсылка" , ДокументОбъект.Ссылка);
    
    Если ДокументОбъект[ИмяТабличнойЧасти].Количество() = 0 Тогда
    Запрос.Текст = СтрЗаменить(Запрос.Текст, "ГДЕ Док.Ссылка = &ДокументСсылка", "ГДЕ ЛОЖЬ");
    КонецЕсли;
    
    Возврат Запрос.Выполнить();
    
    КонецФункции // СформироватьЗапросПоТабличнойЧасти()
    
Похожие темы
  1. Троффи
    Ответов:
    0
    Просмотров:
    1.010
  2. bluntschi
    Ответов:
    7
    Просмотров:
    1.212
  3. Chloe
    Ответов:
    2
    Просмотров:
    3.220
  4. roofless
    Ответов:
    1
    Просмотров:
    511
  5. nickvv
    Ответов:
    1
    Просмотров:
    383
Загрузка...

Поделиться этой страницей