8.х Изменить значение

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем OIT, 8 июл 2009.

  1. TopicStarter Overlay
    OIT
    Offline

    OIT Опытный в 1С

    Регистрация:
    7 май 2007
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    Код:
    Процедура СформироватьОперации() Экспорт 
    ИскомыйДокумент=Документы.НачислениеЗарплатыРаботникамОрганизаций.НайтиПоНомеру("Январь.08", Дата(2009, 1, 31));
    ОбъектДок=ИскомыйДокумент.ПолучитьОбъект();
    Если Не ИскомыйДокумент.Пустая() Тогда
    Для каждого ТекущаяСтрока Из ИскомыйДокумент.ДополнительныеНачисления Цикл   ТекущаяСтрока.ВидРасчета=ПланыВидовРасчета.ДополнительныеНачисленияОрганизаций.НайтиПоКоду("00002");
    КонецЦикла;
    КонецЕсли;
    ОбъектДок.Записать();
    КонецПроцедуры
    
    Выдает сообщение"Поле объекта недоступно для записи(ВидРасчета)
    Благодарю Вас
  2. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    .. из ОбъектДок.ДополнительныеНачисления Цикл..

    Зачем тогда объект-то получали?..
  3. TopicStarter Overlay
    OIT
    Offline

    OIT Опытный в 1С

    Регистрация:
    7 май 2007
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    Спасибо

Поделиться этой страницей